Bug 505929 - plugins not loaded if firefox "restore"
plugins not loaded if firefox "restore"
Status: CLOSED DUPLICATE of bug 437596
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-14 15:01 EDT by Gene Czarcinski
Modified: 2009-08-06 09:03 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-06 09:03:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2009-06-14 15:01:54 EDT
Description of problem:

plugins for firefox are installed.

If the system is restarted with firefox running and a couple of tab are active (this may not be relevant).  After logining in and firefox (re) starts, doing "about:plugins" produces a message that plugins are not loaded.

If you quit that firefox and then start it up again, this doing "about:plugins" shows the list of loaded plugins.

Apparently, mozilla-plugin-config is not run if firefox is "restored" rather than just started.
Comment 1 Andrew Stitcher 2009-08-01 23:19:56 EDT
As a guess I'd say that the way that firefox gets restored by the session manager loses the mozilla directory.

Perhaps this is because what the session manager registers to restart firefox isn't the same thing as is used to start firefox from the command line or menu
Comment 2 Andrew Stitcher 2009-08-01 23:27:29 EDT
This is an annoying "fit and finish" desktop bug.

Because firefox is an application that will very commonly be left on the entire desktop session and hence be saved on logout.

So when it starts at the beginning of the next session but doesn't correctly display content that it displayed without error the previous session (say youtube) one is left puzzled, and feeling that the desktop is unreliable.

However remembering to quit firefox before logging just so that it doesn't start automatically but without all it features is equally annoying when one realises what the bug is.
Comment 3 Vinod Kutty 2009-08-02 12:07:19 EDT
Can the priority of this bug be increased? Hopefully it's not terribly hard to fix?

I'm constantly running into this firefox issue in F11, which compounds already poor session management capabilities in GNOME. This is basic functionality that should just work.

Additional info:

I noticed that I have one locally installed plugin in ~/.mozilla/plugins and this is the only one that shows up in about:plugins after a session restore.
Comment 4 Martin Stransky 2009-08-03 00:34:57 EDT
The patch has to be approved by upstream (mozilla.org). It may be included in some next 3.5 update.
Comment 5 Martin Stransky 2009-08-06 09:03:39 EDT

*** This bug has been marked as a duplicate of bug 437596 ***

Note You need to log in before you can comment on or make changes to this bug.