Bug 505945 - "No id element found" with yumex/yum
"No id element found" with yumex/yum
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
10
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-14 17:21 EDT by John Cox
Modified: 2009-08-21 06:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-21 06:28:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Cox 2009-06-14 17:21:59 EDT
Description of problem:
I get this when I run yumex:
14:04:48 : Error loading update metadata from updates 
14:04:48 :  --> No id element found 
and no updates. No updates with yum either
Version-Release number of selected component (if applicable):
current yumex 

How reproducible:
run yumex F10 package

Steps to Reproduce:
1.run yumex


Expected results:
no error and updates listed

Additional info

tried yum clean all, yum clean metadata and using the base url instead of mirrors.

I am also seeing this on my laptop with F11 installed as RC. No updates either.

Related thread on fedoraforum:
http://forums.fedoraforum.org/showthread.php?t=223402
Comment 1 Tim Lauridsen 2009-06-16 09:28:09 EDT
it is a problem with yum, if the update metadata xml is missing id elements, it is fixed in upstream yum, but has not been released yet.

http://yum.baseurl.org/gitweb?p=yum.git;a=blobdiff;f=yum/update_md.py;h=dc8f58562a76021a66bfa9f2e13b783f5dd84af6;hp=c15bae4fa8ff9f7290232278bc7277bedc805990;hb=4ec72c0bf27474c61d4295576b59fc95030e547c;hpb=3e0325de50a1b5194d04d82db61f1d4170e5c370

Note You need to log in before you can comment on or make changes to this bug.