Bug 505948 - Webcam "No valid video chain found." issue (0c45:62c0 Microdia Sonix)
Webcam "No valid video chain found." issue (0c45:62c0 Microdia Sonix)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-14 17:56 EDT by Valent Turkovic
Modified: 2009-09-04 08:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-04 08:32:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lsusb -v output (42.89 KB, text/plain)
2009-06-14 17:56 EDT, Valent Turkovic
no flags Details
from Ubuntu; modinfo uvcvideo (1.11 KB, application/octet-stream)
2009-06-15 11:28 EDT, Valent Turkovic
no flags Details
from Ubuntu; dmesg (186 bytes, application/octet-stream)
2009-06-15 11:30 EDT, Valent Turkovic
no flags Details
from Ubuntu; ls -al /dev/video0 (59 bytes, application/octet-stream)
2009-06-15 11:31 EDT, Valent Turkovic
no flags Details

  None (edit)
Description Valent Turkovic 2009-06-14 17:56:37 EDT
Created attachment 347868 [details]
lsusb -v output

Description of problem:

I have installed Fedora 11 on my sisters laptop with this webcam:
Bus 002 Device 002: ID 0c45:62c0 Microdia Sonix USB 2.0 Camera

Laptop is MSI MS-1221 (PR200):
https://wiki.ubuntu.com/LaptopTestingTeam/MSIPR200

It worked on Ubuntu 8.04 with System76 drivers package, but now on Fedora 11 it doesn't work. I checked your webpage and this usb model is under supported models.

This is what I get when I unload and load the uvcvideo module:

uvcvideo: Found UVC 1.00 device USB 2.0 Camera (0c45:62c0)
uvcvideo: No valid video chain found.
usbcore: registered new interface driver uvcvideo
USB Video Class driver (v0.1.0)

but cheese and mplayer don't see the webcam and there is no /dev/video0 device ;(

kernel is:
2.6.29.4-167.fc11.i586

lsusb output:
Bus 002 Device 002: ID 0c45:62c0 Microdia Sonix USB 2.0 Camera

Is there some caveat that I'm missing? Can I provide you with some more feedback? How can I get this webcam working?

Cheers!


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Valent Turkovic 2009-06-15 11:27:11 EDT
I have grabbed info from Ubuntu system and will post logs and other info here, as with uvcvideo module under Ubuntu 8.04 webcam works just fine.
Comment 2 Valent Turkovic 2009-06-15 11:28:40 EDT
Created attachment 347951 [details]
from Ubuntu; modinfo uvcvideo
Comment 3 Valent Turkovic 2009-06-15 11:30:09 EDT
Created attachment 347952 [details]
from Ubuntu; dmesg

This is a dmesg after loading uvcvideo module on Ubuntu. After loading this module webcam works under Ubuntu.
Comment 4 Valent Turkovic 2009-06-15 11:31:32 EDT
Created attachment 347953 [details]
from Ubuntu; ls -al /dev/video0

Under Ubuntu after loading uvcvideo module /dev/video0 device appears but under Fedora it does not :(
Comment 5 Valent Turkovic 2009-06-15 11:32:02 EDT
Do you need some more feedback from me?
Comment 6 Hans de Goede 2009-06-16 04:00:06 EDT
Hi Valent,

This bug has been re-assigned to me, as I'm the webcam expert within Fedora. Given
that this is a uvc cam, I've send a mail to the uvc driver author asking him
for help.
Comment 7 Valent Turkovic 2009-06-16 05:49:43 EDT
Thank you Hans,
I send mail to uvcvideo devel mailing list but I don't see it there (I registered for an account previously)...

If I can do anything more just say.
Comment 8 Valent Turkovic 2009-06-20 11:39:39 EDT
Hi, please check out the discussion from uvcvideo-devel mailing list:
https://lists.berlios.de/pipermail/linux-uvc-devel/2009-June/004880.html

I compiled vanilla 2.6.30 kernel and it still fails to create /dev/video0 device.

But there is a patch that fixes this:
http://bbs.archlinux.org/viewtopic.php?id=70685

I haven't been able to apply this patch to vanilla 2.6.30 kernel

And here is also an other upstream conversation:
http://developer.berlios.de/support/?func=detailsupport&support_id=102913&group_id=5681

Will this patch be applied in Fedora kernel?
Comment 9 Hans de Goede 2009-08-10 05:37:37 EDT
Valent,

The involved UVC descriptor parsing code seems to be rewritten in the rawhide kernels, can you please try your camera again with a rawhide kernel ?
Comment 10 Valent Turkovic 2009-09-03 16:07:04 EDT
I haven't tested the rawhide kernel, is there a Fedora 11 kernel that I can check out?

How can I testo Rawhide kernel? Is there a possibility of Fedora 11 getting wrong packages (rawhide ones) after I install Rawhide kernel?
Comment 11 Hans de Goede 2009-09-04 02:10:38 EDT
You can download the kernel here:
http://koji.fedoraproject.org/koji/buildinfo?buildID=130393

Then install from a terminal using:

rpm -ivh kernel-......rpm

It is important to use -ivh and *not* -Uvh, so that you keep your old kernel
to fall back to if things don't work.

This won't replace any F-11 packages.
Comment 12 Valent Turkovic 2009-09-04 07:50:44 EDT
I managed to do it before you posted this reply, I tried with:
yum update kernel* --enablerepo=rawhide

this also worked

But webcam still doesn't work :(

This is the message I get:

#
# dmesg -c
#
atkbd.c: Unknown key pressed (translated set 2, code 0xee on isa0060/serio0).
#
atkbd.c: Use 'setkeycodes e06e <keycode>' to make it known.
#
atkbd.c: Unknown key released (translated set 2, code 0xee on isa0060/serio0).
#
atkbd.c: Use 'setkeycodes e06e <keycode>' to make it known.
#
usb 2-1: new high speed USB device using ehci_hcd and address 4
#
usb 2-1: New USB device found, idVendor=0c45, idProduct=62c0
#
usb 2-1: New USB device strings: Mfr=2, Product=1, SerialNumber=3
#
usb 2-1: Product: USB 2.0 Camera
#
usb 2-1: Manufacturer: Sonix Technology Co., Ltd.
#
usb 2-1: SerialNumber: SN0001
#
usb 2-1: configuration #1 chosen from 1 choice
#
uvcvideo: Found UVC 1.00 device USB 2.0 Camera (0c45:62c0)
#
uvcvideo: No valid video chain found.
#
[root@taichii ~]#
#
[root@taichii ~]# uname -a
#
Linux taichii.localdomain 2.6.30 #1 SMP Sat Jun 20 19:03:55 CEST 2009 i686 i686 i386 GNU/Linux
Comment 13 Valent Turkovic 2009-09-04 08:06:03 EDT
# rpm -ivh kernel-2.6.31-0.199.rc8.git2.fc12.i686.rpm 
error: Failed dependencies:
	grubby >= 7.0.2-1 is needed by kernel-2.6.31-0.199.rc8.git2.fc12.i686

This fails, as there are dependencies that are in rawhide repos.
Comment 14 Valent Turkovic 2009-09-04 08:12:48 EDT
with kernel 2.6.30 (updated via yum update) when I remove and load module I get this:

# rmmod uvcvideo
# dmesg -c
# modprobe uvcvideo
# dmesg

uvcvideo: Found UVC 1.00 device USB 2.0 Camera (0c45:62c0)
uvcvideo: No valid video chain found.
usbcore: registered new interface driver uvcvideo
USB Video Class driver (v0.1.0)

"uname -a" says it is 2.6.30 kernel but yum installed package named "kernel-headers-2.6.31-0.199.rc8.git2.fc12.i686"
Comment 15 Valent Turkovic 2009-09-04 08:18:04 EDT
I forced kernel install, and will now try do test it again.

# rpm -ivh /home/valentt/Download/kernel-2.6.31-0.199.rc8.git2.fc12.i686.rpm --nodeps
Preparing...                ########################################### [100%]
   1:kernel                 ########################################### [100%]
Usage: new-kernel-pkg [-v] [--mkinitrd] [--rminitrd]
       [--initrdfile=<initrd-image>] [--depmod] [--rmmoddep]
       [--kernel-args=<args>] [--remove-args=<args>]
       [--banner=<banner>] [--multiboot=multiboot]
       [--mbargs=mbargs] [--make-default]
       <--install | --remove | --update | --rpmposttrans> <kernel-version>
       (ex: new-kernel-pkg --mkinitrd --depmod --install 2.4.7-2)
warning: %post(kernel-2.6.31-0.199.rc8.git2.fc12.i686) scriptlet failed, exit status 1
Comment 16 Hans de Goede 2009-09-04 08:21:15 EDT
(In reply to comment #15)
> I forced kernel install, and will now try do test it again.
> 
> # rpm -ivh /home/valentt/Download/kernel-2.6.31-0.199.rc8.git2.fc12.i686.rpm
> --nodeps
> Preparing...                ########################################### [100%]
>    1:kernel                 ########################################### [100%]
> Usage: new-kernel-pkg [-v] [--mkinitrd] [--rminitrd]
>        [--initrdfile=<initrd-image>] [--depmod] [--rmmoddep]
>        [--kernel-args=<args>] [--remove-args=<args>]
>        [--banner=<banner>] [--multiboot=multiboot]
>        [--mbargs=mbargs] [--make-default]
>        <--install | --remove | --update | --rpmposttrans> <kernel-version>
>        (ex: new-kernel-pkg --mkinitrd --depmod --install 2.4.7-2)
> warning: %post(kernel-2.6.31-0.199.rc8.git2.fc12.i686) scriptlet failed, exit
> status 1  

Ah, yes.

This is not a problem, you need to generate the initrd manually:
mkinitrd /boot/initrd-2.6.31-0.199.rc8.git2.fc12.i686.img \
  2.6.31-0.199.rc8.git2.fc12.i686

And then edit grub.conf to add an entry for this kernel (simply copy an
existing one and adjust the version)
Comment 17 Valent Turkovic 2009-09-04 08:26:42 EDT
I manually addded kernel in grub and after reboot with new kernel it webcam works!

Can this be fixed so it works with default fedora kernels?
Comment 18 Hans de Goede 2009-09-04 08:32:05 EDT
(In reply to comment #17)
> I manually addded kernel in grub and after reboot with new kernel it webcam
> works!
> 

Good to hear!

> Can this be fixed so it works with default fedora kernels?  

It will if / when 2.6.31 becomes available as an update for Fedora 11.

Note You need to log in before you can comment on or make changes to this bug.