Bug 505954 - preupgrade crash with traceback
preupgrade crash with traceback
Status: CLOSED DUPLICATE of bug 504826
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-14 19:35 EDT by Telsa Gwynne
Modified: 2014-01-21 18:09 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-15 14:23:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Telsa Gwynne 2009-06-14 19:35:54 EDT
Description of problem: preupgrade crashed

Ran preupgrade from the command line, it crashed, here is traceback. 

Traceback (most recent call last):
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 238, in on_assistant_apply
    self._do_main()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 257, in _do_main
    self.main_preupgrade()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 473, in main_preupgrade
    bootdevpath = bootpath_to_anacondapath(stage2_abs,UUID=True)
  File "/usr/lib/python2.5/site-packages/preupgrade/dev.py", line 86, in bootpath_to_anacondapath
    raise PUError, "/boot is on RAID device %s" % bootdev
NameError: global name 'PUError' is not defined
Comment 1 Will Woods 2009-06-15 14:23:36 EDT

*** This bug has been marked as a duplicate of bug 504826 ***

Note You need to log in before you can comment on or make changes to this bug.