Bug 505988 - selinux blocks named (bind) from acting as forwarder
selinux blocks named (bind) from acting as forwarder
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-15 01:20 EDT by Joseph D. Wagner
Modified: 2013-04-30 19:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-15 11:47:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joseph D. Wagner 2009-06-15 01:20:03 EDT
Description of problem:
SELinux blocks named from forwarding DNS queries to any of the IP's in "forwards."  If "forward only" is specified, DNS lookup will fail.

Workaround:
Switching SELinux to permissive mode and restarting named resolves the issue.


Summary:

SELinux is preventing polkit-resolve- (polkit_resolve_t) "getattr" fs_t.

Detailed Description:

[SELinux is in permissive mode, the operation would have been denied but was
permitted due to permissive mode.]

SELinux denied access requested by polkit-resolve-. It is not expected that this
access is required by polkit-resolve- and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Or you can disable
SELinux protection altogether. Disabling SELinux protection is not recommended.
Please file a bug report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi)
against this package.

Additional Information:

Source Context                system_u:system_r:polkit_resolve_t:s0-s0:c0.c1023
Target Context                system_u:object_r:fs_t:s0
Target Objects                / [ filesystem ]
Source                        polkit-resolve-
Source Path                   <Unknown>
Port                          <Unknown>
Host                          localhost.localdomain
Source RPM Packages           
Target RPM Packages           filesystem-2.4.21-1.fc11
Policy RPM                    selinux-policy-3.6.12-39.fc11
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     localhost.localdomain
Platform                      Linux localhost.localdomain
                              2.6.29.4-167.fc11.x86_64 #1 SMP Wed May 27
                              17:27:08 EDT 2009 x86_64 x86_64
Alert Count                   2
First Seen                    Sun 14 Jun 2009 10:10:31 PM PDT
Last Seen                     Sun 14 Jun 2009 10:10:31 PM PDT
Local ID                      054b4a23-495f-49c2-9cf1-f60a7a6f7b14
Line Numbers                  

Raw Audit Messages            

node=localhost.localdomain type=AVC msg=audit(1245042631.92:35104): avc:  denied  { getattr } for  pid=6595 comm="polkit-resolve-" name="/" dev=sdb5 ino=2 scontext=system_u:system_r:polkit_resolve_t:s0-s0:c0.c1023 tcontext=system_u:object_r:fs_t:s0 tclass=filesystem
Comment 1 Joseph D. Wagner 2009-06-15 11:47:42 EDT
I think I jumped the gun in reporting this.  named stopped working under additional testing.  I'll do further research to get to the bottom of my issue and refile if necessary.  (Hopefully, it's just a configuration issue.)

Note You need to log in before you can comment on or make changes to this bug.