This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 505991 - Fedora 11 flattened the Preferences Menu on an existing system
Fedora 11 flattened the Preferences Menu on an existing system
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: preferences-menus (Show other bugs)
11
All Linux
low Severity low
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-15 02:04 EDT by Richard Schwarting
Modified: 2009-06-16 22:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-16 22:08:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Schwarting 2009-06-15 02:04:43 EDT
Description of problem:

In Fedora 10, the Preferences menu was well organised.  Different preference applications were grouped together in their own groups.  After upgrading to Fedora 11, its now all gone flat and there is no grouping.  Consequently, the menu even needs to be scrolled now, and it's much harder to find what I'm looking for, since I have to sift through a few dozen items every time, and related ones aren't near one another.

I know I can edit the menu myself, but it's annoying that it happened in the same place and this will steal minutes of my time on each of my computers.  Ugh.  Perhaps flattening this was intentional (I hope not), but if it was, it would have been nice for it not to change the existing organisation when someone upgraded instead of doing a fresh install.

Version-Release number of selected component (if applicable):

How reproducible:
Always (at least on both upgraded Fedora 11 boxes)

Steps to Reproduce:
1. Click on System
2. Hover over Preferences
3. Behold the confusion!
  
Actual results:
All the preference applications appear in one, long, alphabetical list

Expected results:
Preference groups should be visible so we can quickly drill down to what we need rather than having to look at a long list.  It's almost like going from n^1/2 to n :(

Additional info:
The Control Center-type thing still seems to be mostly logically laid out.
Comment 1 Richard Schwarting 2009-06-15 02:43:00 EDT
Oh, I'll note that the Applications menu didn't have changes I had applied to it reverted, so I'm grateful that the application does generally preserve at least parts of the menu through an upgrade :)
Comment 2 Matthias Clasen 2009-06-16 22:08:06 EDT
We want to move away from deep menu hierarchies, which are problematic for many users.

If you want the hierarchical menus back, you can install the preferences-menus package.
Comment 3 Richard Schwarting 2009-06-16 22:34:38 EDT
Alright, thank you. 

I'm wondering whether it would have been better to install preferences-menus for users upgrading from Fedora 10 so their experience wouldn't seem to change.  

Ah well!  Sorry for consuming your time.

Note You need to log in before you can comment on or make changes to this bug.