Bug 505996 - yum needs to make sure pkg to be installed is not already obsoleted by installed pkg
yum needs to make sure pkg to be installed is not already obsoleted by instal...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
11
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On: 507702
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-15 03:15 EDT by johan
Modified: 2014-01-21 18:09 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-24 17:05:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
verbose yum output (209.48 KB, text/plain)
2009-06-22 11:01 EDT, Christoph Wickert
no flags Details

  None (edit)
Description johan 2009-06-15 03:15:55 EDT
When selecting xfce4-xmms-plugin x86_64 for install (observed in both yum and yumex)
will not show xfce4-xmms-plugin but instead shows xfce4-panel i586 to be installed, plus a slew of i586 dependencies.

Version-Release number of selected component (if applicable):
Select xfce4-xmms-plugin x86_64 0.5.1-3.fc11
Will install xfce4-panel i586 4.6.1-1.fc11

How reproducible:
consistent

Steps to Reproduce:
1. Have no i586 packages in system
3. Install xfce4-xmms-plugin
  
Actual results:
Wants to install xfce4-panel i586, plus all its dependencies
Comment 1 Christoph Wickert 2009-06-15 09:07:59 EDT
I'm afraid there is not much I can do here: xfce4-xmms-plugin is broken and so is it's successor xfce4-playercontrol-plugin. Upstream knows this and is clueless, I don't think the new developer actively maintains the  program. So I decided to remove xfce4-xmms-panel from F-11 and let xfce4-panel obsolete it. Now that audacious and most other players have their own systray icons there is not mich use for the plugin any longer.

So all I can do is to ask rel-eng to remove the xmms-plugin from the repo, this should have happened already before release. But I cannot fix the strange behavior of yum. Yum should simply refuse to install anything instead of the i586 panel.
Comment 2 Christoph Wickert 2009-06-21 19:49:42 EDT
Rel-eng denied to remove the package from the repo, so there is nothing I can do.

Reassigning to yum because IMO the bug is in yum. yum does not honor the arch of the obsoleted package and tries to install the 586 version of xfce4-panel instead.
Comment 3 James Antill 2009-06-22 01:41:07 EDT
"""Yum should simply refuse to install anything instead of the i586 panel. """

 Err, no.
 But it should install the xfce4-panel.x86_64 version ... does it not do that?
 What does "yum list xfce4-panel" say?
 What does "yum install xfce4-panel" say?
Comment 4 James Antill 2009-06-22 01:41:28 EDT
Oh, and what version of yum?
Comment 5 johan 2009-06-22 04:15:08 EDT
The main reason I can see is:
'Package xfce4-xmms-plugin is obsoleted by xfce4-panel, trying to install xfce4-panel-4.6.1-1.fc11.i586 instead'

I have tried your suggestions, and I hope the following screen clips answer them. The output of various commands:

>yum --version
3.2.23
  Installed: rpm-4.7.0-1.fc11.x86_64 at 2009-06-11 17:12
  Built    : Fedora Project at 2009-04-16 09:32
  Committed: Panu Matilainen <pmatilai@redhat.com> at 2009-04-16 12:00

  Installed: yum-3.2.23-3.fc11.noarch at 2009-06-16 18:02
  Built    : Fedora Project at 2009-05-20 22:29
  Committed: Seth Vidal <skvidal at fedoraproject.org> at 2009-05-20 12:00

  Installed: yum-metadata-parser-1.1.2-12.fc11.x86_64 at 2009-06-11 17:13
  Built    : Fedora Project at 2009-02-25 18:45
  Committed: Fedora Release Engineering <rel-eng@lists.fedoraproject.org> at 2009-02-25 22:00

>yum install xfce4-xmms-plugin
Loaded plugins: refresh-packagekit
livna                                                    | 2.4 kB     00:00     
rpmfusion-free-updates                                   | 3.8 kB     00:00     
rpmfusion-nonfree-updates                                | 3.8 kB     00:00     
updates/metalink                                         |  24 kB     00:00     
Setting up Install Process
Package xfce4-xmms-plugin is obsoleted by xfce4-panel, trying to install xfce4-panel-4.6.1-1.fc11.i586 instead
Resolving Dependencies
--> Running transaction check
---> Package xfce4-panel.i586 0:4.6.1-1.fc11 set to be updated
--> Processing Dependency: libwnck-1.so.22 for package: xfce4-panel-4.6.1-1.fc11.i586
--> Processing Dependency: libstartup-notification-1.so.0 for package: xfce4-panel-4.6.1-1.fc11.i586
--> Processing Dependency: libexo-0.3.so.0 for package: xfce4-panel-4.6.1-1.fc11.i586
--> Processing Dependency: libxfce4util.so.4 for package: xfce4-panel-4.6.1-1.fc11.i586
--> Processing Dependency: libxfcegui4.so.4 for package: xfce4-panel-4.6.1-1.fc11.i586
--> Running transaction check
---> Package exo.i586 0:0.3.101-1.fc11 set to be updated
--> Processing Dependency: libnotify.so.1 for package: exo-0.3.101-1.fc11.i586
--> Processing Dependency: libhal-storage.so.1 for package: exo-0.3.101-1.fc11.i586
--> Processing Dependency: libhal.so.1 for package: exo-0.3.101-1.fc11.i586
---> Package libwnck.i586 0:2.26.1-1.fc11 set to be updated
--> Processing Dependency: libXRes.so.1 for package: libwnck-2.26.1-1.fc11.i586
---> Package libxfce4util.i586 0:4.6.1-1.fc11 set to be updated
---> Package libxfcegui4.i586 0:4.6.1-1.fc11 set to be updated
--> Processing Dependency: libglade-2.0.so.0 for package: libxfcegui4-4.6.1-1.fc11.i586
--> Processing Dependency: libICE.so.6 for package: libxfcegui4-4.6.1-1.fc11.i586
--> Processing Dependency: libxfconf-0.so.2 for package: libxfcegui4-4.6.1-1.fc11.i586
--> Processing Dependency: libdbus-glib-1.so.2 for package: libxfcegui4-4.6.1-1.fc11.i586
--> Processing Dependency: libSM.so.6 for package: libxfcegui4-4.6.1-1.fc11.i586
---> Package startup-notification.i586 0:0.9-6.fc11 set to be updated
--> Running transaction check
---> Package dbus-glib.i586 0:0.80-2.fc11 set to be updated
---> Package hal-libs.i586 0:0.5.12-26.20090226git.fc11 set to be updated
---> Package libICE.i586 0:1.0.4-7.fc11 set to be updated
---> Package libSM.i586 0:1.1.0-4.fc11 set to be updated
---> Package libXres.i586 0:1.0.3-6.fc11 set to be updated
---> Package libglade2.i586 0:2.6.4-1.fc11 set to be updated
---> Package libnotify.i586 0:0.4.5-2.fc11 set to be updated
---> Package xfconf.i586 0:4.6.1-1.fc11 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                 Arch    Version                        Repository
                                                                           Size
================================================================================
Installing:
 xfce4-panel             i586    4.6.1-1.fc11                   fedora    548 k
Installing for dependencies:
 dbus-glib               i586    0.80-2.fc11                    fedora    178 k
 exo                     i586    0.3.101-1.fc11                 fedora    1.2 M
 hal-libs                i586    0.5.12-26.20090226git.fc11     fedora     70 k
 libICE                  i586    1.0.4-7.fc11                   fedora     55 k
 libSM                   i586    1.1.0-4.fc11                   fedora     27 k
 libXres                 i586    1.0.3-6.fc11                   fedora     15 k
 libglade2               i586    2.6.4-1.fc11                   fedora     66 k
 libnotify               i586    0.4.5-2.fc11                   fedora     36 k
 libwnck                 i586    2.26.1-1.fc11                  fedora    403 k
 libxfce4util            i586    4.6.1-1.fc11                   fedora    103 k
 libxfcegui4             i586    4.6.1-1.fc11                   fedora    309 k
 startup-notification    i586    0.9-6.fc11                     fedora     39 k
 xfconf                  i586    4.6.1-1.fc11                   fedora    122 k

Transaction Summary
================================================================================
Install     14 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 3.2 M
Is this ok [y/N]: N


>yum list xfce4-panel
Loaded plugins: refresh-packagekit
Installed Packages
xfce4-panel.x86_64                    4.6.1-1.fc11                     installed
Available Packages
xfce4-panel.i586                      4.6.1-1.fc11                     fedora


>yum install xfce4-panel
Loaded plugins: refresh-packagekit
Setting up Install Process
Package xfce4-panel-4.6.1-1.fc11.x86_64 already installed and latest version
Nothing to do
Comment 6 seth vidal 2009-06-22 09:37:02 EDT
could you run:

yum list obsoletes

please?
Comment 7 Christoph Wickert 2009-06-22 09:52:41 EDT
yum list obsoletes returns nothing here.
Comment 8 seth vidal 2009-06-22 10:27:40 EDT
So there is nothing obsoleting anything - this looks just like an update that is working correctly, given the pkgs in the repo - but the problem is the pkgs in the repo.


Can you attach the original run output with more information?

yum -d 9 install xfce4-xmms-plugin

I'd like to make sure i'm seeing all the details.
Comment 9 Christoph Wickert 2009-06-22 11:00:50 EDT
(In reply to comment #8)
> So there is nothing obsoleting anything 

This cannot be true. From the spec:

# xfce4-xmms-plugin isn't in F11
Provides: xfce4-xmms-plugin = 0.5.1-4
Obsoletes: xfce4-xmms-plugin <= 0.5.1-3.fc11

I also have a couple of other packages installed that obsolete others, e. .g lxsession 0.3.0 correctly obsoletes lxsession-lite 0.3.6.
Comment 10 Christoph Wickert 2009-06-22 11:01:38 EDT
Created attachment 348925 [details]
verbose yum output
Comment 11 seth vidal 2009-06-22 11:10:58 EDT
what ver of xfce4-xmms-plugin do you currently have installed?

and yum list obsoletes doesn't list things you have installed which obsolete other pkgs - it only lists available packages which obsolete something you currentlyhave installed.
Comment 12 seth vidal 2009-06-22 11:16:46 EDT
okay. the issue here is

Package xfce4-xmms-plugin is obsoleted by xfce4-panel, trying to install xfce4-panel-4.6.1-1.fc11.i586 instead

so you are asking it to install a pkg which is not installed but which IS obsoleted by a pkg that's in the repo.

the yum issue is that it is not noticing that an already installed pkg has obsoleted the requested pkg already and therefore yum doesn't need to do anything other than report that.
Comment 13 Christoph Wickert 2009-06-22 11:22:21 EDT
(In reply to comment #11)
> what ver of xfce4-xmms-plugin do you currently have installed?

none, since it it not installable.

(In reply to comment #12)
> so you are asking it to install a pkg which is not installed but which IS
> obsoleted by a pkg that's in the repo.

Exactly

> the yum issue is that it is not noticing that an already installed pkg has
> obsoleted the requested pkg already and therefore yum doesn't need to do
> anything other than report that.  

Ok, but we do agree that this is a bug in yum? yum should simply refuse to install anything and return that the package is obsoleted by xfce4-panel.
Comment 14 seth vidal 2009-06-22 11:40:05 EDT
I have no problem calling this a yum bug, yeah.
Comment 15 johan 2009-06-22 12:03:12 EDT
>yum list obsoletes
Loaded plugins: refresh-packagekit
livna                                                    | 2.4 kB     00:00     
rpmfusion-free-updates                                   | 3.8 kB     00:00     
rpmfusion-nonfree-updates                                | 3.8 kB     00:00     
updates/metalink                                         |  23 kB     00:00     

(-d 9 means verbose right, verbose it is... )
(needed to cut 'unnecessary' parts due to bugzilla limit of 65k char content)

>yum -d 9 install xfce4-xmms-plugin
Not loading "blacklist" plugin, as it is disabled
Loading "refresh-packagekit" plugin
Not loading "whiteout" plugin, as it is disabled
Config time: 0.071
Yum Version: 3.2.23
COMMAND: yum -d 9 install xfce4-xmms-plugin 
Installroot: /
Ext Commands:

   xfce4-xmms-plugin
Setting up Package Sacks
pkgsack time: 0.007
Reading Local RPMDB
rpmdb time: 0.004
Setting up Install Process
Building updates object
up:Obs Init time: 0.102
putting libfontenc in complex update
putting postgresql-libs in complex update
putting libxfce4util in complex update
putting gstreamer-plugins-flumpegdemux in complex update
putting redland in complex update
putting libical in complex update
putting libmpeg2 in complex update
putting xfce4-doc in complex update
putting libtextcat in complex update
putting libgssglue in complex update
putting libcroco in complex update
putting libidn in complex update
putting libmng in complex update
putting libnfnetlink in complex update
putting device-mapper-devel in complex update
putting libmtp in complex update
putting gnome-keyring-pam in complex update
putting libbinio in complex update
putting gnome-panel-libs in complex update
putting fipscheck in complex update
putting libspectre in complex update
putting libudev0 in complex update
putting plymouth-libs in complex update
putting gstreamer-plugins-bad in complex update
putting anthy in complex update
putting libXt in complex update
putting libebml in complex update
putting parted in complex update
putting gnome-menus in complex update
putting hal-libs in complex update
putting libisofs in complex update
putting gnome-desktop in complex update
putting libiec61883 in complex update
putting readline in complex update
putting alsa-plugins-pulseaudio in complex update
putting libbonoboui in complex update
putting hplip-libs in complex update
putting libgpod in complex update
putting libicu in complex update
putting libsoup in complex update
putting gnome-vfs2 in complex update
putting gpgme in complex update
putting e2fsprogs-devel in complex update
putting xorg-x11-drv-intel in complex update
putting lzma-libs in complex update
putting libkate in complex update
putting libgphoto2 in complex update
putting nspr in complex update
putting twolame-libs in complex update
putting imlib in complex update
putting libgsf in complex update
putting nash in complex update
putting glibc-devel in complex update
putting boost in complex update
putting libpcap in complex update
putting libselinux-devel in complex update
putting libass in complex update
putting xfce4-settings in complex update
putting pciutils-libs in complex update
putting lirc-libs in complex update
putting libproxy in complex update
putting enca in complex update
putting libgnomeui in complex update
putting perl in complex update
putting libiptcdata in complex update
putting libXpm in complex update
putting freeglut in complex update
putting libasyncns in complex update
putting mesa-libGL in complex update
putting libXmu in complex update
putting eet in complex update
putting directfb in complex update
putting liblqr-1 in complex update
putting webkitgtk in complex update
putting rpm-libs in complex update
putting libvncserver in complex update
putting xfdesktop in complex update
putting xfce4-sensors-plugin in complex update
putting libxfcegui4 in complex update
putting gtk-nodoka-engine in complex update
putting tokyocabinet in complex update
putting ibus-libs in complex update
putting gstreamer-plugins-bad in complex update
putting libxfce4menu in complex update
putting libshout in complex update
putting sox in complex update
putting libatasmart in complex update
putting libedit in complex update
putting xfce4-mixer in complex update
putting enchant in complex update
putting libsepol-devel in complex update
putting samba-common in complex update
putting libdvdnav in complex update
putting ntfsprogs in complex update
putting librsvg2 in complex update
putting gstreamer in complex update
putting libdc1394 in complex update
putting libgnome in complex update
putting aalib-libs in complex update
putting libsemanage in complex update
putting libssh2 in complex update
putting clamav-lib in complex update
putting imsettings-libs in complex update
putting hesiod in complex update
putting pam in complex update
putting json-glib in complex update
putting libmowgli in complex update
putting libxfce4util in complex update
putting qt3 in complex update
putting DeviceKit in complex update
putting PackageKit-glib in complex update
putting ImageMagick in complex update
putting vte in complex update
putting nss in complex update
putting netpbm in complex update
putting cdparanoia-libs in complex update
putting hunspell in complex update
putting brasero-libs in complex update
putting metacity in complex update
putting soundtouch in complex update
putting pulseaudio-libs in complex update
putting pulseaudio-utils in complex update
putting nss_db in complex update
putting imlib2 in complex update
putting PackageKit-gtk-module in complex update
putting libnetfilter_conntrack in complex update
putting pakchois in complex update
putting libcddb in complex update
putting cryptsetup-luks in complex update
putting gmyth in complex update
putting xfce4-panel in complex update
putting libdv in complex update
putting setools-libs in complex update
putting elfutils-libelf in complex update
putting libfreebob in complex update
putting libieee1284 in complex update
putting libXxf86vm in complex update
putting alsa-lib in complex update
putting libmp4v2 in complex update
putting fprintd-pam in complex update
putting libaio in complex update
putting schroedinger in complex update
putting mpfr in complex update
putting mesa-libGLU in complex update
putting SDL_image in complex update
putting libsamplerate in complex update
putting hyphen in complex update
putting libXdmcp in complex update
putting libzip in complex update
putting nss_compat_ossl in complex update
putting bluez-libs in complex update
putting GConf2 in complex update
putting poppler in complex update
putting libsndfile in complex update
putting bzip2-libs in complex update
putting libnl in complex update
putting xfce4-panel in complex update
putting gnutls-devel in complex update
putting xfsprogs in complex update
putting libconfig in complex update
putting libstdc++-devel in complex update
putting ntfs-3g in complex update
putting exo in complex update
putting wireless-tools in complex update
putting libtalloc in complex update
putting startup-notification in complex update
putting SDL in complex update
putting libfprint in complex update
putting soprano in complex update
putting gmp in complex update
putting libICE in complex update
putting jack-audio-connection-kit in complex update
putting libvisual in complex update
putting ncurses-libs in complex update
putting fipscheck-lib in complex update
putting libusb1 in complex update
putting exiv2-libs in complex update
putting Thunar in complex update
putting m17n-lib in complex update
putting libtirpc in complex update
putting strigi-libs in complex update
putting zvbi in complex update
putting xulrunner in complex update
putting gdm in complex update
putting exempi in complex update
putting valgrind in complex update
putting xfce-utils in complex update
putting pulseaudio-libs-glib2 in complex update
putting libxfce4menu in complex update
putting sane-backends-libs in complex update
putting mcs-libs in complex update
putting mjpegtools-libs in complex update
putting libspiro in complex update
putting Terminal in complex update
putting redhat-lsb in complex update
putting libcdio in complex update
putting pth in complex update
putting avahi-glib in complex update
putting libsidplay in complex update
putting libraw1394 in complex update
putting libxkbfile in complex update
putting ustr in complex update
putting dirac-libs in complex update
putting gettext-libs in complex update
putting gdbm in complex update
putting libchewing in complex update
putting recode in complex update
putting pam_pkcs11 in complex update
putting cloog-ppl in complex update
putting libsepol in complex update
putting libXScrnSaver in complex update
putting exo in complex update
putting libXres in complex update
putting qzion in complex update
putting libwmf in complex update
putting libmusicbrainz in complex update
putting dbus-qt in complex update
putting libgcrypt-devel in complex update
putting faac in complex update
putting lcms-libs in complex update
putting tcp_wrappers-libs in complex update
putting gegl in complex update
putting phonon-backend-xine in complex update
putting DeviceKit-power in complex update
putting opencv in complex update
putting libwmf-lite in complex update
putting xvidcore in complex update
putting libburn in complex update
putting pam_passwdqc in complex update
putting libXxf86misc in complex update
putting lash in complex update
putting libwnck in complex update
putting libXv in complex update
putting lame-libs in complex update
putting cyrus-sasl-lib in complex update
putting qedje in complex update
putting ffmpeg-libs in complex update
putting rasqal in complex update
putting libv4l in complex update
putting xcb-util in complex update
putting OpenEXR-libs in complex update
putting gettext in complex update
putting gnome-keyring in complex update
putting elfutils-libs in complex update
putting gtk2-engines in complex update
putting libgail-gnome in complex update
putting xine-lib-pulseaudio in complex update
putting lzo-minilzo in complex update
putting gstreamer-plugins-good in complex update
putting libmikmod in complex update
putting pcre in complex update
putting gnome-disk-utility-libs in complex update
putting PolicyKit in complex update
putting slang in complex update
putting sqlite in complex update
putting at-spi in complex update
putting gutenprint in complex update
putting libSM in complex update
putting pam_krb5 in complex update
putting libtool-ltdl in complex update
putting x264-libs in complex update
putting libdvbpsi in complex update
putting dbus-glib in complex update
putting gsm in complex update
putting PackageKit-qt in complex update
putting libvolume_id in complex update
putting gd in complex update
putting libupnp in complex update
putting lua in complex update
putting graphviz in complex update
putting libnotify in complex update
putting wavpack in complex update
putting libdmx in complex update
putting zlib-devel in complex update
putting libutempter in complex update
putting newt in complex update
putting audiofile in complex update
putting libmpcdec in complex update
putting libart_lgpl in complex update
putting libdvdread in complex update
putting poppler-glib in complex update
putting libXaw in complex update
putting xfconf in complex update
putting libsmbclient in complex update
putting libksba in complex update
putting xine-lib in complex update
putting libpciaccess in complex update
putting rarian in complex update
putting libmusicbrainz3 in complex update
putting libavc1394 in complex update
putting a2ps in complex update
putting libgweather in complex update
putting libgnomekbd in complex update
putting gnome-media-libs in complex update
putting cyrus-sasl-plain in complex update
putting gvfs in complex update
putting nas-libs in complex update
putting libtimidity in complex update
putting python-libs in complex update
putting minizip in complex update
putting libglade2 in complex update
putting libpaper in complex update
putting libopenraw in complex update
putting pam_ccreds in complex update
putting libXxf86dga in complex update
putting babl in complex update
putting NetworkManager-glib in complex update
putting xfwm4 in complex update
putting gpm-libs in complex update
putting audacious-libs in complex update
putting phonon in complex update
putting nfs-utils-lib in complex update
putting gettext-devel in complex update
putting gstreamer-plugins-bad-extras in complex update
putting fuse-libs in complex update
putting libsexy in complex update
putting celt in complex update
putting ppl in complex update
putting libarchive in complex update
putting libffi in complex update
putting qt-x11 in complex update
putting faad2-libs in complex update
putting libIDL in complex update
putting libcdaudio in complex update
putting openjpeg-libs in complex update
putting ORBit2 in complex update
putting a52dec in complex update
putting lm_sensors in complex update
putting pam_smb in complex update
putting fftw in complex update
putting libopenraw-gnome in complex update
putting libvorbis in complex update
putting libdca in complex update
putting geoclue in complex update
putting sg3_utils-libs in complex update
putting krb5-devel in complex update
putting libXfont in complex update
putting file-libs in complex update
putting control-center in complex update
putting perl-libs in complex update
putting libevent in complex update
putting samba-winbind in complex update
putting openssl in complex update
putting PolicyKit-gnome-libs in complex update
putting paps-libs in complex update
putting numactl in complex update
putting binutils in complex update
putting net-snmp-libs in complex update
putting libcurl in complex update
putting xorg-x11-drv-openchrome in complex update
putting libusb in complex update
putting qt in complex update
putting libbonobo in complex update
putting speex in complex update
putting lftp in complex update
putting libcanberra-gtk2 in complex update
putting fluidsynth-libs in complex update
putting raptor in complex update
putting ilmbase in complex update
putting libgnomecanvas in complex update
putting vlc-core in complex update
putting mesa-dri-drivers in complex update
putting libgxim in complex update
putting libgomp in complex update
putting libfwbuilder in complex update
putting clucene-core in complex update
putting libtdb in complex update
putting gtkhtml2 in complex update
putting glibc in complex update
putting iptables in complex update
putting libXvMC in complex update
putting libdiscid in complex update
putting sendmail in complex update
putting db4 in complex update
putting libmatroska in complex update
putting libvoikko in complex update
putting live555 in complex update
putting taglib in complex update
putting libofa in complex update
putting linux-atm-libs in complex update
putting xfce4-session in complex update
putting liboil in complex update
putting kpathsea in complex update
putting ConsoleKit-libs in complex update
putting libmad in complex update
putting libwpd in complex update
putting keyutils-libs-devel in complex update
putting libbeagle in complex update
putting libmpd in complex update
putting libmms in complex update
putting PyQt4 in complex update
putting libid3tag in complex update
putting xosd in complex update
putting xfprint in complex update
putting libexif in complex update
putting giflib in complex update
putting openssl in complex update
putting bind-libs in complex update
putting libtar in complex update
putting libogg in complex update
putting unique in complex update
putting wildmidi-libs in complex update
putting libmodplug in complex update
putting gtkimageview in complex update
putting evince in complex update
putting libxfcegui4 in complex update
putting libao in complex update
putting libhangul in complex update
putting lockdev in complex update
putting libdrm in complex update
putting gstreamer-plugins-bad-extras in complex update
putting flac in complex update
putting libtheora in complex update
putting libxklavier in complex update
putting libsysfs in complex update
putting gimp-libs in complex update
putting libxslt in complex update
putting gstreamer-plugins-base in complex update
putting glib in complex update
putting gtk+ in complex update
putting libXtst in complex update
putting ghostscript in complex update
putting cups-devel in complex update
putting evolution-data-server in complex update
putting libmalaga in complex update
putting libacl in complex update
putting Thunar in complex update
putting linuxwacom in complex update
putting cracklib in complex update
putting libnxml in complex update
putting fribidi in complex update
putting nss_ldap in complex update
putting device-mapper-libs in complex update
putting libuser in complex update
putting xfce4-appfinder in complex update
putting openldap in complex update
putting libgpg-error-devel in complex update
putting libgfortran in complex update
putting libgcj in complex update
putting libx86 in complex update
putting libcaca in complex update
putting pygobject2 in complex update
putting nautilus-extensions in complex update
putting libcanberra in complex update
putting mysql-libs in complex update
putting neon in complex update
putting xfconf in complex update
putting libquicktime in complex update
processing libfontenc
processing libfontenc
processing postgresql-libs
processing postgresql-libs
processing libxfce4util
processing libxfce4util
..cut..
processing libquicktime
processing libquicktime
up:simple updates time: 0.183
up:obs time: 0.005
up:condense time: 0.000
updates time: 1.648
Package xfce4-xmms-plugin is obsoleted by xfce4-panel, trying to install xfce4-panel-4.6.1-1.fc11.i586 instead
Resolving Dependencies
--> Running transaction check
---> Package xfce4-panel.i586 0:4.6.1-1.fc11 set to be updated
Checking deps for xfce4-panel.i586 0-4.6.1-1.fc11 - u
looking for (u'libxfcegui4', u'GE', (u'0', u'4.6.1', None)) as a requirement of xfce4-panel.i586 0-4.6.1-1.fc11 - u
looking for (u'libc.so.6(GLIBC_2.4)', None, (None, None, None)) as a requirement of xfce4-panel.i586 0-4.6.1-1.fc11 - u
looking for (u'libglib-2.0.so.0', None, (None, None, None)) as a requirement of xfce4-panel.i586 0-4.6.1-1.fc11 - u
looking for (u'libm.so.6(GLIBC_2.0)', None, (None, None, None)) as a requirement of xfce4-panel.i586 0-4.6.1-1.fc11 - u
looking for (u'libwnck-1.so.22', None, (None, None, None)) as a requirement of xfce4-panel.i586 0-4.6.1-1.fc11 - u
looking for (u'libpangocairo-1.0.so.0', None, (None, None, None)) as a requirement of xfce4-panel.i586 0-4.6.1-1.fc11 - u
looking for (u'libc.so.6(GLIBC_2.1.3)', None, (None, None, None)) as a requirement of xfce4-panel.i586 0-4.6.1-1.fc11 - u
looking for (u'libstartup-notification-1.so.0', None, (None, None, None)) as a requirement of xfce4-panel.i586 0-4.6.1-1.fc11 - u
looking for (u'libexo-0.3.so.0', None, (None, None, None)) as a requirement of xfce4-panel.i586 0-4.6.1-1.fc11 - u
looking for (u'libfontconfig.so.1', None, (None, None, None)) as a requirement of xfce4-panel.i586 0-4.6.1-1.fc11 - u
looking for (u'/bin/sh', None, (None, None, None)) as a requirement of xfce4-panel.i586 0-4.6.1-1.fc11 - u
looking for (u'libgdk_pixbuf-2.0.so.0', None, (None, None, None)) as a requirement of xfce4-panel.i586 0-4.6.1-1.fc11 - u
looking for (u'libm.so.6', None, (None, None, None)) as a requirement of xfce4-panel.i586 0-4.6.1-1.fc11 - u
looking for (u'libpangoft2-1.0.so.0', None, (None, None, None)) as a requirement of xfce4-panel.i586 0-4.6.1-1.fc11 - u
looking for (u'libxfce4util.so.4', None, (None, None, None)) as a requirement of xfce4-panel.i586 0-4.6.1-1.fc11 - u
looking for (u'libc.so.6', None, (None, None, None)) as a requirement of xfce4-panel.i586 0-4.6.1-1.fc11 - u
looking for (u'libfreetype.so.6', None, (None, None, None)) as a requirement of xfce4-panel.i586 0-4.6.1-1.fc11 - u
looking for (u'mousepad', None, (None, None, None)) as a requirement of xfce4-panel.i586 0-4.6.1-1.fc11 - u
looking for (u'/bin/sh', None, (None, None, None)) as a requirement of xfce4-panel.i586 0-4.6.1-1.fc11 - u
looking for (u'libgdk-x11-2.0.so.0', None, (None, None, None)) as a requirement of xfce4-panel.i586 0-4.6.1-1.fc11 - u
looking for (u'rtld(GNU_HASH)', None, (None, None, None)) as a requirement of xfce4-panel.i586 0-4.6.1-1.fc11 - u
looking for (u'libgio-2.0.so.0', None, (None, None, None)) as a requirement of xfce4-panel.i586 0-4.6.1-1.fc11 - u
looking for (u'libgtk-x11-2.0.so.0', None, (None, None, None)) as a requirement of xfce4-panel.i586 0-4.6.1-1.fc11 - u
looking for (u'libc.so.6(GLIBC_2.0)', None, (None, None, None)) as a requirement of xfce4-panel.i586 0-4.6.1-1.fc11 - u
looking for (u'libatk-1.0.so.0', None, (None, None, None)) as a requirement of xfce4-panel.i586 0-4.6.1-1.fc11 - u
looking for (u'Terminal', None, (None, None, None)) as a requirement of xfce4-panel.i586 0-4.6.1-1.fc11 - u
looking for (u'libX11.so.6', None, (None, None, None)) as a requirement of xfce4-panel.i586 0-4.6.1-1.fc11 - u
looking for (u'libcairo.so.2', None, (None, None, None)) as a requirement of xfce4-panel.i586 0-4.6.1-1.fc11 - u
looking for (u'libxfcegui4.so.4', None, (None, None, None)) as a requirement of xfce4-panel.i586 0-4.6.1-1.fc11 - u
looking for (u'xfce4-doc', None, (None, None, None)) as a requirement of xfce4-panel.i586 0-4.6.1-1.fc11 - u
looking for (u'libpango-1.0.so.0', None, (None, None, None)) as a requirement of xfce4-panel.i586 0-4.6.1-1.fc11 - u
looking for (u'libgmodule-2.0.so.0', None, (None, None, None)) as a requirement of xfce4-panel.i586 0-4.6.1-1.fc11 - u
looking for (u'libgobject-2.0.so.0', None, (None, None, None)) as a requirement of xfce4-panel.i586 0-4.6.1-1.fc11 - u
xfce4-panel-4.6.1-1.fc11.i586 requires: libwnck-1.so.22
--> Processing Dependency: libwnck-1.so.22 for package: xfce4-panel-4.6.1-1.fc11.i586
Searching pkgSack for dep: libwnck-1.so.22
Potential match for libwnck-1.so.22 from libwnck-2.26.1-1.fc11.i586
Matched libwnck-2.26.1-1.fc11.i586 to require for libwnck-1.so.22
TSINFO: Marking libwnck-2.26.1-1.fc11.i586 as install for xfce4-panel-4.6.1-1.fc11.i586
xfce4-panel-4.6.1-1.fc11.i586 requires: libstartup-notification-1.so.0
--> Processing Dependency: libstartup-notification-1.so.0 for package: xfce4-panel-4.6.1-1.fc11.i586
Searching pkgSack for dep: libstartup-notification-1.so.0
Potential match for libstartup-notification-1.so.0 from startup-notification-0.9-6.fc11.i586
Matched startup-notification-0.9-6.fc11.i586 to require for libstartup-notification-1.so.0
TSINFO: Marking startup-notification-0.9-6.fc11.i586 as install for xfce4-panel-4.6.1-1.fc11.i586
xfce4-panel-4.6.1-1.fc11.i586 requires: libexo-0.3.so.0
--> Processing Dependency: libexo-0.3.so.0 for package: xfce4-panel-4.6.1-1.fc11.i586
Searching pkgSack for dep: libexo-0.3.so.0
Potential match for libexo-0.3.so.0 from exo-0.3.101-1.fc11.i586
Matched exo-0.3.101-1.fc11.i586 to require for libexo-0.3.so.0
Potential match for libexo-0.3.so.0 from exo-0.3.101-1.fc11.i586
Matched exo-0.3.101-1.fc11.i586 to require for libexo-0.3.so.0
TSINFO: Marking exo-0.3.101-1.fc11.i586 as install for xfce4-panel-4.6.1-1.fc11.i586
xfce4-panel-4.6.1-1.fc11.i586 requires: libxfce4util.so.4
--> Processing Dependency: libxfce4util.so.4 for package: xfce4-panel-4.6.1-1.fc11.i586
Searching pkgSack for dep: libxfce4util.so.4
Potential match for libxfce4util.so.4 from libxfce4util-4.6.1-1.fc11.i586
Matched libxfce4util-4.6.1-1.fc11.i586 to require for libxfce4util.so.4
Potential match for libxfce4util.so.4 from libxfce4util-4.6.1-1.fc11.i586
Matched libxfce4util-4.6.1-1.fc11.i586 to require for libxfce4util.so.4
TSINFO: Marking libxfce4util-4.6.1-1.fc11.i586 as install for xfce4-panel-4.6.1-1.fc11.i586
xfce4-panel-4.6.1-1.fc11.i586 requires: libxfcegui4.so.4
--> Processing Dependency: libxfcegui4.so.4 for package: xfce4-panel-4.6.1-1.fc11.i586
Searching pkgSack for dep: libxfcegui4.so.4
Potential match for libxfcegui4.so.4 from libxfcegui4-4.6.1-1.fc11.i586
Matched libxfcegui4-4.6.1-1.fc11.i586 to require for libxfcegui4.so.4
Potential match for libxfcegui4.so.4 from libxfcegui4-4.6.1-1.fc11.i586
Matched libxfcegui4-4.6.1-1.fc11.i586 to require for libxfcegui4.so.4
TSINFO: Marking libxfcegui4-4.6.1-1.fc11.i586 as install for xfce4-panel-4.6.1-1.fc11.i586
--> Running transaction check
---> Package exo.i586 0:0.3.101-1.fc11 set to be updated
Checking deps for exo.i586 0-0.3.101-1.fc11 - u
looking for (u'dbus-glib', u'GE', (u'0', u'0.22', None)) as a requirement of exo.i586 0-0.3.101-1.fc11 - u
looking for (u'libnotify.so.1', None, (None, None, None)) as a requirement of exo.i586 0-0.3.101-1.fc11 - u
looking for (u'libc.so.6(GLIBC_2.3.4)', None, (None, None, None)) as a requirement of exo.i586 0-0.3.101-1.fc11 - u
looking for (u'libc.so.6(GLIBC_2.4)', None, (None, None, None)) as a requirement of exo.i586 0-0.3.101-1.fc11 - u
looking for (u'libc.so.6(GLIBC_2.2.3)', None, (None, None, None)) as a requirement of exo.i586 0-0.3.101-1.fc11 - u
looking for (u'libgthread-2.0.so.0', None, (None, None, None)) as a requirement of exo.i586 0-0.3.101-1.fc11 - u
looking for (u'libpangocairo-1.0.so.0', None, (None, None, None)) as a requirement of exo.i586 0-0.3.101-1.fc11 - u
looking for (u'libc.so.6(GLIBC_2.1.3)', None, (None, None, None)) as a requirement of exo.i586 0-0.3.101-1.fc11 - u
looking for (u'libcairo.so.2', None, (None, None, None)) as a requirement of exo.i586 0-0.3.101-1.fc11 - u
looking for (u'libfontconfig.so.1', None, (None, None, None)) as a requirement of exo.i586 0-0.3.101-1.fc11 - u
looking for (u'/bin/sh', None, (None, None, None)) as a requirement of exo.i586 0-0.3.101-1.fc11 - u
looking for (u'libgdk_pixbuf-2.0.so.0', None, (None, None, None)) as a requirement of exo.i586 0-0.3.101-1.fc11 - u
looking for (u'perl(URI::Escape)', None, (None, None, None)) as a requirement of exo.i586 0-0.3.101-1.fc11 - u
looking for (u'libc.so.6(GLIBC_2.2)', None, (None, None, None)) as a requirement of exo.i586 0-0.3.101-1.fc11 - u
looking for (u'libpangoft2-1.0.so.0', None, (None, None, None)) as a requirement of exo.i586 0-0.3.101-1.fc11 - u
looking for (u'libc.so.6(GLIBC_2.1)', None, (None, None, None)) as a requirement of exo.i586 0-0.3.101-1.fc11 - u
looking for (u'libc.so.6', None, (None, None, None)) as a requirement of exo.i586 0-0.3.101-1.fc11 - u
looking for (u'libhal-storage.so.1', None, (None, None, None)) as a requirement of exo.i586 0-0.3.101-1.fc11 - u
looking for (u'libfreetype.so.6', None, (None, None, None)) as a requirement of exo.i586 0-0.3.101-1.fc11 - u
looking for (u'libpthread.so.0(GLIBC_2.0)', None, (None, None, None)) as a requirement of exo.i586 0-0.3.101-1.fc11 - u
looking for (u'/bin/sh', None, (None, None, None)) as a requirement of exo.i586 0-0.3.101-1.fc11 - u
looking for (u'libgdk-x11-2.0.so.0', None, (None, None, None)) as a requirement of exo.i586 0-0.3.101-1.fc11 - u
looking for (u'rtld(GNU_HASH)', None, (None, None, None)) as a requirement of exo.i586 0-0.3.101-1.fc11 - u
looking for (u'libdbus-1.so.3', None, (None, None, None)) as a requirement of exo.i586 0-0.3.101-1.fc11 - u
looking for (u'libgio-2.0.so.0', None, (None, None, None)) as a requirement of exo.i586 0-0.3.101-1.fc11 - u
looking for (u'/usr/bin/env', None, (None, None, None)) as a requirement of exo.i586 0-0.3.101-1.fc11 - u
looking for (u'libgtk-x11-2.0.so.0', None, (None, None, None)) as a requirement of exo.i586 0-0.3.101-1.fc11 - u
looking for (u'libc.so.6(GLIBC_2.0)', None, (None, None, None)) as a requirement of exo.i586 0-0.3.101-1.fc11 - u
looking for (u'libatk-1.0.so.0', None, (None, None, None)) as a requirement of exo.i586 0-0.3.101-1.fc11 - u
looking for (u'perl(strict)', None, (None, None, None)) as a requirement of exo.i586 0-0.3.101-1.fc11 - u
looking for (u'libxfce4util.so.4', None, (None, None, None)) as a requirement of exo.i586 0-0.3.101-1.fc11 - u
looking for (u'xfce4-doc', None, (None, None, None)) as a requirement of exo.i586 0-0.3.101-1.fc11 - u
looking for (u'libglib-2.0.so.0', None, (None, None, None)) as a requirement of exo.i586 0-0.3.101-1.fc11 - u
looking for (u'perl(URI::URL)', None, (None, None, None)) as a requirement of exo.i586 0-0.3.101-1.fc11 - u
looking for (u'libhal.so.1', None, (None, None, None)) as a requirement of exo.i586 0-0.3.101-1.fc11 - u
looking for (u'libpango-1.0.so.0', None, (None, None, None)) as a requirement of exo.i586 0-0.3.101-1.fc11 - u
looking for (u'libgmodule-2.0.so.0', None, (None, None, None)) as a requirement of exo.i586 0-0.3.101-1.fc11 - u
looking for (u'perl(URI::file)', None, (None, None, None)) as a requirement of exo.i586 0-0.3.101-1.fc11 - u
looking for (u'libpthread.so.0', None, (None, None, None)) as a requirement of exo.i586 0-0.3.101-1.fc11 - u
looking for (u'libgobject-2.0.so.0', None, (None, None, None)) as a requirement of exo.i586 0-0.3.101-1.fc11 - u
exo-0.3.101-1.fc11.i586 requires: libnotify.so.1
--> Processing Dependency: libnotify.so.1 for package: exo-0.3.101-1.fc11.i586
Searching pkgSack for dep: libnotify.so.1
Potential match for libnotify.so.1 from libnotify-0.4.5-2.fc11.i586
Matched libnotify-0.4.5-2.fc11.i586 to require for libnotify.so.1
TSINFO: Marking libnotify-0.4.5-2.fc11.i586 as install for exo-0.3.101-1.fc11.i586
exo-0.3.101-1.fc11.i586 requires: libhal-storage.so.1
--> Processing Dependency: libhal-storage.so.1 for package: exo-0.3.101-1.fc11.i586
Searching pkgSack for dep: libhal-storage.so.1
Potential match for libhal-storage.so.1 from hal-libs-0.5.12-26.20090226git.fc11.i586
Matched hal-libs-0.5.12-26.20090226git.fc11.i586 to require for libhal-storage.so.1
TSINFO: Marking hal-libs-0.5.12-26.20090226git.fc11.i586 as install for exo-0.3.101-1.fc11.i586
exo-0.3.101-1.fc11.i586 requires: libhal.so.1
--> Processing Dependency: libhal.so.1 for package: exo-0.3.101-1.fc11.i586
Quick matched hal-libs-0.5.12-26.20090226git.fc11.i586 to require for libhal.so.1
---> Package libwnck.i586 0:2.26.1-1.fc11 set to be updated
Checking deps for libwnck.i586 0-2.26.1-1.fc11 - u
looking for (u'startup-notification', u'GE', (u'0', u'0.5', None)) as a requirement of libwnck.i586 0-2.26.1-1.fc11 - u
looking for (u'glib2', u'GE', (u'0', u'2.16.0', None)) as a requirement of libwnck.i586 0-2.26.1-1.fc11 - u
looking for (u'gtk2', u'GE', (u'0', u'2.11.3', None)) as a requirement of libwnck.i586 0-2.26.1-1.fc11 - u
looking for (u'libc.so.6(GLIBC_2.3.4)', None, (None, None, None)) as a requirement of libwnck.i586 0-2.26.1-1.fc11 - u
looking for (u'libc.so.6(GLIBC_2.4)', None, (None, None, None)) as a requirement of libwnck.i586 0-2.26.1-1.fc11 - u
looking for (u'libglib-2.0.so.0', None, (None, None, None)) as a requirement of libwnck.i586 0-2.26.1-1.fc11 - u
looking for (u'libpangocairo-1.0.so.0', None, (None, None, None)) as a requirement of libwnck.i586 0-2.26.1-1.fc11 - u
looking for (u'libc.so.6(GLIBC_2.1.3)', None, (None, None, None)) as a requirement of libwnck.i586 0-2.26.1-1.fc11 - u
looking for (u'libstartup-notification-1.so.0', None, (None, None, None)) as a requirement of libwnck.i586 0-2.26.1-1.fc11 - u
looking for (u'libcairo.so.2', None, (None, None, None)) as a requirement of libwnck.i586 0-2.26.1-1.fc11 - u
looking for (u'libfontconfig.so.1', None, (None, None, None)) as a requirement of libwnck.i586 0-2.26.1-1.fc11 - u
looking for (u'libgdk_pixbuf-2.0.so.0', None, (None, None, None)) as a requirement of libwnck.i586 0-2.26.1-1.fc11 - u
looking for (u'libc.so.6(GLIBC_2.2)', None, (None, None, None)) as a requirement of libwnck.i586 0-2.26.1-1.fc11 - u
looking for (u'libpangoft2-1.0.so.0', None, (None, None, None)) as a requirement of libwnck.i586 0-2.26.1-1.fc11 - u
looking for (u'libc.so.6', None, (None, None, None)) as a requirement of libwnck.i586 0-2.26.1-1.fc11 - u
looking for (u'libfreetype.so.6', None, (None, None, None)) as a requirement of libwnck.i586 0-2.26.1-1.fc11 - u
looking for (u'libgdk-x11-2.0.so.0', None, (None, None, None)) as a requirement of libwnck.i586 0-2.26.1-1.fc11 - u
looking for (u'/sbin/ldconfig', None, (None, None, None)) as a requirement of libwnck.i586 0-2.26.1-1.fc11 - u
looking for (u'rtld(GNU_HASH)', None, (None, None, None)) as a requirement of libwnck.i586 0-2.26.1-1.fc11 - u
looking for (u'libXRes.so.1', None, (None, None, None)) as a requirement of libwnck.i586 0-2.26.1-1.fc11 - u
looking for (u'libgio-2.0.so.0', None, (None, None, None)) as a requirement of libwnck.i586 0-2.26.1-1.fc11 - u
looking for (u'libgtk-x11-2.0.so.0', None, (None, None, None)) as a requirement of libwnck.i586 0-2.26.1-1.fc11 - u
looking for (u'libc.so.6(GLIBC_2.0)', None, (None, None, None)) as a requirement of libwnck.i586 0-2.26.1-1.fc11 - u
looking for (u'libatk-1.0.so.0', None, (None, None, None)) as a requirement of libwnck.i586 0-2.26.1-1.fc11 - u
looking for (u'libX11.so.6', None, (None, None, None)) as a requirement of libwnck.i586 0-2.26.1-1.fc11 - u
looking for (u'/sbin/ldconfig', None, (None, None, None)) as a requirement of libwnck.i586 0-2.26.1-1.fc11 - u
looking for (u'libpango-1.0.so.0', None, (None, None, None)) as a requirement of libwnck.i586 0-2.26.1-1.fc11 - u
looking for (u'libgmodule-2.0.so.0', None, (None, None, None)) as a requirement of libwnck.i586 0-2.26.1-1.fc11 - u
looking for (u'libgobject-2.0.so.0', None, (None, None, None)) as a requirement of libwnck.i586 0-2.26.1-1.fc11 - u
libwnck-2.26.1-1.fc11.i586 requires: libXRes.so.1
--> Processing Dependency: libXRes.so.1 for package: libwnck-2.26.1-1.fc11.i586
Searching pkgSack for dep: libXRes.so.1
Potential match for libXRes.so.1 from libXres-1.0.3-6.fc11.i586
Matched libXres-1.0.3-6.fc11.i586 to require for libXRes.so.1
TSINFO: Marking libXres-1.0.3-6.fc11.i586 as install for libwnck-2.26.1-1.fc11.i586
---> Package libxfce4util.i586 0:4.6.1-1.fc11 set to be updated
Checking deps for libxfce4util.i586 0-4.6.1-1.fc11 - u
looking for (u'glib2', u'GE', (u'0', u'2.0.0', None)) as a requirement of libxfce4util.i586 0-4.6.1-1.fc11 - u
looking for (u'libc.so.6(GLIBC_2.2)', None, (None, None, None)) as a requirement of libxfce4util.i586 0-4.6.1-1.fc11 - u
looking for (u'libc.so.6(GLIBC_2.3.4)', None, (None, None, None)) as a requirement of libxfce4util.i586 0-4.6.1-1.fc11 - u
looking for (u'libc.so.6(GLIBC_2.4)', None, (None, None, None)) as a requirement of libxfce4util.i586 0-4.6.1-1.fc11 - u
looking for (u'libglib-2.0.so.0', None, (None, None, None)) as a requirement of libxfce4util.i586 0-4.6.1-1.fc11 - u
looking for (u'libc.so.6(GLIBC_2.1.3)', None, (None, None, None)) as a requirement of libxfce4util.i586 0-4.6.1-1.fc11 - u
looking for (u'/sbin/ldconfig', None, (None, None, None)) as a requirement of libxfce4util.i586 0-4.6.1-1.fc11 - u
looking for (u'libc.so.6(GLIBC_2.1)', None, (None, None, None)) as a requirement of libxfce4util.i586 0-4.6.1-1.fc11 - u
looking for (u'rtld(GNU_HASH)', None, (None, None, None)) as a requirement of libxfce4util.i586 0-4.6.1-1.fc11 - u
looking for (u'/sbin/ldconfig', None, (None, None, None)) as a requirement of libxfce4util.i586 0-4.6.1-1.fc11 - u
looking for (u'libc.so.6', None, (None, None, None)) as a requirement of libxfce4util.i586 0-4.6.1-1.fc11 - u
looking for (u'libc.so.6(GLIBC_2.0)', None, (None, None, None)) as a requirement of libxfce4util.i586 0-4.6.1-1.fc11 - u
looking for (u'libgobject-2.0.so.0', None, (None, None, None)) as a requirement of libxfce4util.i586 0-4.6.1-1.fc11 - u
---> Package libxfcegui4.i586 0:4.6.1-1.fc11 set to be updated
Checking deps for libxfcegui4.i586 0-4.6.1-1.fc11 - u
looking for (u'libxfce4util', u'GE', (u'0', u'4.6.1', None)) as a requirement of libxfcegui4.i586 0-4.6.1-1.fc11 - u
looking for (u'gtk2', u'GE', (u'0', u'2.0.6', None)) as a requirement of libxfcegui4.i586 0-4.6.1-1.fc11 - u
looking for (u'libc.so.6(GLIBC_2.3.4)', None, (None, None, None)) as a requirement of libxfcegui4.i586 0-4.6.1-1.fc11 - u
looking for (u'libc.so.6(GLIBC_2.4)', None, (None, None, None)) as a requirement of libxfcegui4.i586 0-4.6.1-1.fc11 - u
looking for (u'libcairo.so.2', None, (None, None, None)) as a requirement of libxfcegui4.i586 0-4.6.1-1.fc11 - u
looking for (u'libpangocairo-1.0.so.0', None, (None, None, None)) as a requirement of libxfcegui4.i586 0-4.6.1-1.fc11 - u
looking for (u'libc.so.6(GLIBC_2.1.3)', None, (None, None, None)) as a requirement of libxfcegui4.i586 0-4.6.1-1.fc11 - u
looking for (u'libstartup-notification-1.so.0', None, (None, None, None)) as a requirement of libxfcegui4.i586 0-4.6.1-1.fc11 - u
looking for (u'libxml2.so.2', None, (None, None, None)) as a requirement of libxfcegui4.i586 0-4.6.1-1.fc11 - u
looking for (u'libglib-2.0.so.0', None, (None, None, None)) as a requirement of libxfcegui4.i586 0-4.6.1-1.fc11 - u
looking for (u'libfontconfig.so.1', None, (None, None, None)) as a requirement of libxfcegui4.i586 0-4.6.1-1.fc11 - u
looking for (u'/bin/sh', None, (None, None, None)) as a requirement of libxfcegui4.i586 0-4.6.1-1.fc11 - u
looking for (u'libgdk_pixbuf-2.0.so.0', None, (None, None, None)) as a requirement of libxfcegui4.i586 0-4.6.1-1.fc11 - u
looking for (u'libc.so.6(GLIBC_2.2)', None, (None, None, None)) as a requirement of libxfcegui4.i586 0-4.6.1-1.fc11 - u
looking for (u'libglade-2.0.so.0', None, (None, None, None)) as a requirement of libxfcegui4.i586 0-4.6.1-1.fc11 - u
looking for (u'libpangoft2-1.0.so.0', None, (None, None, None)) as a requirement of libxfcegui4.i586 0-4.6.1-1.fc11 - u
looking for (u'libc.so.6', None, (None, None, None)) as a requirement of libxfcegui4.i586 0-4.6.1-1.fc11 - u
looking for (u'libfreetype.so.6', None, (None, None, None)) as a requirement of libxfcegui4.i586 0-4.6.1-1.fc11 - u
looking for (u'libICE.so.6', None, (None, None, None)) as a requirement of libxfcegui4.i586 0-4.6.1-1.fc11 - u
looking for (u'/bin/sh', None, (None, None, None)) as a requirement of libxfcegui4.i586 0-4.6.1-1.fc11 - u
looking for (u'libgdk-x11-2.0.so.0', None, (None, None, None)) as a requirement of libxfcegui4.i586 0-4.6.1-1.fc11 - u
looking for (u'rtld(GNU_HASH)', None, (None, None, None)) as a requirement of libxfcegui4.i586 0-4.6.1-1.fc11 - u
looking for (u'libdbus-1.so.3', None, (None, None, None)) as a requirement of libxfcegui4.i586 0-4.6.1-1.fc11 - u
looking for (u'libgio-2.0.so.0', None, (None, None, None)) as a requirement of libxfcegui4.i586 0-4.6.1-1.fc11 - u
looking for (u'libgtk-x11-2.0.so.0', None, (None, None, None)) as a requirement of libxfcegui4.i586 0-4.6.1-1.fc11 - u
looking for (u'libc.so.6(GLIBC_2.0)', None, (None, None, None)) as a requirement of libxfcegui4.i586 0-4.6.1-1.fc11 - u
looking for (u'libatk-1.0.so.0', None, (None, None, None)) as a requirement of libxfcegui4.i586 0-4.6.1-1.fc11 - u
looking for (u'libX11.so.6', None, (None, None, None)) as a requirement of libxfcegui4.i586 0-4.6.1-1.fc11 - u
looking for (u'libxfce4util.so.4', None, (None, None, None)) as a requirement of libxfcegui4.i586 0-4.6.1-1.fc11 - u
looking for (u'libxfconf-0.so.2', None, (None, None, None)) as a requirement of libxfcegui4.i586 0-4.6.1-1.fc11 - u
looking for (u'libpango-1.0.so.0', None, (None, None, None)) as a requirement of libxfcegui4.i586 0-4.6.1-1.fc11 - u
looking for (u'libgmodule-2.0.so.0', None, (None, None, None)) as a requirement of libxfcegui4.i586 0-4.6.1-1.fc11 - u
looking for (u'libdbus-glib-1.so.2', None, (None, None, None)) as a requirement of libxfcegui4.i586 0-4.6.1-1.fc11 - u
looking for (u'libSM.so.6', None, (None, None, None)) as a requirement of libxfcegui4.i586 0-4.6.1-1.fc11 - u
looking for (u'libgobject-2.0.so.0', None, (None, None, None)) as a requirement of libxfcegui4.i586 0-4.6.1-1.fc11 - u
libxfcegui4-4.6.1-1.fc11.i586 requires: libglade-2.0.so.0
--> Processing Dependency: libglade-2.0.so.0 for package: libxfcegui4-4.6.1-1.fc11.i586
Searching pkgSack for dep: libglade-2.0.so.0
Potential match for libglade-2.0.so.0 from libglade2-2.6.4-1.fc11.i586
Matched libglade2-2.6.4-1.fc11.i586 to require for libglade-2.0.so.0
TSINFO: Marking libglade2-2.6.4-1.fc11.i586 as install for libxfcegui4-4.6.1-1.fc11.i586
libxfcegui4-4.6.1-1.fc11.i586 requires: libICE.so.6
--> Processing Dependency: libICE.so.6 for package: libxfcegui4-4.6.1-1.fc11.i586
Searching pkgSack for dep: libICE.so.6
Potential match for libICE.so.6 from libICE-1.0.4-7.fc11.i586
Matched libICE-1.0.4-7.fc11.i586 to require for libICE.so.6
TSINFO: Marking libICE-1.0.4-7.fc11.i586 as install for libxfcegui4-4.6.1-1.fc11.i586
libxfcegui4-4.6.1-1.fc11.i586 requires: libxfconf-0.so.2
--> Processing Dependency: libxfconf-0.so.2 for package: libxfcegui4-4.6.1-1.fc11.i586
Searching pkgSack for dep: libxfconf-0.so.2
Potential match for libxfconf-0.so.2 from xfconf-4.6.1-1.fc11.i586
Matched xfconf-4.6.1-1.fc11.i586 to require for libxfconf-0.so.2
Potential match for libxfconf-0.so.2 from xfconf-4.6.1-1.fc11.i586
Matched xfconf-4.6.1-1.fc11.i586 to require for libxfconf-0.so.2
TSINFO: Marking xfconf-4.6.1-1.fc11.i586 as install for libxfcegui4-4.6.1-1.fc11.i586
libxfcegui4-4.6.1-1.fc11.i586 requires: libdbus-glib-1.so.2
--> Processing Dependency: libdbus-glib-1.so.2 for package: libxfcegui4-4.6.1-1.fc11.i586
Searching pkgSack for dep: libdbus-glib-1.so.2
Potential match for libdbus-glib-1.so.2 from dbus-glib-0.80-2.fc11.i586
Matched dbus-glib-0.80-2.fc11.i586 to require for libdbus-glib-1.so.2
TSINFO: Marking dbus-glib-0.80-2.fc11.i586 as install for libxfcegui4-4.6.1-1.fc11.i586
libxfcegui4-4.6.1-1.fc11.i586 requires: libSM.so.6
--> Processing Dependency: libSM.so.6 for package: libxfcegui4-4.6.1-1.fc11.i586
Searching pkgSack for dep: libSM.so.6
Potential match for libSM.so.6 from libSM-1.1.0-4.fc11.i586
Matched libSM-1.1.0-4.fc11.i586 to require for libSM.so.6
TSINFO: Marking libSM-1.1.0-4.fc11.i586 as install for libxfcegui4-4.6.1-1.fc11.i586
---> Package startup-notification.i586 0:0.9-6.fc11 set to be updated
Checking deps for startup-notification.i586 0-0.9-6.fc11 - u
looking for (u'libICE.so.6', None, (None, None, None)) as a requirement of startup-notification.i586 0-0.9-6.fc11 - u
looking for (u'libc.so.6(GLIBC_2.3.4)', None, (None, None, None)) as a requirement of startup-notification.i586 0-0.9-6.fc11 - u
looking for (u'libc.so.6(GLIBC_2.4)', None, (None, None, None)) as a requirement of startup-notification.i586 0-0.9-6.fc11 - u
looking for (u'libc.so.6(GLIBC_2.1.3)', None, (None, None, None)) as a requirement of startup-notification.i586 0-0.9-6.fc11 - u
looking for (u'/sbin/ldconfig', None, (None, None, None)) as a requirement of startup-notification.i586 0-0.9-6.fc11 - u
looking for (u'rtld(GNU_HASH)', None, (None, None, None)) as a requirement of startup-notification.i586 0-0.9-6.fc11 - u
looking for (u'/sbin/ldconfig', None, (None, None, None)) as a requirement of startup-notification.i586 0-0.9-6.fc11 - u
looking for (u'libc.so.6', None, (None, None, None)) as a requirement of startup-notification.i586 0-0.9-6.fc11 - u
looking for (u'libc.so.6(GLIBC_2.0)', None, (None, None, None)) as a requirement of startup-notification.i586 0-0.9-6.fc11 - u
looking for (u'libSM.so.6', None, (None, None, None)) as a requirement of startup-notification.i586 0-0.9-6.fc11 - u
looking for (u'libX11.so.6', None, (None, None, None)) as a requirement of startup-notification.i586 0-0.9-6.fc11 - u
--> Running transaction check
---> Package dbus-glib.i586 0:0.80-2.fc11 set to be updated
Checking deps for dbus-glib.i586 0-0.80-2.fc11 - u
looking for (u'chkconfig', u'GE', (u'0', u'1.3.26', None)) as a requirement of dbus-glib.i586 0-0.80-2.fc11 - u
looking for (u'libc.so.6(GLIBC_2.2)', None, (None, None, None)) as a requirement of dbus-glib.i586 0-0.80-2.fc11 - u
looking for (u'libc.so.6(GLIBC_2.3.4)', None, (None, None, None)) as a requirement of dbus-glib.i586 0-0.80-2.fc11 - u
looking for (u'libc.so.6(GLIBC_2.4)', None, (None, None, None)) as a requirement of dbus-glib.i586 0-0.80-2.fc11 - u
looking for (u'libglib-2.0.so.0', None, (None, None, None)) as a requirement of dbus-glib.i586 0-0.80-2.fc11 - u
looking for (u'libc.so.6', None, (None, None, None)) as a requirement of dbus-glib.i586 0-0.80-2.fc11 - u
looking for (u'/sbin/ldconfig', None, (None, None, None)) as a requirement of dbus-glib.i586 0-0.80-2.fc11 - u
looking for (u'rtld(GNU_HASH)', None, (None, None, None)) as a requirement of dbus-glib.i586 0-0.80-2.fc11 - u
looking for (u'libdbus-1.so.3', None, (None, None, None)) as a requirement of dbus-glib.i586 0-0.80-2.fc11 - u
looking for (u'/sbin/ldconfig', None, (None, None, None)) as a requirement of dbus-glib.i586 0-0.80-2.fc11 - u
looking for (u'libc.so.6(GLIBC_2.1.3)', None, (None, None, None)) as a requirement of dbus-glib.i586 0-0.80-2.fc11 - u
looking for (u'libexpat.so.1', None, (None, None, None)) as a requirement of dbus-glib.i586 0-0.80-2.fc11 - u
looking for (u'libc.so.6(GLIBC_2.0)', None, (None, None, None)) as a requirement of dbus-glib.i586 0-0.80-2.fc11 - u
looking for (u'libgobject-2.0.so.0', None, (None, None, None)) as a requirement of dbus-glib.i586 0-0.80-2.fc11 - u
---> Package hal-libs.i586 0:0.5.12-26.20090226git.fc11 set to be updated
Checking deps for hal-libs.i586 0-0.5.12-26.20090226git.fc11 - u
looking for (u'dbus', u'GE', (u'0', u'0.90', None)) as a requirement of hal-libs.i586 0-0.5.12-26.20090226git.fc11 - u
looking for (u'libc.so.6(GLIBC_2.3.4)', None, (None, None, None)) as a requirement of hal-libs.i586 0-0.5.12-26.20090226git.fc11 - u
looking for (u'libc.so.6(GLIBC_2.4)', None, (None, None, None)) as a requirement of hal-libs.i586 0-0.5.12-26.20090226git.fc11 - u
looking for (u'libc.so.6', None, (None, None, None)) as a requirement of hal-libs.i586 0-0.5.12-26.20090226git.fc11 - u
looking for (u'rtld(GNU_HASH)', None, (None, None, None)) as a requirement of hal-libs.i586 0-0.5.12-26.20090226git.fc11 - u
looking for (u'libdbus-1.so.3', None, (None, None, None)) as a requirement of hal-libs.i586 0-0.5.12-26.20090226git.fc11 - u
looking for (u'libc.so.6(GLIBC_2.1.3)', None, (None, None, None)) as a requirement of hal-libs.i586 0-0.5.12-26.20090226git.fc11 - u
looking for (u'libc.so.6(GLIBC_2.0)', None, (None, None, None)) as a requirement of hal-libs.i586 0-0.5.12-26.20090226git.fc11 - u
---> Package libICE.i586 0:1.0.4-7.fc11 set to be updated
Checking deps for libICE.i586 0-1.0.4-7.fc11 - u
looking for (u'libc.so.6(GLIBC_2.3.4)', None, (None, None, None)) as a requirement of libICE.i586 0-1.0.4-7.fc11 - u
looking for (u'libc.so.6(GLIBC_2.4)', None, (None, None, None)) as a requirement of libICE.i586 0-1.0.4-7.fc11 - u
looking for (u'libc.so.6(GLIBC_2.1.3)', None, (None, None, None)) as a requirement of libICE.i586 0-1.0.4-7.fc11 - u
looking for (u'/sbin/ldconfig', None, (None, None, None)) as a requirement of libICE.i586 0-1.0.4-7.fc11 - u
looking for (u'libc.so.6(GLIBC_2.1)', None, (None, None, None)) as a requirement of libICE.i586 0-1.0.4-7.fc11 - u
looking for (u'rtld(GNU_HASH)', None, (None, None, None)) as a requirement of libICE.i586 0-1.0.4-7.fc11 - u
looking for (u'/sbin/ldconfig', None, (None, None, None)) as a requirement of libICE.i586 0-1.0.4-7.fc11 - u
looking for (u'libc.so.6', None, (None, None, None)) as a requirement of libICE.i586 0-1.0.4-7.fc11 - u
looking for (u'libc.so.6(GLIBC_2.0)', None, (None, None, None)) as a requirement of libICE.i586 0-1.0.4-7.fc11 - u
looking for (u'libc.so.6(GLIBC_2.3)', None, (None, None, None)) as a requirement of libICE.i586 0-1.0.4-7.fc11 - u
---> Package libSM.i586 0:1.1.0-4.fc11 set to be updated
Checking deps for libSM.i586 0-1.1.0-4.fc11 - u
looking for (u'libICE.so.6', None, (None, None, None)) as a requirement of libSM.i586 0-1.1.0-4.fc11 - u
looking for (u'libc.so.6(GLIBC_2.3.4)', None, (None, None, None)) as a requirement of libSM.i586 0-1.1.0-4.fc11 - u
looking for (u'libc.so.6(GLIBC_2.4)', None, (None, None, None)) as a requirement of libSM.i586 0-1.1.0-4.fc11 - u
looking for (u'libc.so.6(GLIBC_2.1.3)', None, (None, None, None)) as a requirement of libSM.i586 0-1.1.0-4.fc11 - u
looking for (u'/sbin/ldconfig', None, (None, None, None)) as a requirement of libSM.i586 0-1.1.0-4.fc11 - u
looking for (u'libuuid.so.1', None, (None, None, None)) as a requirement of libSM.i586 0-1.1.0-4.fc11 - u
looking for (u'rtld(GNU_HASH)', None, (None, None, None)) as a requirement of libSM.i586 0-1.1.0-4.fc11 - u
looking for (u'/sbin/ldconfig', None, (None, None, None)) as a requirement of libSM.i586 0-1.1.0-4.fc11 - u
looking for (u'libc.so.6', None, (None, None, None)) as a requirement of libSM.i586 0-1.1.0-4.fc11 - u
looking for (u'libc.so.6(GLIBC_2.0)', None, (None, None, None)) as a requirement of libSM.i586 0-1.1.0-4.fc11 - u
---> Package libXres.i586 0:1.0.3-6.fc11 set to be updated
Checking deps for libXres.i586 0-1.0.3-6.fc11 - u
looking for (u'libc.so.6(GLIBC_2.1.3)', None, (None, None, None)) as a requirement of libXres.i586 0-1.0.3-6.fc11 - u
looking for (u'/sbin/ldconfig', None, (None, None, None)) as a requirement of libXres.i586 0-1.0.3-6.fc11 - u
looking for (u'rtld(GNU_HASH)', None, (None, None, None)) as a requirement of libXres.i586 0-1.0.3-6.fc11 - u
looking for (u'/sbin/ldconfig', None, (None, None, None)) as a requirement of libXres.i586 0-1.0.3-6.fc11 - u
looking for (u'libc.so.6', None, (None, None, None)) as a requirement of libXres.i586 0-1.0.3-6.fc11 - u
looking for (u'libXext.so.6', None, (None, None, None)) as a requirement of libXres.i586 0-1.0.3-6.fc11 - u
looking for (u'libc.so.6(GLIBC_2.0)', None, (None, None, None)) as a requirement of libXres.i586 0-1.0.3-6.fc11 - u
looking for (u'libX11.so.6', None, (None, None, None)) as a requirement of libXres.i586 0-1.0.3-6.fc11 - u
---> Package libglade2.i586 0:2.6.4-1.fc11 set to be updated
Checking deps for libglade2.i586 0-2.6.4-1.fc11 - u
looking for (u'libxml2', u'GE', (u'0', u'2.4.12', u'0.7')) as a requirement of libglade2.i586 0-2.6.4-1.fc11 - u
looking for (u'gtk2', u'GE', (u'0', u'2.5.0', None)) as a requirement of libglade2.i586 0-2.6.4-1.fc11 - u
looking for (u'libc.so.6(GLIBC_2.4)', None, (None, None, None)) as a requirement of libglade2.i586 0-2.6.4-1.fc11 - u
looking for (u'libglib-2.0.so.0', None, (None, None, None)) as a requirement of libglade2.i586 0-2.6.4-1.fc11 - u
looking for (u'libpangocairo-1.0.so.0', None, (None, None, None)) as a requirement of libglade2.i586 0-2.6.4-1.fc11 - u
looking for (u'libc.so.6(GLIBC_2.1.3)', None, (None, None, None)) as a requirement of libglade2.i586 0-2.6.4-1.fc11 - u
looking for (u'libcairo.so.2', None, (None, None, None)) as a requirement of libglade2.i586 0-2.6.4-1.fc11 - u
looking for (u'libfontconfig.so.1', None, (None, None, None)) as a requirement of libglade2.i586 0-2.6.4-1.fc11 - u
looking for (u'libgdk_pixbuf-2.0.so.0', None, (None, None, None)) as a requirement of libglade2.i586 0-2.6.4-1.fc11 - u
looking for (u'libpangoft2-1.0.so.0', None, (None, None, None)) as a requirement of libglade2.i586 0-2.6.4-1.fc11 - u
looking for (u'libc.so.6', None, (None, None, None)) as a requirement of libglade2.i586 0-2.6.4-1.fc11 - u
looking for (u'libfreetype.so.6', None, (None, None, None)) as a requirement of libglade2.i586 0-2.6.4-1.fc11 - u
looking for (u'libgdk-x11-2.0.so.0', None, (None, None, None)) as a requirement of libglade2.i586 0-2.6.4-1.fc11 - u
looking for (u'/sbin/ldconfig', None, (None, None, None)) as a requirement of libglade2.i586 0-2.6.4-1.fc11 - u
looking for (u'libxml2.so.2', None, (None, None, None)) as a requirement of libglade2.i586 0-2.6.4-1.fc11 - u
looking for (u'rtld(GNU_HASH)', None, (None, None, None)) as a requirement of libglade2.i586 0-2.6.4-1.fc11 - u
looking for (u'libgio-2.0.so.0', None, (None, None, None)) as a requirement of libglade2.i586 0-2.6.4-1.fc11 - u
looking for (u'libgtk-x11-2.0.so.0', None, (None, None, None)) as a requirement of libglade2.i586 0-2.6.4-1.fc11 - u
looking for (u'libc.so.6(GLIBC_2.0)', None, (None, None, None)) as a requirement of libglade2.i586 0-2.6.4-1.fc11 - u
looking for (u'libatk-1.0.so.0', None, (None, None, None)) as a requirement of libglade2.i586 0-2.6.4-1.fc11 - u
looking for (u'/sbin/ldconfig', None, (None, None, None)) as a requirement of libglade2.i586 0-2.6.4-1.fc11 - u
looking for (u'libpango-1.0.so.0', None, (None, None, None)) as a requirement of libglade2.i586 0-2.6.4-1.fc11 - u
looking for (u'libgmodule-2.0.so.0', None, (None, None, None)) as a requirement of libglade2.i586 0-2.6.4-1.fc11 - u
looking for (u'libgobject-2.0.so.0', None, (None, None, None)) as a requirement of libglade2.i586 0-2.6.4-1.fc11 - u
---> Package libnotify.i586 0:0.4.5-2.fc11 set to be updated
Checking deps for libnotify.i586 0-0.4.5-2.fc11 - u
looking for (u'glib2', u'GE', (u'0', u'2.2.2', None)) as a requirement of libnotify.i586 0-0.4.5-2.fc11 - u
looking for (u'libc.so.6(GLIBC_2.3.4)', None, (None, None, None)) as a requirement of libnotify.i586 0-0.4.5-2.fc11 - u
looking for (u'libglib-2.0.so.0', None, (None, None, None)) as a requirement of libnotify.i586 0-0.4.5-2.fc11 - u
looking for (u'libpangocairo-1.0.so.0', None, (None, None, None)) as a requirement of libnotify.i586 0-0.4.5-2.fc11 - u
looking for (u'libc.so.6(GLIBC_2.1.3)', None, (None, None, None)) as a requirement of libnotify.i586 0-0.4.5-2.fc11 - u
looking for (u'libcairo.so.2', None, (None, None, None)) as a requirement of libnotify.i586 0-0.4.5-2.fc11 - u
looking for (u'libfontconfig.so.1', None, (None, None, None)) as a requirement of libnotify.i586 0-0.4.5-2.fc11 - u
looking for (u'/bin/sh', None, (None, None, None)) as a requirement of libnotify.i586 0-0.4.5-2.fc11 - u
looking for (u'libgdk_pixbuf-2.0.so.0', None, (None, None, None)) as a requirement of libnotify.i586 0-0.4.5-2.fc11 - u
looking for (u'libpangoft2-1.0.so.0', None, (None, None, None)) as a requirement of libnotify.i586 0-0.4.5-2.fc11 - u
looking for (u'libc.so.6', None, (None, None, None)) as a requirement of libnotify.i586 0-0.4.5-2.fc11 - u
looking for (u'libfreetype.so.6', None, (None, None, None)) as a requirement of libnotify.i586 0-0.4.5-2.fc11 - u
looking for (u'/bin/sh', None, (None, None, None)) as a requirement of libnotify.i586 0-0.4.5-2.fc11 - u
looking for (u'libgdk-x11-2.0.so.0', None, (None, None, None)) as a requirement of libnotify.i586 0-0.4.5-2.fc11 - u
looking for (u'rtld(GNU_HASH)', None, (None, None, None)) as a requirement of libnotify.i586 0-0.4.5-2.fc11 - u
looking for (u'libdbus-1.so.3', None, (None, None, None)) as a requirement of libnotify.i586 0-0.4.5-2.fc11 - u
looking for (u'libgio-2.0.so.0', None, (None, None, None)) as a requirement of libnotify.i586 0-0.4.5-2.fc11 - u
looking for (u'libgtk-x11-2.0.so.0', None, (None, None, None)) as a requirement of libnotify.i586 0-0.4.5-2.fc11 - u
looking for (u'libc.so.6(GLIBC_2.0)', None, (None, None, None)) as a requirement of libnotify.i586 0-0.4.5-2.fc11 - u
looking for (u'libatk-1.0.so.0', None, (None, None, None)) as a requirement of libnotify.i586 0-0.4.5-2.fc11 - u
looking for (u'desktop-notification-daemon', None, (None, None, None)) as a requirement of libnotify.i586 0-0.4.5-2.fc11 - u
looking for (u'libpango-1.0.so.0', None, (None, None, None)) as a requirement of libnotify.i586 0-0.4.5-2.fc11 - u
looking for (u'libgmodule-2.0.so.0', None, (None, None, None)) as a requirement of libnotify.i586 0-0.4.5-2.fc11 - u
looking for (u'libdbus-glib-1.so.2', None, (None, None, None)) as a requirement of libnotify.i586 0-0.4.5-2.fc11 - u
looking for (u'libgobject-2.0.so.0', None, (None, None, None)) as a requirement of libnotify.i586 0-0.4.5-2.fc11 - u
---> Package xfconf.i586 0:4.6.1-1.fc11 set to be updated
Checking deps for xfconf.i586 0-4.6.1-1.fc11 - u
looking for (u'libc.so.6(GLIBC_2.3.4)', None, (None, None, None)) as a requirement of xfconf.i586 0-4.6.1-1.fc11 - u
looking for (u'libc.so.6(GLIBC_2.4)', None, (None, None, None)) as a requirement of xfconf.i586 0-4.6.1-1.fc11 - u
looking for (u'libglib-2.0.so.0', None, (None, None, None)) as a requirement of xfconf.i586 0-4.6.1-1.fc11 - u
looking for (u'libc.so.6', None, (None, None, None)) as a requirement of xfconf.i586 0-4.6.1-1.fc11 - u
looking for (u'/sbin/ldconfig', None, (None, None, None)) as a requirement of xfconf.i586 0-4.6.1-1.fc11 - u
looking for (u'libc.so.6(GLIBC_2.1)', None, (None, None, None)) as a requirement of xfconf.i586 0-4.6.1-1.fc11 - u
looking for (u'libxfce4util.so.4', None, (None, None, None)) as a requirement of xfconf.i586 0-4.6.1-1.fc11 - u
looking for (u'libdbus-1.so.3', None, (None, None, None)) as a requirement of xfconf.i586 0-4.6.1-1.fc11 - u
looking for (u'/sbin/ldconfig', None, (None, None, None)) as a requirement of xfconf.i586 0-4.6.1-1.fc11 - u
looking for (u'libc.so.6(GLIBC_2.1.3)', None, (None, None, None)) as a requirement of xfconf.i586 0-4.6.1-1.fc11 - u
looking for (u'rtld(GNU_HASH)', None, (None, None, None)) as a requirement of xfconf.i586 0-4.6.1-1.fc11 - u
looking for (u'libc.so.6(GLIBC_2.0)', None, (None, None, None)) as a requirement of xfconf.i586 0-4.6.1-1.fc11 - u
looking for (u'libdbus-glib-1.so.2', None, (None, None, None)) as a requirement of xfconf.i586 0-4.6.1-1.fc11 - u
looking for (u'libgobject-2.0.so.0', None, (None, None, None)) as a requirement of xfconf.i586 0-4.6.1-1.fc11 - u
--> Finished Dependency Resolution
Dependency Process ending
Depsolve time: 1.407

Dependencies Resolved

================================================================================
 Package                 Arch    Version                        Repository
                                                                           Size
================================================================================
Installing:
 xfce4-panel             i586    4.6.1-1.fc11                   fedora    548 k
Installing for dependencies:
 dbus-glib               i586    0.80-2.fc11                    fedora    178 k
 exo                     i586    0.3.101-1.fc11                 fedora    1.2 M
 hal-libs                i586    0.5.12-26.20090226git.fc11     fedora     70 k
 libICE                  i586    1.0.4-7.fc11                   fedora     55 k
 libSM                   i586    1.1.0-4.fc11                   fedora     27 k
 libXres                 i586    1.0.3-6.fc11                   fedora     15 k
 libglade2               i586    2.6.4-1.fc11                   fedora     66 k
 libnotify               i586    0.4.5-2.fc11                   fedora     36 k
 libwnck                 i586    2.26.1-1.fc11                  fedora    403 k
 libxfce4util            i586    4.6.1-1.fc11                   fedora    103 k
 libxfcegui4             i586    4.6.1-1.fc11                   fedora    309 k
 startup-notification    i586    0.9-6.fc11                     fedora     39 k
 xfconf                  i586    4.6.1-1.fc11                   fedora    122 k

Transaction Summary
================================================================================
Install     14 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 3.2 M
Is this ok [y/N]: N
Comment 16 seth vidal 2009-06-23 16:54:06 EDT
The only way to fix this is to get bug 507702 fixed, too
Comment 17 seth vidal 2009-06-24 17:05:09 EDT
Okay as a partial fix to the specific problem.

I've added a patch to yum that checks to see if we have any other pkgs by the same name as the obsoleting pkg that is available. If we do have any pkgs by the same name, then we look to see if they are an obsoleter of the pkg we want to install. If so then we duck out without doing anything b/c it is already done.

http://yum.baseurl.org/gitweb?p=yum.git;a=commitdiff;h=56f8145aadd0396f9f1e3db3398a71aac5000f8f

feel free to test but I duplicated it locally, I think. I'll work on a testcase for it, too.
Comment 18 Fedora Update System 2009-09-29 21:38:42 EDT
yum-3.2.24-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2009-10-19 12:45:20 EDT
yum-3.2.24-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/yum-3.2.24-2.fc10
Comment 20 Fedora Update System 2009-11-04 07:06:04 EST
yum-3.2.24-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.