Bug 50601 - Festival 1.4.1 on RH7.1. Packages problems
Festival 1.4.1 on RH7.1. Packages problems
Status: CLOSED CURRENTRELEASE
Product: Red Hat Powertools
Classification: Retired
Component: festival (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-01 10:25 EDT by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-01 10:25:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-08-01 10:25:27 EDT
Hi!

I tried to reconstruct Festival 1.4.1 (from the RH 7.0 powertool CD) by
using rpm --rebuild.
I have two minor problems:
at the end of the building process, when the packages are generated, I have
the following message:


Processing files: festival-devel-1.4.1-5
Executing(%doc): /bin/sh -e /var/tmp/rpm-tmp.82483
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd festival
+ DOCDIR=/var/tmp/festival-buildroot/usr/share/doc/festival-devel-1.4.1
+ export DOCDIR
+ rm -rf /var/tmp/festival-buildroot/usr/share/doc/festival-devel-1.4.1
+ /bin/mkdir -p
/var/tmp/festival-buildroot/usr/share/doc/festival-devel-1.4.1
+ cp -pr festdoc-1.4.0.1/festival/src-manual
/var/tmp/festival-buildroot/usr/sha
re/doc/festival-devel-1.4.1
cp: cannot stat `festdoc-1.4.0.1/festival/src-manual': No such file or
directory
error: Bad exit status from /var/tmp/rpm-tmp.82483 (%doc)

but it builds the two packages anyway


Moreover, when I am looking at the structure of the .i386.rpm, I see that
the documentation is in /usr/doc instead of /usr/share/doc


Daniel
Comment 1 Bernhard Rosenkraenzer 2001-08-04 15:26:30 EDT
We aren't shipping festival anymore.

However, the current version of the rpm can be found at http://rhcontrib.bero.org/
It fixes this problem.
Comment 2 Need Real Name 2001-08-06 03:24:39 EDT
Thanks for the information
BTW, Can Mosix be a part of the rhcontrib? Is it planned? Is Mosix planned for
the next RH release?

Daniel
Comment 3 Need Real Name 2001-08-06 04:29:50 EDT
Festival 1.4.2-1 has still the same problem (rpm --rebuild
festival-1.4.2-1.src.rpm): 

+ cp -pr festdoc-1.4.0.1/festival/src-manual
/var/tmp/festival-buildroot/usr/share/doc/festival-devel-1.4.2
cp: cannot stat `festdoc-1.4.0.1/festival/src-manual': No such file or directory
error: Bad exit status from /var/tmp/rpm-tmp.89599 (%doc)
Finding  Provides: (using /usr/lib/rpm/find-provides)...
Finding  Requires: (using /usr/lib/rpm/find-requires)...

The /usr/share/doc/festival-devel-1.4.2 directory is empty and there is no
/usr/share/doc/festival-1.4.2 directory either.

Daniel

Note You need to log in before you can comment on or make changes to this bug.