Bug 506024 - missing dependency gives warning: group nagios does not exist - using root for SUID
missing dependency gives warning: group nagios does not exist - using root fo...
Status: CLOSED DUPLICATE of bug 469530
Product: Fedora
Classification: Fedora
Component: nagios-plugins (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Mike McGrath
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-15 06:25 EDT by Mads Kiilerich
Modified: 2009-09-30 16:49 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-30 16:49:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mads Kiilerich 2009-06-15 06:25:37 EDT
Description of problem:

yum install nagios-plugins-all
...
  Installing     : nagios-plugins-ide_smart-1.4.13-14.fc11.i586 13/53 
warning: group nagios does not exist - using root
...
  Installing     : nagios-plugins-dhcp-1.4.13-14.fc11.i586 31/53 
warning: group nagios does not exist - using root
  Installing     : nagios-plugins-dig-1.4.13-14.fc11.i586 32/53 
  Installing     : nagios-plugins-icmp-1.4.13-14.fc11.i586 33/53 
warning: group nagios does not exist - using root
  Installing     : fping-2.4b2-9.fc11.i586 34/53 
  Installing     : nagios-plugins-fping-1.4.13-14.fc11.i586 35/53 
warning: group nagios does not exist - using root
...

NO dependency to nagios package. Installing nagios-3.0.6-3.fc11.i586 creates the nagios group but leaves for example /usr/lib/nagios/plugins/check_ide_smart owned by the root group. That might be dangerous for a SUID, but I don't know if it has security implications.


Version-Release number of selected component (if applicable):

nagios-3.0.6-3.fc11.i586
nagios-plugins-all-1.4.13-14.fc11.i586
nagios-plugins-ide_smart-1.4.13-14.fc11.i586
Comment 1 Jose Pedro Oliveira 2009-09-30 16:49:57 EDT
Mads,

Known problem. Closing this ticket as a duplicate of #469530

/jpo

PS - Maybe it can be solved in #526561

*** This bug has been marked as a duplicate of bug 469530 ***

Note You need to log in before you can comment on or make changes to this bug.