Bug 506035 - Want ac97 sound, and want it by default
Want ac97 sound, and want it by default
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Cole Robinson
Virtualization Bugs
:
: 508527 (view as bug list)
Depends On:
Blocks: 508747
  Show dependency treegraph
 
Reported: 2009-06-15 07:18 EDT by Markus Armbruster
Modified: 2013-01-09 16:43 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 508747 (view as bug list)
Environment:
Last Closed: 2009-09-02 05:43:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Use ac97 as only sound model for qemu driver. (1.56 KB, patch)
2009-06-29 14:27 EDT, Cole Robinson
no flags Details | Diff

  None (edit)
Description Markus Armbruster 2009-06-15 07:18:15 EDT
Description of problem:
Sound hardware is es1370 by default.  Users can change it to pcspk or sb16.  What we really want is ac97, because that actually works (see bug 492775).


How reproducible:
Always

Steps to Reproduce:
1. Create a new KVM guest with virt-manager.
2. Check its sound hardware under Hardware / Sound
3. Add another soundcare with Add Hardware
  
Actual results:
Step 2: es1370
Step 3: choices es1370 (default), pcspk, sb16

Expected results:
Step 2: ac97
Step 3: choices ac97 (default), not sure we care about the others
Comment 1 Daniel Berrange 2009-06-15 07:42:25 EDT
NB KVM and Xen both support es1370.  Only KVM supports ac97. So this will need to vary between them if this is changed, or Xen made to support ac97, or es1370 fixed.
Comment 2 Michal Novotny 2009-06-15 07:48:26 EDT
Well, we shouldn't make ac97 default then now but what about making the ac97 choice available when choosing audio hardware if KVM is used (machine is under KVM - this information should be available but correct me if I am wrong) ?
Comment 4 Cole Robinson 2009-06-29 13:22:44 EDT
*** Bug 508527 has been marked as a duplicate of this bug. ***
Comment 5 Cole Robinson 2009-06-29 14:27:11 EDT
Created attachment 349848 [details]
Use ac97 as only sound model for qemu driver.
Comment 11 errata-xmlrpc 2009-09-02 05:43:28 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1285.html

Note You need to log in before you can comment on or make changes to this bug.