Bug 506063 - kernel executes scripts in /etc/profile.d/ during startup
Summary: kernel executes scripts in /etc/profile.d/ during startup
Status: CLOSED DUPLICATE of bug 482888
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts   
(Show other bugs)
Version: 11
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-06-15 12:55 UTC by Vadym Chepkov
Modified: 2014-03-17 03:19 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-16 21:25:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Vadym Chepkov 2009-06-15 12:55:50 UTC
Some kernel process during startup executes scripts in /etc/profile.d/
I usually have a separate /usr file system, so I noticed failure messages after 'audit policy loaded' and before 'Welcome to Fedora'. 
I believe /etc/profile.d/ scripts should be executed only by login sessions

Comment 1 Chuck Ebbert 2009-06-16 05:29:03 UTC
It's probably an upstart problem...

Comment 2 Casey Dahlin 2009-06-16 13:56:32 UTC
More likely one of the init scripts. Upstart doesn't execute any raw script files.

Comment 3 Bill Nottingham 2009-06-16 16:01:38 UTC
What are the errors you see?

Comment 4 Vadym Chepkov 2009-06-16 17:02:51 UTC
I see lot's of errors because /usr is not mounted yet, but that not the major concern, I don't think the scripts in /etc/profile.d/ should be executed at all during startup. 
I don't think initscrits are to blame though, as I indicated it happens way before, before 'Welcome to Fedora appears".

Comment 5 Bill Nottingham 2009-06-16 17:09:26 UTC
Thank you, but *what are the errors* that you see? Specifics are nice.

Comment 6 Vadym Chepkov 2009-06-16 18:02:47 UTC
Sorry, I thought this is something easily reproducible. 

I can't grab output without serial console attached and it scrolls very fast, but it something like this:

/etc/profile.d/lang.sh setlocale LC_COLLATE can not change locale, files not found

lots of similar, but I take it back, it seem only this one script, lang.sh, gets executed, not all files from profile.d

Comment 7 Bill Nottingham 2009-06-16 21:25:58 UTC
Thanks!

*** This bug has been marked as a duplicate of bug 482888 ***


Note You need to log in before you can comment on or make changes to this bug.