This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 506077 - Evolution Exchange Plugin cannot connect to Exchange Server
Evolution Exchange Plugin cannot connect to Exchange Server
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution-exchange (Show other bugs)
11
x86_64 Linux
low Severity urgent
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-15 09:42 EDT by Thomas Kordelle
Modified: 2009-06-28 22:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-28 22:33:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Errormessage after pressing button Authenticate (25.50 KB, image/png)
2009-06-15 09:42 EDT, Thomas Kordelle
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 587263 None None None Never

  None (edit)
Description Thomas Kordelle 2009-06-15 09:42:34 EDT
Created attachment 347938 [details]
Errormessage after pressing button Authenticate

After upgrade from Fedora 10 to 11 evolution does not connect to exchange server. 

Used versions:
evolution-exchange-2.26.2-1.fc11.x86_64
evolution-data-server-2.26.2-1.fc11.x86_64
evolution-data-server-2.26.2-1.fc11.i586
evolution-help-2.26.2-1.fc11.noarch
evolution-data-server-debuginfo-2.24.5-5.fc10.x86_64
evolution-2.26.2-1.fc11.x86_64
mail-notification-evolution-plugin-5.4-10.fc11.x86_64

Plugin debugmessage:
e-data-server-ui-Message: Unable to find password(s) in keyring (Keyring reports: No matching results)
e-data-server-ui-Message: Key file does not have group 'Passwords-Exchange'

(evolution:19178): e-utils-WARNING **: No parent set, or default parent available for error dialog


Steps to Reproduce:
1. cleanup folder .evolution and .gconf/apps/evolution
2. setup a new account to connect to exchange server
3. on step 4, when authentication is checked, only an errormessage apears
  
Evolution-Exchange plugin is unusable within Fedora 11.

Screenshot of errormessage attached.
Comment 1 Thomas Kordelle 2009-06-26 07:45:48 EDT
Hi,

after a little bit of debugging i've found the problem. With in the gnome-settings a proxy (with authorization) was configured. This proxy is silently used by the exchange-plugin while doing the HTTP Authentication with the exchange server. The proxy returned a httpcode 407 which is silently eaten by the plugin (e2k-autoconfig.c:425). An unsusable errormessage is show instead the real problem and errorcode.

This handling must be changed to give the user a change to get the plugin working in any case of http or exchange-server errors.

With best regards
Thomas
Comment 2 Matthew Barnes 2009-06-28 22:33:10 EDT
Moving this upstream for better visibility.
Please see [1] for further updates.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=587263

Note You need to log in before you can comment on or make changes to this bug.