Bug 506095 - Beagle Plugin doesn't work with any mozilla products in F11
Beagle Plugin doesn't work with any mozilla products in F11
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: beagle (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Adel Gadllah
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-15 10:36 EDT by G. Michael Carter
Modified: 2010-06-28 09:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 09:01:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description G. Michael Carter 2009-06-15 10:36:37 EDT
I managed to solve so of the beagle problem by doing the following:

sudo ln -s /usr/lib/libgmime-2.4.so.2.4.3 /usr/lib/libgmime-2.0.so.2.4.3

The above only solved the plugin from reporting errors with beagle.   

Thunderbird however is reporting:

Error: uncaught exception: [Exception... "Not enough arguments [nsIMsgFolderNotificationService.addListener]"  nsresult: "0x80570001 (NS_ERROR_XPC_NOT_ENOUGH_ARGS)"  location: "JS frame :: chrome://beagle/content/beagleService.js :: anonymous :: line 286"  data: no]

If I do a drop everything I get a whole set of new errors:

Warning: XUL box for vbox element contained an inline #text child, forcing all its children to be wrapped in a block.
Source File: chrome://beagle/content/beagleUnindex.xul
Line: 0

Error: folder.path is undefined
Source File: chrome://beagle/content/beagleIndexer.js
Line: 416


After 8 hours of playing with this I'm still no closer to a solution.  Firefox doesn't work either but I haven't even started to look at why yet.  (As firefox I can use google to search.  Where thunderbird I have nothing due to a lack of searching on my companies IMAP server)
Comment 1 Bug Zapper 2010-04-27 10:56:47 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Bug Zapper 2010-06-28 09:01:59 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.