Bug 50611 - strange phantom printer definitions
strange phantom printer definitions
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: printconf (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-01 12:14 EDT by Gene Czarcinski
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-01 17:28:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
printconf-0.3.0-5 with two "phantom" entries1 (2.27 KB, text/plain)
2001-08-01 17:26 EDT, Gene Czarcinski
no flags Details
settings.xml (1.11 KB, text/xml)
2001-08-01 22:19 EDT, Crutcher Dunnavant
no flags Details
settings.xml (1.11 KB, text/plain)
2001-08-01 22:20 EDT, Crutcher Dunnavant
no flags Details

  None (edit)
Description Gene Czarcinski 2001-08-01 12:14:54 EDT
Description of Problem:
Define a remote unix lpd printer.
After deleting this printer, I tried to (re)define a printer with the name
"lp" -- would not "finish" and text message in the terminal window said
that "lp" alread exists.

Restarted printconf-gui and noticed a "strange" entry labeled "lp" but with
Queue Type "INVALID" and Details "Invalid Printer Record".

More attempts to define a printer produced some additional "Invalid Printer
Record" entries.

These records cannot be selected/deleted.

/etc/printcap shows nothing and /var/spool/lpd has nothing.

How Reproducible:


Steps to Reproduce:
1. Define "lp"
2. Delete "lp"
3. "define "lp"

Actual Results:
garbage

Expected Results:
valid entry

Additional Information:
Comment 1 Gene Czarcinski 2001-08-01 13:07:07 EDT
OK, this is not happening with printconf-0.3.6 from rawhide for NEW definitions
but I do I get rrid of the existing phantoms whithout blowing away this system.
Comment 2 Gene Czarcinski 2001-08-01 13:22:09 EDT
OK, the nature of this bug has changes.  I discovered printconf-tui and it does
see and can delete the phantom (INVALID Queue type records).  The problem is
that the gui interface cannot.
Comment 3 Crutcher Dunnavant 2001-08-01 16:28:15 EDT
can you do the following for me?

printconf-tui --Xexport > printer-settings.xml

and then attach printer-settings.xml to this bug? Thanks.

Comment 4 Glen Foster 2001-08-01 16:29:43 EDT
This defect is considered MUST-FIX for Fairfax
Comment 5 Gene Czarcinski 2001-08-01 17:26:09 EDT
Created attachment 25893 [details]
printconf-0.3.0-5 with two "phantom" entries1
Comment 6 Gene Czarcinski 2001-08-01 17:27:56 EDT
After creating the attachment, I was able to back with printconf-tui and delete
a bad entry but printconf-gui does not let me do this.
Comment 7 Crutcher Dunnavant 2001-08-01 22:09:01 EDT
hoho.

Well, I apparently didnt want people to try to edit invalid printer entries, so
I /explicitly/ made them unselectable. Which of course means you can not delete
them.

fixed. Thanks for spotting this one.
Comment 8 Crutcher Dunnavant 2001-08-01 22:12:13 EDT
btw, to fix your existing system, use the following attachement, and do:

printconf-tui --Ximport < settings.xml
Comment 9 Crutcher Dunnavant 2001-08-01 22:19:40 EDT
Created attachment 25932 [details]
settings.xml
Comment 10 Crutcher Dunnavant 2001-08-01 22:20:47 EDT
Created attachment 25933 [details]
settings.xml

Note You need to log in before you can comment on or make changes to this bug.