Bug 506116 - After install F11, Network Manager no longer connects automatically
After install F11, Network Manager no longer connects automatically
Status: CLOSED DUPLICATE of bug 498207
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-15 12:22 EDT by Steevithak
Modified: 2009-06-15 17:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-15 17:00:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steevithak 2009-06-15 12:22:14 EDT
Description of problem:
On previous versions of Fedora, Network Manager automatically connected my laptop to an available network, whether it was a WiFi or eth connection. The only time I needed to do anything was if the available network required a password to connect. Otherwise Network Manager made everything automatic and easy.

After installing F11, Network Manager always starts with no network connection, displaying a small red x on the icon. I have to manually select the network I want to connect with. Even after connecting to a network once, Network Manager doesn't seem to remember it and connect automatically next time that network connection is available.


Version-Release number of selected component (if applicable):
NetworkManager-0.7.1-4.git20090414.fc11.i586


How reproducible:
alway

Steps to Reproduce:
1. Install F11
2. Boot with a variety of physical and wifi nets available
3. 
  
Actual results:
No network connection is made until manually selected, regardless of what type of network is available

Expected results:
Network Manager manages my network connections, causing my computer to be connected to a network with minimal intervention from me.

Additional info:
I'm running F11 on a Dell Inspiron 8600 with an Intel 2200 WiFi card and a 10/100 Ethernet card. Both connections work fine when manually setup and both worked on previous versions of Fedora. 

There was briefly a bug in F10 that caused a similar problem but it was fixed. I wonder if this could be a recurrence of bug 489398?
Comment 1 Steevithak 2009-06-15 15:31:26 EDT
I just discovered one additional oddity related to this problem. Earlier today, I happened to be in range of the same WiFi net that was active when I installed F11. When I booted in this area, Network Manager connected automatically. But an hour later, when I booted up at my office with two WiFi nets available and a physical eth connected, Network Manager failed to make a connection until I manually selected a network. 

It appears NM will connect automatically *only* to the network that was present during the original install, but not to any other network. Hopefully this fact will help track down the cause of the bug.
Comment 2 Niels Haase 2009-06-15 17:00:53 EDT
Thanks for filling this bug. This particular bug has already been reported into our bug tracking system, but please feel free to report any further bugs you find.

Please find more information (and a workaround for the problem) here:
(This is also valid for wireless connections, but remember, you need first to login to GNOME because NM can connect automatic to the wireless network (the WEP/WPA and so on key is stored in the key-ring), only if the key-ring is accessible.

https://fedoraproject.org/wiki/Documentation_Networking_Beat#Ethernet_connections_are_not_started_at_first_boot

<SNIP>
You can use the NetworkManager tray icon to enable the ethernet interface you wish to use, but you would have to do this at each boot. To specify that an interface should always be started on boot, use the Network Connections tool: in the system menu, it is under System > Preferences > Network Connections. In the Wired tab, select the interface you wish to start at boot, and click Edit. Check the box marked Connect automatically, then click Apply, and quit the tool. 
</SNIP>

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 498207 ***

Note You need to log in before you can comment on or make changes to this bug.