Bug 506172 - nouveau kms fails with 2 monitors attached
nouveau kms fails with 2 monitors attached
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-15 16:33 EDT by klaas.hoelscher
Modified: 2009-12-04 13:53 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-04 13:53:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages (141.99 KB, application/octet-stream)
2009-06-15 16:35 EDT, klaas.hoelscher
no flags Details
output from xorg (88.20 KB, application/octet-stream)
2009-06-15 16:37 EDT, klaas.hoelscher
no flags Details
/var/log/messages without nouveau.modeset=1 (460.39 KB, application/octet-stream)
2009-06-16 14:00 EDT, klaas.hoelscher
no flags Details
x.org log after logging in, no kms (165.72 KB, text/plain)
2009-06-16 14:01 EDT, klaas.hoelscher
no flags Details

  None (edit)
Description klaas.hoelscher 2009-06-15 16:33:40 EDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b4) Gecko/20090427 Fedora/3.5-0.20.beta4.fc11 Firefox/3.5b4

Using a VGA compatible controller: nVidia Corporation GeForce 8500 GT (rev a1) with a fedora 11 install and enabling nouveau.modeset=1 locks up after loading gdm, with the boot-loader image as background. Attached is a 22 and a 24 inch screen.

While booting, nouveau sets the wrong resolution at the bigger screen, resulting in 2 black areas, because only an area as big as the smaller screen gets drawn. Eventually the smaller screen gets readjusted to 1024x768.



Reproducible: Always

Steps to Reproduce:
1. enable kms for nouveau
2. boot

Actual Results:  
unresponsive screen, needed reboot

Expected Results:  
should boot as usual with kms enabled
Comment 1 klaas.hoelscher 2009-06-15 16:35:32 EDT
Created attachment 348001 [details]
/var/log/messages
Comment 2 klaas.hoelscher 2009-06-15 16:37:20 EDT
Created attachment 348002 [details]
output from xorg
Comment 3 Ben Skeggs 2009-06-16 01:54:20 EDT
The behaviour you see with black areas is the way it's "supposed" to work currently, when you have mis-matches screen sizes.

However, the hang.  I assume X starts up fine with both displays connected if you boot without kms enabled?  Can I get your /var/log/Xorg.0.log from that also.
Comment 4 klaas.hoelscher 2009-06-16 04:00:01 EDT
Yes, it works fine without KMS, i can post the logfile later today.
I switched to nouveau.modeset=2, which works as it is supposed to.
Comment 5 klaas.hoelscher 2009-06-16 14:00:01 EDT
Created attachment 348143 [details]
/var/log/messages without nouveau.modeset=1

output after booting without kms
Comment 6 klaas.hoelscher 2009-06-16 14:01:19 EDT
Created attachment 348144 [details]
x.org log after logging in, no kms
Comment 7 Ben Skeggs 2009-08-23 19:43:22 EDT
I'm almost certain that this problem will have been resolved in rawhide already, the kms code has seen some substantial improvements since F11.  Is there any chance you could give this a try to confirm?
Comment 8 klaas.hoelscher 2009-08-26 01:44:40 EDT
I used the Fedora 12 Alpha to create a live image, works great with kms :)
Comment 9 Vedran Miletić 2009-12-04 13:53:23 EST
Closing per comment #8.

Note You need to log in before you can comment on or make changes to this bug.