Bug 506175 - anaconda tries to set up networking after partitioning; shuts down if network isn't available
anaconda tries to set up networking after partitioning; shuts down if network...
Status: CLOSED DUPLICATE of bug 505639
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
powerpc Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-15 16:41 EDT by Alex Kanavin
Modified: 2009-09-04 16:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-04 16:57:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda log (87.33 KB, text/plain)
2009-08-07 17:59 EDT, Alex Kanavin
no flags Details
program log (15.59 KB, text/plain)
2009-08-07 18:00 EDT, Alex Kanavin
no flags Details
storage log (154.24 KB, text/plain)
2009-08-07 18:00 EDT, Alex Kanavin
no flags Details
syslog (28.80 KB, text/plain)
2009-08-07 18:00 EDT, Alex Kanavin
no flags Details
anaconda log - askmethod (50.21 KB, text/plain)
2009-08-10 14:08 EDT, Alex Kanavin
no flags Details
program log - askmethod (20.70 KB, text/plain)
2009-08-10 14:08 EDT, Alex Kanavin
no flags Details
storage log - askmethod (85.70 KB, text/plain)
2009-08-10 14:08 EDT, Alex Kanavin
no flags Details
syslog - askmethod (29.21 KB, text/plain)
2009-08-10 14:09 EDT, Alex Kanavin
no flags Details
screen shot of the repo selection screen (122.54 KB, image/jpeg)
2009-08-28 12:54 EDT, Alex Kanavin
no flags Details

  None (edit)
Description Alex Kanavin 2009-06-15 16:41:10 EDT
I'm booting from a F11 PowerPC DVD. After partitioning and formatting the drive anaconda immediately brings up a network interface setup dialog for some reason - there's nothing on the virtual consoles that gives a hint. This shouldn't happen to begin with, and after I press 'Cancel' anaconda shuts itself down and prompts to reboot. Trying to force the interface setup doesn't help either - timout on dhcp, rinse, repeat (the computer isn't connected to anything at installation time). This effectively blocks F11 installation.
Comment 1 Chris Lumens 2009-06-29 11:20:00 EDT
Are you enabling the Fedora Updates repo or another repo only available via the network during installation?  If not, could you please attach /tmp/anaconda.log, /tmp/storage.log, etc. to this bug report so we can investigate why anaconda may want the network?  Thanks.
Comment 2 Alex Kanavin 2009-08-07 17:59:26 EDT
Created attachment 356718 [details]
anaconda log
Comment 3 Alex Kanavin 2009-08-07 18:00:05 EDT
Created attachment 356719 [details]
program log
Comment 4 Alex Kanavin 2009-08-07 18:00:27 EDT
Created attachment 356720 [details]
storage log
Comment 5 Alex Kanavin 2009-08-07 18:00:45 EDT
Created attachment 356721 [details]
syslog
Comment 6 Alex Kanavin 2009-08-07 18:02:39 EDT
I'm not enabling anything special - just trying to install a default configuration. The network dialog goes up immediately after partitioning and formatting, so I'm not even getting to the repository selection dialog. The logs have been attached.
Comment 7 Chris Lumens 2009-08-10 10:38:13 EDT
What happens if you add the "askmethod" parameter to your boot up arguments and manually tell anaconda the DVD contains the installation source?
Comment 8 Alex Kanavin 2009-08-10 14:07:40 EDT
Exactly same thing happens (plus the appearance of a dialog that asks me for installation source early on). I've attached the logs for this case as well.
Comment 9 Alex Kanavin 2009-08-10 14:08:12 EDT
Created attachment 356932 [details]
anaconda log - askmethod
Comment 10 Alex Kanavin 2009-08-10 14:08:37 EDT
Created attachment 356933 [details]
program log - askmethod
Comment 11 Alex Kanavin 2009-08-10 14:08:57 EDT
Created attachment 356934 [details]
storage log - askmethod
Comment 12 Alex Kanavin 2009-08-10 14:09:20 EDT
Created attachment 356935 [details]
syslog - askmethod
Comment 13 Aram Agajanian 2009-08-13 18:10:27 EDT
The Fedora Updates repo is to be enabled by default.  When you connect the computer to the Internet, you can proceed with the installation.
Comment 14 Aram Agajanian 2009-08-13 18:14:48 EDT
Correction:  The Fedora Updates repo _is_ enabled by default.
Comment 15 Alex Kanavin 2009-08-13 18:35:10 EDT
Any links/references to back up your claim? I believe the updates repo is in fact *not* enabled by default, and the only enabled repository is the installation media. I'm not even getting to the repo selection screen - the network interface dialog is shown before that.
Comment 16 Aram Agajanian 2009-08-13 18:57:00 EDT
I worked on an install yesterday.

My best recollection is that the repo selection screen is visible immediately after the connection to the Internet is established (via the dialog).

One the repo selection screen is visible, one can see that both the Fedora repo and the Fedora Updates repo are enabled by default.
Comment 17 Andy Lindeberg 2009-08-14 09:23:15 EDT
This has been incorrect in all my testing - Installation Repo and Updates Repo are *offered*, but only the Installation Repo and the "Office and Productivity" group in the box above are selected by default.

Can you attach a picture of the screen? If your install is enabling the Updates Repo by default, something somewhere is going really wrong.
Comment 18 Alex Kanavin 2009-08-28 12:54:27 EDT
Created attachment 359098 [details]
screen shot of the repo selection screen

Right. I attached an ethernet cable to make it through to the repo dialog and Aram is right - both installation and updates repo are selected by default, pictorial evidence attached. So something is clearly wrong here.
Comment 19 Chris Lumens 2009-08-28 15:48:15 EDT
Those checkboxes are controlled by the repo config files in /etc/anaconda.repos.d.  Can you please verify whether or not the updates repo has enabled=1?  Sorry for all the leg work, but this is how it goes when we're unable to reproduce a problem.
Comment 20 Alex Kanavin 2009-08-29 04:09:42 EDT
Yes - the updates repo has enabled=1, and so does the main fedora repo. If I manually edit the updates repo file before starting the installation to have enabled=0 then it doesn't get deselected but simply disappears from the list. Before that the network dialog still shows, and main repo database is still retrieved from the internet.

If I also disable the main repo, then the installer simply says it can't proceed because it can't read the repo info.

So the problem might be something else entirely. Why is the repo on the DVD not picked up?
Comment 21 Chris Lumens 2009-09-04 16:57:16 EDT

*** This bug has been marked as a duplicate of bug 505639 ***

Note You need to log in before you can comment on or make changes to this bug.