Bug 506270 - Firefox 3.5b4 does not "see" PackageKit-browser-plugin
Firefox 3.5b4 does not "see" PackageKit-browser-plugin
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
: 514473 (view as bug list)
Depends On: 511385
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-16 09:57 EDT by Hugo Melo
Modified: 2010-04-29 04:39 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-29 04:39:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hugo Melo 2009-06-16 09:57:11 EDT
Description of problem:
Using Firefox 3.5-beta4 in Fedora 11 I don't see the Packagekit plugin loaded.
Other plugins are showed.

Version-Release number of selected component (if applicable):
PackageKit-browser-plugin-0.4.6-8.fc11.i586
firefox-3.5-0.20.beta4.fc11.i586

How reproducible:
Everytime.

Steps to Reproduce:
1. Install PackageKit-browser-plugin
2. Restart Firefox
3. open a tab: about:plugins
  
Actual results:
- No packagekit plugins being showed

Expected results:
- A packagekit entry in about:plugins

Additional info:
Worked on earlier releases.
Comment 1 Richard Hughes 2009-06-16 10:34:43 EDT
The PackageKit plugin hasn't changed since Fedora 10 -- I assume something has changed in Firefox to make the plugin no longer load. Unfortunately, I don't know how to debug this, so I'll reassign to firefox. If it really is a PackageKit bug, please reassign but with some helpful debugging tips. Thanks!
Comment 2 Christopher Aillon 2009-06-17 14:10:19 EDT
Martin, please have a look here.
Comment 3 Martin Stransky 2009-06-18 02:20:43 EDT
Reporter, can you attach output of 

rpm -qa \*nspluginwrapper\* \*PackageKit-browser\*

thanks
Comment 4 Richard Hughes 2009-06-18 03:08:34 EDT
[hughsie@hughsie-laptop ~]$ rpm -qa \*nspluginwrapper\* \*PackageKit-browser\*
PackageKit-browser-plugin-0.5.0-0.1250.20090617git.fc11.i586
nspluginwrapper-1.3.0-5.fc11.i586
Comment 5 Richard Hughes 2009-06-18 03:09:07 EDT
(that's my local machine, also happens with PackageKit-browser-plugin-0.4.x)
Comment 6 John Walicki 2009-06-18 09:45:31 EDT
$ rpm -qa \*nspluginwrapper\* \*PackageKit-browser\*
nspluginwrapper-1.3.0-5.fc11.i586
c4eb-config-nspluginwrapper-5.20-2.oc2.noarch
PackageKit-browser-plugin-0.4.6-8.fc11.i586

You'll ask what the c4eb-config-nspluginwrapper package does, so I'll put that in a separate comment.
Comment 7 John Walicki 2009-06-18 09:49:32 EDT
We're customizing the nspluginwrapper depending whether our users are running on 64bit or 32bit systems.  I don't think its related to the problem with PackageKit-browser-plugin however.

$ rpm -q c4eb-config-nspluginwrapper-5.20-2.oc2.noarch --scripts

postinstall scriptlet (using /bin/sh):
if [ `uname -m` != "x86_64" ]; then 
  PLUGINS=":nppdf*:npgpws*"
else
  PLUGINS=""
fi
if ! grep "IGNORE_WRAP=\$IGNORE_WRAP" /etc/sysconfig/nspluginwrapper > /dev/null 2>&1; then
  echo "export IGNORE_WRAP=\$IGNORE_WRAP\"${PLUGINS}\" # Open Client Do Not Modify" >> /etc/sysconfig/nspluginwrapper
else
  sed -i "s|export IGNORE_WRAP=\$IGNORE_WRAP*.*|export IGNORE_WRAP=\$IGNORE_WRAP\"${PLUGINS}\" # Open Client Do Not Modify|g" /etc/sysconfig/nspluginwrapper
fi

# reconfigure the wrapper
/usr/bin/mozilla-plugin-config -r > /dev/null 2>&1 || :
/usr/bin/mozilla-plugin-config -i -f > /dev/null 2>&1 || :
exit 0
Comment 8 Hugo Melo 2009-06-24 08:56:56 EDT
In a clean Fedora installation:
 PackageKit-browser-plugin-0.4.8-1.fc11.i586
 nspluginwrapper-1.3.0-5.fc11.i586
Nothing related to c4eb-config-nspluginwrapper. The problem persists without installing the IBM layer.
Comment 9 Martin Stransky 2009-06-24 11:37:34 EDT
Which mime types are handled by PackageKit-browser-plugin? Because recently it returns none so mozilla ignores it.
Comment 10 Richard Hughes 2009-06-24 12:46:22 EDT
(In reply to comment #9)
> Which mime types are handled by PackageKit-browser-plugin? Because recently it
> returns none so mozilla ignores it.  

application/x-packagekit-plugin

I'm slightly confused, as it used to work. Suggestions welcome. The code is here if you're interested: http://cgit.freedesktop.org/packagekit/tree/contrib/browser-plugin
Comment 11 Martin Stransky 2009-06-25 05:54:24 EDT
The problem is that PackageKit-browser-plugin does not export NP_GetMIMEDescription(). It exports only NPP_GetMIMEDescription(), which is not correct. see:

http://gplflash.sourceforge.net/gplflash2_blog/npapi.html#SEC9
https://developer.mozilla.org/En/NP_GetMIMEDescription

I think just rename NPP_GetMIMEDescription() -> NP_GetMIMEDescription() should work here.
Comment 12 Richard Hughes 2009-06-25 07:17:19 EDT
I've done this, and it now displays correctly in about:plugins. It still doesn't work tho, with the test page[1] coming up as blank.

[1] http://cgit.freedesktop.org/packagekit/plain/contrib/browser-plugin/tests/test.html
Comment 13 Christopher Aillon 2009-06-30 14:46:03 EDT
Martin, please take the time to figure out what code changes are needed in PK to make this work.  It's a pretty important bug to solve.  Thanks.
Comment 14 Richard Hughes 2009-07-01 10:39:39 EDT
Martin, if you want to build the sources, you can do:

yum install glib2-devel dbus-devel dbus-glib-devel pam-devel libX11-devel xmlto sqlite-devel NetworkManager-glib-devel polkit-devel libtool docbook-utils gnome-doc-utils python-devel intltool gettext xulrunner-devel libarchive-devel gstreamer-devel gstreamer-plugins-base-devel qt4-devel cppunit-devel pango-devel fontconfig-devel

git clone git://anongit.freedesktop.org/git/packagekit/PackageKit
git branch --track PACKAGEKIT_0_4_X origin/PACKAGEKIT_0_4_X
git checkout PACKAGEKIT_0_4_X

./autogen.sh --with-enable-default-backend=yum --enable-yum --enable-dummy --disable-tests --disable-gtk-doc

Then the plugin is located in contrib/browser-plugin
Comment 15 Martin Stransky 2009-07-07 05:04:20 EDT
okay, will take a look.
Comment 16 Richard Hughes 2009-07-14 17:24:04 EDT
Okay, I've got the plugin to work with xulrunner after some in depth debugging. It now needs a patch to nspluginwrapper to exclude the packagekit plugin, just like the totem one. I've opened a bug for this, and will merge the new plugin code to PackageKit git master in the next few days. I'll make packages available then too.
Comment 17 John Walicki 2009-07-14 22:53:52 EDT
@Richard - Excellent work - Thanks!
Comment 18 Richard Hughes 2009-07-15 06:29:31 EDT
There's a test package here: http://people.freedesktop.org/~hughsient/fedora/11/SRPMS/PackageKit-0.5.1-0.1272.20090715git.fc11.src.rpm

You'll need polkit and polkit-gnome from rawhide to use this package. I'll probably backport this to 0.4.x for a release in a couple of weeks.

If you're desperate for a patch against f11, yell and I can russle up a package without too many problems.
Comment 19 Hugo Melo 2009-08-04 10:33:32 EDT
Hey Richard,
I talked to you some days ago. You said you had some other fixes to add and would backport it to Fedora 11. Do you already have a 0.4.X release I can incorporate to Fedora 11?
Comment 20 Martin Stransky 2009-08-12 07:37:22 EDT
Moving back to PackageKit component.
Comment 21 Richard Hughes 2009-08-12 08:12:48 EDT
(In reply to comment #19)
> I talked to you some days ago. You said you had some other fixes to add and
> would backport it to Fedora 11. Do you already have a 0.4.X release I can
> incorporate to Fedora 11?  

Hey Hugo. Martin "legend" Stransky has recently made the plugin work with WebKit and so I'll be backporting the plugin code to 0.4.x when I've done some 64 bit testing, hopefully today. I don't think I'll be updating Fedora 11 until 3 weeks time, but I can do a F11 scratchbuild in koji for you if you want.

Richard.
Comment 22 Hugo Melo 2009-08-12 13:17:39 EDT
Hey Richard,
Thanks for the good news. I would like to get a koji build if it's easy to you.
You need some help you can ask me!
Comment 23 Richard Hughes 2009-08-18 09:56:12 EDT
Preview build here: http://koji.fedoraproject.org/koji/taskinfo?taskID=1612276
Comment 24 Hugo Melo 2009-08-18 16:25:13 EDT
Hey Richard,
I've just tested your new package..

rpm -qa \*PackageKit\*
PackageKit-glib-0.4.10-0.1.20090818git.fc11.i586
PackageKit-yum-0.4.10-0.1.20090818git.fc11.i586
PackageKit-browser-plugin-0.4.10-0.1.20090818git.fc11.i586
PackageKit-yum-plugin-0.4.10-0.1.20090818git.fc11.i586
PackageKit-qt-0.4.10-0.1.20090818git.fc11.i586
PackageKit-0.4.10-0.1.20090818git.fc11.i586
PackageKit-gtk-module-0.4.10-0.1.20090818git.fc11.i586

I decided don't install the other packages built together because it's the default we have installed on Fedora 11.

- It showed all the buttons,
- when a package is installed (firefox) you can see the version there,
- when a package is not available it shows the message,
- I could click to install and it showed
"installing...", but instantly came back to a button clearly not installing that...

The PackageKit backend is not being called, I think. How can I get a log or debug the package?
Thanks!
Comment 25 Hugo Melo 2009-09-02 09:13:57 EDT
Hey Richard,
I've discovered the plugin doesn't work using kde. Tested using gnome and kde on some laptops. with gnome it works, with kde it doesn't.
Comment 26 Steven M. Parrish 2009-09-12 20:52:56 EDT
*** Bug 514473 has been marked as a duplicate of this bug. ***
Comment 27 Hugo Melo 2009-10-08 16:55:29 EDT
Hey Richard
Here in IBM, we are having an issue using  PackageKit-browser-plugin-0.4.10-0.1.20090818git.fc11.i586.rpm in Fedora 11.
The environment we use here is:
We have a page with links to package pages. These package pages have some description about the package and the packagekit entry for installing the package.
When we click on one package, go back to the links page and click on other package, the packagekit box doesn't show. And any other page I click I see the issue. I can't install any other package until I restart firefox.
I couldn't reproduce it on Fedora 11, but saw on Fedora 12 using 0.5.3.
Can you take a look at this?
Thanks!
Comment 28 Hugo Melo 2009-12-02 11:20:18 EST
Hey Richard,
As I've reported by mail it's the issue I get when I try to use packagekit-browser-plugin in Fedora 12 (last updated packages).


hugo@Fedora ~$:firefox
** (firefox:14622): DEBUG: installed    firefox;3.5.5-1.fc12;i686;installed     Mozilla Firefox Web browser
FN:pk-plugin-install.c FC:pk_plugin_install_get_best_desktop_file LN:200
!!      failed to open database: can't open database: out of memory
** (firefox:14622): DEBUG: available    kdeedu;4.3.3-2.fc12;i686;updates        Educational/Edutainment applications
** (firefox:14622): DEBUG: available    gnubg;1:0.9.0.1-8.fc12;i686;fedora      A backgammon game and analyser
** (firefox:14622): DEBUG: installed    f-spot;0.6.1.5-1.fc12;i686;installed    Photo management application
terminate called after throwing an instance of 'std::bad_alloc'
  what():  std::bad_alloc
/usr/lib/firefox-3.5.5/run-mozilla.sh: line 131: 14622 Aborted                 (core dumped) "$prog" ${1+"$@"}

PackageKit-browser-plugin-0.5.4-0.4.20091029git.fc12.i686
Comment 29 Bug Zapper 2010-04-27 10:58:31 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 30 Alex Lancaster 2010-04-28 19:31:11 EDT
According to comment #28, still in F-12.
Comment 31 Hugo Melo 2010-04-28 21:14:31 EDT
I can confirm it's still crashing my Firefox using F-12.
Comment 32 Alex Lancaster 2010-04-28 22:04:42 EDT
(In reply to comment #31)
> I can confirm it's still crashing my Firefox using F-12.    

This bug was originally about whether you could "see" the plugin using "about:plugins", it seems to be working now as far as that part goes.

As for crashing I also get that and I opened up bug #587117.  If your crash is the same or similar as that bug, I suggest you Cc yourself to that bug and we can close this one.
Comment 33 Richard Hughes 2010-04-29 04:39:43 EDT
(In reply to comment #32)
> This bug was originally about whether you could "see" the plugin using
> "about:plugins", it seems to be working now as far as that part goes.

Agreed, thanks.

Note You need to log in before you can comment on or make changes to this bug.