Bug 50629 - Error during ping
Error during ping
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-01 15:01 EDT by Need Real Name
Modified: 2007-04-18 12:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-06 12:21:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-08-01 15:01:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-12 i686)

Description of problem:
I get: Warning: time of day goes back, taking counter measures.

This happens when I ping 127.0.0.1.

How reproducible:
Always

Steps to Reproduce:
1.ping 127.0.0.1
2.
3.
	

Actual Results:  PING 127.0.0.1 (127.0.01) from 127.0.0.1: 56(84) bytest of
data.
Warning: time of day goes back, taking countermeasures.
64 bytes from 127.0.0.1 icmp_seq=0 ttl=255 time=862 usec
64 bytes from 127.0.0.1 icmp_seq=1 ttl=255 time=72 usec


Additional info:

No warning
Comment 1 Michael Schwendt 2001-08-11 02:44:09 EDT
Duplicate of bug #37485.
Comment 2 Gary L. Fournerat, MCP 2001-09-07 16:43:29 EDT
I believe the user is setup with an incorrect timezone. I recently (Sept 7th) 
realized I have this same problem, and I'm currently running a testcase to 
prove/disprove the solution.

I have been using GMT -0500 when I should have been at -0600 (Dallas) all 
along.
Comment 3 Need Real Name 2001-09-07 18:18:12 EDT
FYI-
<pasted from http://www.samag.com/quest/archive/2001/0248.htm>

This is a problem with the iputils-20001110-1 package -- specifically the 
pr_pack routine in ping.c (you'll even notice you get that error while pinging 
localhost). Updating (upgrading) the package will resolve the problem. 

Comment 4 Gary L. Fournerat, MCP 2001-09-08 02:30:40 EDT
updating (upgrading) to iputils-20001110-5 did not correct my problem...

but here's what did:

1. Selected my favorite package manager
2. Uninstall iputils-20001110-5
3. Download iputils-20000418-6 
(ftp.rpmfind.net/linux/redhat/7.0/en/os/i386/RedHat/RPMS/)
4. rpm -ivh iputils-20000418-6.i386.rpm

and everything works just fine once again. :)

Note You need to log in before you can comment on or make changes to this bug.