Bug 506293 - Framing error brings down cluster.
Framing error brings down cluster.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
1.2
All Linux
high Severity urgent
: ---
: ---
Assigned To: William Henry
MRG Quality Engineering
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-16 11:59 EDT by William Henry
Modified: 2009-06-18 15:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-18 15:47:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log and tool output of the failure. (29.62 KB, text/plain)
2009-06-16 11:59 EDT, William Henry
no flags Details

  None (edit)
Description William Henry 2009-06-16 11:59:53 EDT
Created attachment 348127 [details]
Log and tool output of the failure.

Description of problem:

[There is an attachment]


Both brokers in the cluster shutdown:

Broker 1:
2009-jun-16 09:14:30 error Error decoding events: framing-error: Framing version unsupported (qpid/framing/AMQFrame.cpp:113)
2009-jun-16 09:14:30 notice 192.168.2.14:11860(LEFT) leaving cluster TestCluster
2009-jun-16 09:14:30 notice Shut down

Broker 2:
2009-jun-16 09:14:30 error Error decoding events: framing-error: Framing version unsupported (qpid/framing/AMQFrame.cpp:113)
2009-jun-16 09:14:30 notice 192.168.2.15:11964(LEFT) leaving cluster TestCluster
2009-jun-16 09:14:30 notice Shut down

Version-Release number of selected component (if applicable):

1.1.2

How reproducible:

See attached file.


  
Actual results:


Expected results:


Additional info:
Comment 1 William Henry 2009-06-16 12:09:47 EDT
The customer is using 1.1.1 clients.  And I wonder if there are framing incompatibilities between 1.1.1 and 1.1.2  

Begs the question, if this is the problem, whether it's acceptable to have errata not compatible at the framing level.
Comment 2 Gordon Sim 2009-06-17 14:19:17 EDT
May have been solved by upgrading to correct openais version.
Comment 3 William Henry 2009-06-18 15:47:04 EDT
Solved by upgrading their openais version. Not a bug.

Note You need to log in before you can comment on or make changes to this bug.