Bug 506295 - As of Fedora 11, the 'at' package pulls in all of hal
As of Fedora 11, the 'at' package pulls in all of hal
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: at (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-16 12:11 EDT by Ben Webb
Modified: 2009-10-12 12:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-21 06:54:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Webb 2009-06-16 12:11:47 EDT
Description of problem:
We typically do not run hal on our servers and compute nodes - only on our desktops. However, when upgrading to F11, hal is now required on these machines (it was not required in F10). This is because the at package now requires pm-utils, which in turn needs hal. We never turn off our servers, so don't need at to be suspend/resume aware, but would like to have the at utility.

Version-Release number of selected component (if applicable):
at-3.1.10-30.fc11.i586


How reproducible:
Always.

Steps to Reproduce:
1. rpm -e hal hal-info
  
Actual results:
Cannot remove the hal package:
error: Failed dependencies:
	hal is needed by (installed) pm-utils-1.2.5-2.fc11.i586

rpm -e hal hal-info pm-utils reports:
error: Failed dependencies:
	pm-utils is needed by (installed) at-3.1.10-30.fc11.i586


"rpm -e hal hal-info pm-utils at" succeeds, but obviously removes the at package as well.


Expected results:
hal package is removed.
Comment 1 Marcela Mašláňová 2009-06-17 02:58:28 EDT
I've added pm-utils for problems with hibernation/suspend. I assume pm-utils and hal will be installed by default. 

The only solution could be create subpackage of at, which requires pm-utils. This subpackage could be installed only on desktop.
Comment 2 Marcela Mašláňová 2009-06-17 03:28:09 EDT
Even better solution will be move the script which cause the dependency into pm-utils. I've opened new bug on pm-utils for inclusion.
Comment 3 Curtis Doty 2009-10-11 17:53:40 EDT
Please rebuild for F-11 without pm-utils dep. It drags in the kitchen sink.
Comment 4 Marcela Mašláňová 2009-10-12 03:11:40 EDT
It's not so easy as rebuilt without pm-utils. At provides script which is owned by at, but the directory where is this script stored is owned by filesystem and dhclient. This is not true for F-11 and I'd rather not change in it for released version.
Comment 5 Curtis Doty 2009-10-12 12:46:52 EDT
Okay, thanks for looking. I've cooked a local at package that doesn't drag in the kitchen sink on minimalist F-11 systems.

Note You need to log in before you can comment on or make changes to this bug.