Bug 5063 - raidtools do not inform user the they >must< use "persistent-superblock 1" in their raids
raidtools do not inform user the they >must< use "persistent-superblock 1" in...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: raidtools (Show other bugs)
6.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Erik Troan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-09-10 22:15 EDT by mrovner
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-24 13:12:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mrovner 1999-09-10 22:15:44 EDT
Since raidadd/raidrun have been replaced with raidstart
and raidstart lacks some of the functionality of starting
raid devices, the user must use "persistent-superblock 1"
for each raid device, or when the raid is stopped,
raidstart will not start it.

All the /etc/raidtab is fine, but without this option in
each raiddev stanze, if you raidstop the device, the
next time I try to raidstart it, I messages in
/var/log/messages of the type:

	kernel: (read) sdc1's sb offset: 8883840 [events: ea5fe76b]
	kernel: md: invalid raid superblock magic on sdc1
	kernel: md: sdc1 has invalid sb, not importing!
	kernel: could not import sdc1!
	kernel: autostart sdc1 failed!
	kernel: huh12?

Simply adding the persistant-superblock removes this
problem.  Without it, the first time you reboot, you lose
your raid.

It would be nice if this were documented as a "must do",
and if it were mentioned in all the sample raidtabs in
/usr/doc/raidtools-0.90, not just raid0.conf.sample in
that direcotory.
Comment 1 Erik Troan 2000-02-24 13:12:59 EST
This is fixed now.

Note You need to log in before you can comment on or make changes to this bug.