Bug 50633 - X Customization hangs after test screen resolution
X Customization hangs after test screen resolution
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i586 Linux
medium Severity low
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-01 15:27 EDT by Danny Trinh
Modified: 2007-04-18 12:35 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-20 15:29:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Danny Trinh 2001-08-01 15:27:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 98; DigExt)

Description of problem:
During install Fairfax beta3 (using text mode), X customization hangs 
after I test screen resolution. The installation process can't be 
completed.


How reproducible:
Always

Steps to Reproduce:
1.Boot from CD1, select text mode
2.At the very end of installation process, choose to customize the X, run 
test screen resolution.
3.The screen will be hung up at X Customization screen.
	

Actual Results:  Unable to finish installation process by using text mode. 
However, I can finish the installation process by using GUI mode.

Expected Results:  Must be able to finish the installation process with 
the ability to configure X.

Additional info:
Comment 1 Glen Foster 2001-08-01 15:37:46 EDT
What specific video hardware (controller and monitor) are you using, and can you
give us the PCI IDs for them, please?
Comment 2 Danny Trinh 2001-08-01 15:45:25 EDT
I saw this bug in two system (PE1300, PE1400). Video chipset are embeded.

PE1300:
 -Video Card: ATI Mach64 3D Rage IIC
 -Video RAM: 2048

PE1400:
 -Video card: ATI Mach64
 -Video RAM: 4096
Comment 3 Danny Trinh 2001-08-01 15:47:45 EDT
Oops, I use Dell's P780 monitor. I think this is not necessary, because there 
is no problem when I use GUI method to install.
Comment 4 Michael Fulbright 2001-08-01 16:00:57 EDT
The X configuration is the last thing done during the install. Any bootloader
and boot floppy has already been written. You should be able to reboot into the
system and run Xconfigurator to setup X.

The same code is used to test an X configuration in GUI and TUI modes.  I have
seen bad behavior of XFree86 4.x drivers from time to time.

Does it happen in text mode if you boot the installer using:

nofb text

?
Comment 5 Danny Trinh 2001-08-01 17:14:43 EDT
Yes, It happens in text mode if you boot the installer using:
nofb text.

Xconfigurator works OK.
Comment 6 Michael Fulbright 2001-08-06 18:14:13 EDT
Brent - 

 Please try to reproduce with our closest hardware.
Comment 7 Brent Fox 2001-08-08 16:32:50 EDT
I've tried unsuccessfully on a PowerEdge 6300 to reproduce this behavior.  It
has an embedded ATI Rage 128 graphics chip with 2048kb of RAM.  Testing the X
configuration in text mode at 16 bit color depth and 1024x768 resolution works
fine for me.  Were you trying different resolutions or color depths perhaps?
Comment 8 Brent Fox 2001-08-08 16:37:54 EDT
The following tests I tried were:
8 bit color:
 640x480
 800x600
 1024x768
 1152x864
 1280x1024

16 bit color:
 640x480
 800x600
 1024x768
Comment 9 Danny Trinh 2001-08-08 17:10:35 EDT
I use 16 bit color depth and 1024x768 resolution. Only PE1300, PE1400 have this 
problem.
PE1300:
 -Embedded Video Card: ATI Mach64 3D Rage IIC
 -Video RAM: 2048

PE1400:
 -Embedded Video card: ATI Mach64
 -Video RAM: 4096

The other servers using ATI chip also, but they work fine.
Comment 10 Bill Nottingham 2001-08-09 11:38:02 EDT
Brent, msf: we have pe1300/pe1400 in the lab. Check with bobm.
Comment 11 Brent Fox 2001-08-09 15:55:33 EDT
Ok, I got a PE1400 from bobm and I could not reproduce the problem.  The
installer was unable to probe the monitor because it ran through the KVM.  The
generic monitor setting would only allow me to test at 640x480, but this worked
ok.  Then, I manually set the monitor to "Dell P991", and then I could test at
all available resolutions.  The graphics card was an ATI Mach64 with 4096 kb of
video RAM.

I don't know what else to do on this bug but resolve as 'worksforme'.
Comment 12 Danny Trinh 2001-08-13 10:15:05 EDT
I retested and duplicated this problem every time ( 3 times).
Below steps are what I did:
- Choose text mode installation.
- At the "X Customization" screen, select:
   - Default Desktop: KDE
   - Default Login: Text
- Use cursor to select "Test" button, then press Enter.
- Use mouse click on "yes"
- The "X Customization" screen come back. And It hung up.
Comment 13 Brent Fox 2001-08-13 19:16:21 EDT
I tried again with today's build on the PE1400 and again I could not reproduce.
 Everything works ok for me.  I don't know what steps to take next...
Comment 14 Bill Nottingham 2001-08-14 01:37:42 EDT
What kind of mouse?
Comment 15 Danny Trinh 2001-08-14 11:24:03 EDT
I'm using Microsoft IntelliMouse.
Comment 16 Brent Fox 2001-08-15 00:43:55 EDT
I was using a two button Dell mouse (made by Logitech).  Can you try with a
non-wheel mouse?
Comment 17 Danny Trinh 2001-08-15 11:34:35 EDT
Yes, It works. So, what's wrong with Microsoft Intellimouse?
Comment 18 Brent Fox 2001-08-15 12:06:25 EDT
I've seen this before...are you specifically selecting Microsoft IntelliMouse in
the mouse selection screen?  I've seem some IntelliMice go completely bonkers in
X if they are set to PS/2 instead of IMPS/2.
Is it a PS/2 mouse or USB?  If it's ps/2, I'm not sure there's much we can do.
Comment 19 Danny Trinh 2001-08-16 14:29:06 EDT
-Either generic mouse, or intellimouse, ---> same result.
- PS2 mouse.
Comment 20 Brent Fox 2001-08-18 11:44:30 EDT
I have three old IntelliMice at home that I'll bring to work on Monday and see
if I can duplicate this.  One is an OEM version and two are retail.  You can
tell the difference because the OEM versions are very smooth while the retail
versions have more of a matte finish.  Which does yours have?

Do you happen to know how old your mouse is?  My two retail versions say that
they are Version 1.1A.  The OEM version has no information on it.  Do you have
another IntelliMouse you could try?
Comment 21 Danny Trinh 2001-08-20 15:28:56 EDT
I have a retail version.
Any way, It seems to work with RC1. I don't know what changed between beta3 and 
RC1, but it works.
We can close this issue.
Comment 22 Brent Fox 2001-08-21 13:54:57 EDT
I guess the problem was with the X server somehow.  There weren't any changes to
anaconda that would account for differences between beta 3 and RC1.  Bugs that
just disappear always worry me, because you don't know when they'll reappear.  I
guess we'll leave this one alone, though.

Note You need to log in before you can comment on or make changes to this bug.