Bug 506342 - multi-org, org trusts, channels consumed "systems" column should either be removed or able to pick up systems from other orgs
multi-org, org trusts, channels consumed "systems" column should either be re...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
530
All Linux
high Severity high
: ---
: ---
Assigned To: Shannon Hughes
wes hayutin
https://rlx-2-04.rhndev.redhat.com/rh...
:
Depends On:
Blocks: 456998
  Show dependency treegraph
 
Reported: 2009-06-16 14:55 EDT by wes hayutin
Modified: 2009-09-10 15:49 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 15:49:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
consumed channels by other orgs (156.85 KB, image/png)
2009-06-16 14:55 EDT, wes hayutin
no flags Details

  None (edit)
Description wes hayutin 2009-06-16 14:55:47 EDT
Created attachment 348151 [details]
consumed channels by other orgs

Description of problem:
multi-org, org trusts, channels consumed "systems" column should either be removed or able to pick up systems from other orgs

6/12.1

recreate:
create three orgs A, B, C

A shares channels out to B and C
B and C consume channels shared by A

in A go to org trusts -> org B or org C, channels consumed
look at the systems column

to display the number of systems consuming the orgs shared channels you would have to have access to those those system lists.  

Either add access to get the list 
or 
remove the column

see screenshot
Comment 1 Clifford Perry 2009-06-17 10:44:19 EDT
Looking at screen shot - also reading the text above that describes that page - the # should be correct. Since the systems are in other orgs, the # should not be a link though to see the systems, since we do not allow you to see other orgs details. Tell you the channel is being used by other orgs sounds right. 

So to me, keep column, make sure it is correct and make it a read only value. 

Cliff
Comment 2 Shannon Hughes 2009-06-17 17:37:18 EDT
fixed, 0c8e0d874d632b4aa3ba6a39bc8303690c6ea753

- system count is fixed
- removed link for system count
- added default of 0 if system count returns null
Comment 3 Shannon Hughes 2009-06-19 11:49:15 EDT
mass move to onqa
Comment 4 wes hayutin 2009-06-23 11:58:17 EDT
verified 6/19
Comment 5 John Matthews 2009-07-30 15:10:05 EDT
Moving to RELEASE_PENDING

Looking at:
/rhn/multiorg/OrgTrustDetails.do

I see (systems in your organization consume 4 of these) 

This is correct
Comment 6 Brandon Perkins 2009-09-10 15:49:14 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.