Bug 506348 - i386 pv guests are uninstallable on x86_64 dom0 amd quad-core opteron 8356 processors
i386 pv guests are uninstallable on x86_64 dom0 amd quad-core opteron 8356 p...
Status: CLOSED DUPLICATE of bug 504988
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.4
All Linux
high Severity high
: beta
: ---
Assigned To: Xen Maintainance List
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-16 15:21 EDT by Gurhan Ozen
Modified: 2013-11-03 20:42 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-17 04:29:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gurhan Ozen 2009-06-16 15:21:35 EDT
Description of problem:

  Trying to install an i386 paravirt guests on a machine with amd quad-core opteron processor causes kernel crash with:


Unable to handle kernel paging request------------[ cut here ]------------
kernel BUG at include/asm/mach-xen/asm/maddr.h:34!
invalid operand: 0000 [#1]
SMP 
Modules linked in:
CPU:    0
EIP:    0061:[<c0113fbf>]    Not tainted VLI
EFLAGS: 00010006   (2.6.9-89.ELxenU) 
EIP is at do_page_fault+0x7ab/0x867
 

Version-Release number of selected component (if applicable):
dom0: 

RHEL5.4-Server-20090616.nightly tree
# rpm -qa | grep xen
kernel-xen-2.6.18-153.el5
xen-libs-3.0.3-88.el5
xen-libs-3.0.3-88.el5
kernel-xen-devel-2.6.18-153.el5
xen-3.0.3-88.el5

domU:
rhel4-u8 released.

How reproducible:
Very. This is with less than 64 GB of ram. 

Steps to Reproduce:
1. The particular machine I used was hp-dl785g5-01.rhts.bos.redhat.com .
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Chris Lalancette 2009-06-17 04:29:28 EDT
Gurhan,
    Hm, logging onto hp-dl785g5-01.rhts.bos.redhat.com, I see that it actually has 128GB of memory (look at the output from xm info).  We automatically limit the *dom0* memory to 32GB, though.  In any case, on a machine with > 64GB, i386 RHEL-4 Xen is known broken, so I'm going to close this as a dup of 504988.

Chris Lalancette

*** This bug has been marked as a duplicate of bug 504988 ***
Comment 2 Joshua higgins 2010-02-02 11:40:20 EST
I don't believe this is still fixed.  Since 5u2, dom0's with greater than 64GB of ram cannot install i386 guest vms.  Solution has always been to use less ram than 64GB. This is still reproducible in 5u4 x86_64 dom0 with 5u2 i386 vms (as well as 5u3 vms; 5u4 guests however, do work).

This isn't a solution though and its still a problem after 3 updates!
Comment 3 Chris Lalancette 2010-02-02 11:59:48 EST
(In reply to comment #2)
> I don't believe this is still fixed.  Since 5u2, dom0's with greater than 64GB
> of ram cannot install i386 guest vms.  Solution has always been to use less ram
> than 64GB. This is still reproducible in 5u4 x86_64 dom0 with 5u2 i386 vms (as
> well as 5u3 vms; 5u4 guests however, do work).
> 
> This isn't a solution though and its still a problem after 3 updates!    

Well, that is actually a different bug.  There was a bug in the *guest* kernel on hosts with > 64GB of RAM; that bug was fixed in 5.4, so you'll need to update your guest kernel to at least 5.4 to run i386 guests on x86_64 dom0's with > 64GB of RAM.

Chris Lalancette

Note You need to log in before you can comment on or make changes to this bug.