Bug 506356 - initrd fails to find root dev on pcmcia usb host
initrd fails to find root dev on pcmcia usb host
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
11
i686 Linux
low Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-16 16:33 EDT by Jón Fairbairn
Modified: 2010-01-12 10:31 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-12 10:31:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jón Fairbairn 2009-06-16 16:33:36 EDT
Description of problem:
If the root device is connected to a pcmcia card usb adaptor, the initrd made by mkinitrd (and anaconda) waits for the usb devices to be ready /before/ loading yenta_socket, and then doesn't wait while the devices are actually found.

Version-Release number of selected component (if applicable):
mkinitrd-6.0.86-2.fc11.i586

How reproducible:
Every time

Steps to Reproduce:
1. Use a live cd to install fedora 11 onto a drive connected to a pcmcia usb adaptor, but with a boot partition on the local hard drive.

2. attempt to boot the new system

3.
  
Actual results:
Complains it can't find the root device and fails to boot.

Expected results:
should start F11 with root on the external drive

Additional info:

The problem is solved by moving the 
lines
+echo "Loading usb-storage module"
+modprobe -q usb-storage
+mount -t usbfs /proc/bus/usb /proc/bus/usb
+echo Waiting for driver initialization.
+stabilized /proc/bus/usb/devices

in init in the initrd to after the disc driver modprobes that come after modprobe yenta_socket. Presumably mkinitrd "knows" that the root device is connected via yenta_socket, so it should know where to put the stabilized command.


The machine in question is an IBM X30.  It can't boot from anything but its local drive, (so /boot is on that), and the on-board USB sockets are only USB1, so horribly slow, hence the use of a pcmcia USB adaptor.  The adaptor I have is:

USB Controller [0c03]: VIA Technologies, Inc. USB 2.0 [1106:3104] (rev 65)

the external hard drive is
ID 1058:0200 Western Digital Technologies, Inc. Firewire USB Combo


This disc configuration worked in F9
Comment 1 Hans de Goede 2009-06-16 16:44:04 EDT
Interesting setup, given that we are replacing mkinitrd with dracut, I don't think we'll be fixing this. You may want to spend some time to make sure this
works with dracut though, try joining the irc channel #dracut on freenode and decribe your setup there, and offer testing.
Comment 2 Hans de Goede 2010-01-12 10:31:04 EST
This is a mass edit of all mkinitrd bugs.

Thanks for taking the time to file this bug report (and/or commenting on it).

As you may have heard in Fedora 12 mkinitrd has been replaced by dracut. In Fedora 12 the mkinitrd package is still around as some programs depend on
certain libraries it provides, but mkinitrd itself is no longer used.

In Fedora 13 mkinitrd will be removed completely. This means that all work
on initrd has stopped.

Rather then keeping mkinitrd bugs open and giving false hope they might get fixed we are mass closing them, so as to clearly communicate that no more work will be done on mkinitrd. We apologize for any inconvenience this may cause. 

If you are using Fedora 11 and are experiencing a mkinitrd bug you cannot work around, please upgrade to Fedora 12. If you experience problems with the initrd in Fedora 12, please file a bug against dracut.

Note You need to log in before you can comment on or make changes to this bug.