Bug 506367 - CherryPy version 3.1.2 is required to work with Python 2.6
CherryPy version 3.1.2 is required to work with Python 2.6
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-cherrypy (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Luke Macken
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-16 17:54 EDT by Mitchell Berger
Modified: 2016-09-19 22:39 EDT (History)
4 users (show)

See Also:
Fixed In Version: 3.1.2-1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-24 15:31:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mitchell Berger 2009-06-16 17:54:05 EDT
Description of problem:
_cpchecker.py replaces warnings.formatwarning, and the argument
list was not consistent with the definition in Python 2.6 until
CherryPy version 3.1.2.  Fedora 11 is currently shipping version
3.1.1, without the necessary patch.

Version-Release number of selected component (if applicable):
3.1.1-2.fc11.noarch

How reproducible:
N/A - the code in this package simply doesn't contain the needed
patch.

Additional info:
CherryPy ticket discussing this issue:
http://www.cherrypy.org/ticket/891
CherryPy patch in version 3.1.2 resolving this issue:
http://www.cherrypy.org/changeset/2096
Python ticket discussing this issue:
http://bugs.python.org/issue4891
Comment 1 Toshio Ernie Kuratomi 2009-06-17 00:45:01 EDT
Does this break cherrypy to the point that 3.1.1 is unusable on python-2.6?  I'm pushing an update but need to decide whether to push to testing or directly to stable.
Comment 2 Mitchell Berger 2009-06-17 01:17:29 EDT
If the CherryPy checker is enabled, which it is by default, then
any warning it produces will become a fatal exception that prevents
the application from starting up.  If your code produces no warnings,
then it will still be able to run.

To test this, you can begin with the scaffold sample application
and add these two lines to the end of example.conf:

[/tmp]
tools.staticdir.on: True

(This would ordinarily produce a warning, but with CherryPy 3.1.1
and Python 2.6, the application cannot start.)

Since the fatal error only occurs when you would have otherwise
received a warning, it may not be critical enough to bypass testing;
we'll rely on your judgment.  Thanks for the quick reply!
Comment 3 Fedora Update System 2009-06-17 01:52:53 EDT
python-cherrypy-3.1.2-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/python-cherrypy-3.1.2-1.fc11
Comment 4 Fedora Update System 2009-06-19 09:35:06 EDT
python-cherrypy-3.1.2-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-cherrypy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6702
Comment 5 Fedora Update System 2009-06-24 15:31:49 EDT
python-cherrypy-3.1.2-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.