Bug 506372 - ath5k driver dropping packets
ath5k driver dropping packets
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
i386 Linux
low Severity high
: ---
: ---
Assigned To: Michal Schmidt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-16 19:06 EDT by Jason Wilson
Modified: 2010-06-28 09:04 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 09:04:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Wilson 2009-06-16 19:06:10 EDT
Description of problem:
When using ath5k driver on an Atheros AR2413 driver network access is intermittent. Presuming that packets are being dropped/lost. 

Version-Release number of selected component (if applicable):
Fedora 11 with kernel 2.6.29.4-167.fc11.i686.PAE

How reproducible:
Everytime by just connecting and attempting to access network.

Steps to Reproduce:
1. Enable wireless networking
2. Tried to access websites or ssh to other server - works occasionally
  
Actual results:
Access works occasionally - if it does, slowly.

Expected results:
Works seemlessly.

Additional info:
On Fedora 10 with madwifi drivers worked fine.

Running lspci | grep Atheros gives:
09:04.0 Ethernet controller: Atheros Communications Inc. AR2413 802.11bg NIC (rev 01)

Will attempt building madwifi for Fedora 11 to see if it makes a difference.
Comment 1 François Bernier 2009-08-05 11:26:47 EDT
I seem to have the exact problem with my AR928X card.
Comment 2 John W. Linville 2009-08-05 13:10:12 EDT
Can you provide wireless traces using wireshare (or equivalent) on another box?
Comment 3 Jason Wilson 2009-08-06 06:32:38 EDT
Not sure what 'wireshare' is - did you mean wireshark?

If so I will get out another box this weekend with wireless and try and gather some data.

For reference, the madwifi drivers work fine on the same box.
Comment 4 John W. Linville 2009-08-06 09:21:18 EDT
wireshark -- sorry, typo!
Comment 5 Jussi Eloranta 2009-11-01 11:57:01 EST
try checking with iwconfig to see if your wlan card is doing a network scan while you see the connection stall. This is the problem I am seeing. If this is the case, I think there was another bugzilla thread on this (but I can't find it now). I remember that there someone was saying that things should get better in 2.6.31 kernel. I am running F12 beta witth 2.6.31 and I can see that things got better but I still occasionally see that the connection stalls.
I have:

03:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)
Comment 6 Lonni J Friedman 2009-11-22 12:29:27 EST
I'm seeing similar problems with 2.6.27.38-170.2.113.fc10.i686 in an Acer notebook that has 'Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)'.  When the network connection dies, I see the following in dmesg:

wlan0: no IPv6 routers present
wlan0: deauthenticated
wlan0: authenticate with AP 00:16:b6:da:8a:44
wlan0: authenticated
wlan0: associate with AP 00:16:b6:da:8a:44
wlan0: RX ReassocResp from 00:16:b6:da:8a:44 (capab=0x421 status=0 aid=1)
wlan0: associated
wlan0: No ProbeResp from current AP 00:16:b6:da:8a:44 - assume out of range
Comment 7 Jussi Eloranta 2009-12-30 13:06:04 EST
The problem still persists on up to date FC12 with  2.6.31.9-174.fc12.i686.PAE.
Really annoying problem. Is there any way to forbid networkmanager for doing a scan? (I am guessing it is the networkmanager doing this)
Comment 8 Luis R. Rodriguez 2009-12-30 17:25:40 EST
Can you try one of the later stable releases?

http://wireless.kernel.org/en/users/Download/stable
Comment 9 Jussi Eloranta 2010-01-01 01:05:47 EST
With compat-wireless-2.6.33-rc1 things are much better (didn't try earlier ones):

248 packets transmitted, 246 received, 0% packet loss, time 248215ms
rtt min/avg/max/mdev = 0.844/14.598/225.449/40.783 ms

The worst response times used to be 1000 - 3000 ms. The response occasionally goes to abt 200 ms for some individual packets. Great improvement!
Comment 10 Jussi Eloranta 2010-01-22 01:33:43 EST
Would be great if we could get a fix for this for current kernels. Recent kernel upgrade took things back to the old problem and had to reinstall wireless-compat again.
Comment 11 Michal Schmidt 2010-01-22 05:06:39 EST
Jussi,
F12 will hopefully soon get a 2.6.32-based kernel as an update. You can give kernel-2.6.32.4-30.fc12 a try, get it from Koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=152350

If it fixes the problem, we just need to wait for the update to be done.

If it does not fix the problem, we'll need to identify which patches between 2.6.32 and 2.6.33-rc1 are needed. I'll make a test kernel build with some likely candidates applied if necessary.
Comment 12 Jussi Eloranta 2010-01-23 22:39:11 EST
With 2.6.32.4-30.fc12.i686.PAE the behavior is different. The response times do not go occasionally but it drops packets completely:

1714 packets transmitted, 1605 received, 6% packet loss, time 1716024ms
rtt min/avg/max/mdev = 0.782/2.795/1378.196/34.484 ms, pipe 2

I was pinging my basestation. With the compat-wireless that I mentioned above this did not happen. So something is still not quite right.
Comment 13 Michal Schmidt 2010-02-03 08:30:10 EST
Jussi, could you download this kernel:
http://kojipkgs.fedoraproject.org/packages/kernel/2.6.32.7/39.fc12/i686/kernel-PAE-2.6.32.7-39.fc12.i686.rpm
and this tarball with several built ath5k modules with picked patches from 2.6.33-rc1:
http://michich.fedorapeople.org/bz506372/ath-2.6.32.7-39.fc12.i686.PAE.tar.xz

Install the kernel and test it. The expected result is the same as in your comment #12.
Then unpack the tarball where you'll find several directories called "ath-$number". In every one of these there are module files ath5k.ko and ath.ko.

Try using each pair of the modules and observe which one fixes the bug:
/etc/init.d/NetworkManager stop
rmmod ath5k
rmmod ath
cd ath-$number
insmod ath.ko
insmod ath5k.ko
/etc/init.d/NetworkManager start
(test)

Please try ath-33 first. It corresponds to the version from 2.6.33-rc1, so it is expected to work. Then do a binary search through the lower numbered ones to find which is the first good one.
Comment 14 Jussi Eloranta 2010-02-04 00:22:03 EST
Well, ath-33 does not work the same way as the compat stuff did. In fact it hardly works at all. Pinging my base station gives:

115 packets transmitted, 95 received, 17% packet loss, time 114932ms
rtt min/avg/max/mdev = 78.118/89.205/297.613/36.288 ms

With the standard ath5k in kernel 2.6.32.7-39.fc12.i686.PAE I got:

301 packets transmitted, 277 received, 7% packet loss, time 300757ms
rtt min/avg/max/mdev = 1.183/1.495/4.325/0.371 ms


Should I try the latest compat-wireless with this particular kernel again?
Comment 15 Jussi Eloranta 2010-02-04 00:31:41 EST
Interesting... I unloaded and loaded the drivers again and I see different behavior (not correct either...):

120 packets transmitted, 100 received, 16% packet loss, time 119324ms
rtt min/avg/max/mdev = 1.217/1.560/2.831/0.391 ms

Packet loss is about the same but the response time is smaller.

Also, this is what I see in dmesg (if it helps..):

ath5k 0000:03:00.0: PCI INT A disabled
ath5k 0000:03:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
ath5k 0000:03:00.0: setting latency timer to 64
ath5k 0000:03:00.0: registered as 'phy5'
ath: EEPROM regdomain: 0x65
ath: EEPROM indicates we should expect a direct regpair map
ath: Country alpha2 being used: 00
ath: Regpair used: 0x65
phy5: Selected rate control algorithm 'minstrel'
ath5k phy5: Atheros AR5414 chip found (MAC: 0xa3, PHY: 0x61)

Quick test also showed that none of the smaller number ath's helped in reducing the packet loss either.
Comment 16 Bug Zapper 2010-04-27 11:00:05 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 17 Bug Zapper 2010-06-28 09:04:40 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.