Bug 506406 - radeon or ati drivers don't work with Radeon Xpress 200M
radeon or ati drivers don't work with Radeon Xpress 200M
Status: CLOSED DUPLICATE of bug 498457
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
11
All Linux
low Severity urgent
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-17 02:47 EDT by david cossé
Modified: 2009-06-22 09:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-22 09:53:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description david cossé 2009-06-17 02:47:57 EDT
Description of problem:
On a tohiba Laptop with Radeon Xpress 200M inside it.
The install in normal graphical resolution wasn't possible, the screen is plenty of artifact. I installed fedora 11 in low graphical mod but on reboot the screen was again plenty of artifact. I launched fedora 11 on runlevel 3 and edit the xorg.conf and try booth ati and radeon drivers but none of them did work. Finaly just the vesa can display something but with a wrong resolution


00:00.0 Host bridge: ATI Technologies Inc Device 5a31 (rev 01)
00:01.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:13.0 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller
00:13.1 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller
00:13.2 USB Controller: ATI Technologies Inc IXP SB400 USB2 Host Controller
00:14.0 SMBus: ATI Technologies Inc IXP SB400 SMBus Controller (rev 11)
00:14.1 IDE interface: ATI Technologies Inc IXP SB400 IDE Controller
00:14.3 ISA bridge: ATI Technologies Inc IXP SB400 PCI-ISA Bridge
00:14.4 PCI bridge: ATI Technologies Inc IXP SB400 PCI-PCI Bridge
00:14.5 Multimedia audio controller: ATI Technologies Inc IXP SB400 AC'97 Audio Controller (rev 02)
00:14.6 Modem: ATI Technologies Inc SB400 AC'97 Modem Controller (rev 02)
01:05.0 VGA compatible controller: ATI Technologies Inc RS400 [Radeon Xpress 200M]
02:04.0 Ethernet controller: Atheros Communications Inc. AR2413 802.11bg NIC (rev 01)
02:06.0 CardBus bridge: Texas Instruments PCI1410 PC card Cardbus Controller (rev 02)
02:07.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
02:0a.0 FireWire (IEEE 1394): Texas Instruments TSB43AB21 IEEE-1394a-2000 Controller (PHY/Link)
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tomasz Chrzczonowicz 2009-06-18 13:14:50 EDT
Same here with slightly different hardware:

01:05.0 VGA compatible controller: ATI Technologies Inc RC410 [Radeon Xpress 200M]

00:00.0 Host bridge: ATI Technologies Inc Device 5a31 (rev 01)
00:01.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:14.0 SMBus: ATI Technologies Inc IXP SB400 SMBus Controller (rev 82)
00:14.3 ISA bridge: ATI Technologies Inc IXP SB400 PCI-ISA Bridge (rev 80)
00:14.4 PCI bridge: ATI Technologies Inc IXP SB400 PCI-PCI Bridge (rev 80)

Running Fedora 11 i386.

There are plenty of artifacts, but X actually hangs everytime with both Anaconda when loading the graphical stage(ie. post media check and install media select) and post-install when loading GDM.

How can I provide more information?
Comment 2 Tomasz Chrzczonowicz 2009-06-21 12:00:51 EDT
I tested all the xorg.conf options for radeon driver mentioned in the Fedora 11 Common Bugs at https://fedoraproject.org/wiki/Common_F11_bugs#radeon-misc-gfx :

nomodeset
Option "AccelMethod" "XAA"
Option "AccelDFS" "off"

None of those worked for me (neither together nor separately) and only differed in the kind of artifacts on the dislpay when X hung.
Comment 3 Matěj Cepl 2009-06-22 09:53:29 EDT

*** This bug has been marked as a duplicate of bug 498457 ***

Note You need to log in before you can comment on or make changes to this bug.