Bug 50642 - gcc breaks on && (address-of-label) operator
gcc breaks on && (address-of-label) operator
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.0
i386 Linux
low Severity high
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-01 16:52 EDT by Mark Zealey
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-01 19:26:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Zealey 2001-08-01 16:52:53 EDT
Description of Problem:gcc versions greater than 2.91.66 break on zealos (zealos.sourceforge.net, cvs module zealos-new) in i386/kern/desc.c:476


How Reproducible:Always. jump location seems to be non-random, but isn't correct either.


Steps to Reproduce:compile it with a non-kgcc gcc compiler and it will usially infinate-loop.
1. download zealos
2. compile with rh7.1's gcc
3. try to run it

Actual Results:it loops round infinatly printing it's messages (jumping to a psudo-random location in the binary)


Expected Results:it should preform a long jump to reload CS and EIP with the new GDT


Additional Information:Told to report it by arjan v
Comment 1 Richard Henderson 2004-10-01 19:26:03 EDT
zealos.sourceforge.net no longer exists, and I can wade through enough
dutch to find where the current code.

I do recall that a lot of folk had invalid source concerning label
addresses and computed gotos at the time.  I strongly suspect this
was one of those.

Note You need to log in before you can comment on or make changes to this bug.