Bug 506428 - Anaconda stops kickstart installation if 'interactive' is used
Anaconda stops kickstart installation if 'interactive' is used
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-17 05:31 EDT by mad
Modified: 2009-07-16 18:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-28 13:22:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mad 2009-06-17 05:31:03 EDT
Description of problem:
Anaconda stops installation with kickstart file if keyword 'interactive' is used.

Version-Release number of selected component (if applicable):
11.5.0.59

How reproducible:
Every time

Steps to Reproduce:
1. Create a minimal kickstart file
Using a minimum kickstart file:
----------------------------------
interactive

%pre
%end

%packages
%end

%post
%end
----------------------------------

2. Start with the installation procedure with the kickstart file

3. Choose language, keyboard and text installation

4. Error will occur:
The following error was found while parsing your kickstart configuration:

Your kickstart file is missing required information that anaconda cannot prompt for. Please add the following sections and try again:
Bootloader configuration

5. Adding the bootloader configuration after 'interactive':
bootloader --location=mbr
zerombr

6. Reboot, repeat step 3, same error message occurs.

Actual results:
No installation

Expected results:
Interactive Fedora 11 installation

Additional info:
If use without
Comment 1 Chris Lumens 2009-06-28 13:22:48 EDT
bootloader configuration is no longer possible in the text mode interface, so anaconda cannot stop and present you with that screen.  You either need to specify bootloader configuration, or leave it out and do a graphical install.
Comment 2 Andrew McNabb 2009-07-16 18:48:57 EDT
I got this error when trying to install an older Athlon machine.  The kickstart script doesn't specify "text" mode, so I would expect Anaconda to do an interactive graphical install.  If Anaconda can't or won't start graphical mode, then the machine is uninstallable, right?
Comment 3 Andrew McNabb 2009-07-16 18:57:26 EDT
It turns out that there wasn't enough memory to do a graphical install.  I guess that means this machine will have to use a different distro.

Note You need to log in before you can comment on or make changes to this bug.