Bug 506432 - Problem in system-config-display
Problem in system-config-display
Status: CLOSED DUPLICATE of bug 505972
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
11
i386 Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-17 05:50 EDT by abhijangda
Modified: 2010-02-04 19:15 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-04 19:15:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf generated automatically by livna-config-display (469 bytes, text/plain)
2009-11-25 19:26 EST, Andre Robatino
no flags Details
dmesg output (40.27 KB, text/plain)
2009-11-25 19:27 EST, Andre Robatino
no flags Details
Xorg.0.log (12.55 KB, text/plain)
2009-11-25 19:29 EST, Andre Robatino
no flags Details

  None (edit)
Description abhijangda 2009-06-17 05:50:55 EDT
Description of problem:I have ATI Radeon Xpress 200 graphics card i have installed system-config-display to change my resolution as i have installed F11 in vesa driver mode and now my resolution is not good. but when i run system-config-display from terminal in root account i get following errors. 

Traceback (most recent call last):
  File "/usr/share/system-config-display/xconf.py", line 376, in <module>
    dialog = xConfigDialog.XConfigDialog(hardware_state, xconfig, rhpxl.videocard.VideoCardInfo())
  File "/usr/share/system-config-display/xConfigDialog.py", line 641, in __init__
    if len(self.xconfig.layout[0].adjacencies) > 1:
IndexError: index out-of-bounds

Please help me 

Version-Release number of selected component (if applicable):
system-config-display-1.1.3-2.fc11.noarch
xorg-x11-drv-ati-6.12.2-14.fc11.i586

How reproducible:
Whenever running system-config-display

Steps to Reproduce:
1.Go to terminal
2.type system-config-display
3.Ghosh! you get the error
  
Actual results:
This text comes on the screen 

Traceback (most recent call last):
  File "/usr/share/system-config-display/xconf.py", line 376, in <module>
    dialog = xConfigDialog.XConfigDialog(hardware_state, xconfig, rhpxl.videocard.VideoCardInfo())
  File "/usr/share/system-config-display/xConfigDialog.py", line 641, in __init__
    if len(self.xconfig.layout[0].adjacencies) > 1:
IndexError: index out-of-bounds

Expected results:
system-config-display opens


Additional info:
Comment 1 Andre Robatino 2009-08-04 16:40:32 EDT
My father who is using a CRT monitor on a clean fully updated install of F11 started seeing this after installing the proprietary Nvidia driver via akmod-nvidia from Rpmfusion.  Previously, with the built-in nv driver, this didn't happen.  His screen is also currently at a higher resolution (1280x1024) than before.  Try using System/Preferences/Display to change your screen resolution and see if it has any effect on whether this bug manifests.

I am using the same model PC as my father but with a 1280x1024 native resolution LCD monitor and I didn't see this problem with s-c-d either before or after installing the Nvidia driver.  But my resolution was set to 1280x1024 both before and after.
Comment 2 Andre Robatino 2009-08-04 16:49:57 EDT
This is also reported as bug #508056 against Rawhide.  The Platform should probably be "All Linux" since it's unlikely to be i386-specific.
Comment 3 abhijangda 2009-08-05 01:30:41 EDT
I m not able to change setting using System/Preferences/Display. It dosn't shows any other setting expect 800 by 640 or 640 by 480.
Comment 4 Matěj Cepl 2009-11-05 13:32:23 EST
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages. For packages from updates-testing repository you can use command

yum upgrade --enablerepo='*-updates-testing'

Alternatively, you can also try to test whether this bug is reproducible with the upcoming Fedora 12 distribution by downloading LiveMedia of F12 Beta available at http://alt.fedoraproject.org/pub/alt/nightly-composes/ . By using that you get all the latest packages without need to install anything on your computer. For more information on using LiveMedia take a look at https://fedoraproject.org/wiki/FedoraLiveCD .

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]
Comment 5 Andre Robatino 2009-11-15 09:42:35 EST
Bug still exists in F12 (AKA RC4).
Comment 6 ISO 2009-11-19 06:43:26 EST
I have the same problem with the final version of FC12. I am using a Motherboard with and AMD AM785 chipset (including an ATI 4xxx onboard graphics chip). I had to select "install or upgrade with basic video driver" during the installation since the normal driver crashed the machine
Comment 7 Pedro Silva 2009-11-23 10:10:53 EST
I upgraded my F11 to F12 with preupgrade and now i get this error.

The Nvidia driver is not loaded, i can only set a lower resolution (1024x768 when max 1280x800) and even playing some videos is painfully slow.

I've tried to used the (previously backuped) xorg.conf from F11 but it stays the same.

Everything was working fine in F11 before the upgrade.
Comment 8 Matěj Cepl 2009-11-25 19:03:13 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available), output of the dmesg command, and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 9 Andre Robatino 2009-11-25 19:24:30 EST
I started seeing this on F12 immediately after installing Nvidia's video driver.  Requested attachments follow.
Comment 10 Andre Robatino 2009-11-25 19:26:06 EST
Created attachment 373884 [details]
xorg.conf generated automatically by livna-config-display
Comment 11 Andre Robatino 2009-11-25 19:27:51 EST
Created attachment 373887 [details]
dmesg output
Comment 12 Andre Robatino 2009-11-25 19:29:11 EST
Created attachment 373890 [details]
Xorg.0.log
Comment 13 ISO 2009-11-30 16:29:35 EST
Hi;
   When I installed using the basic video driver, a short xorg.conf was created (Only three lines). For some reason this file causes the system-config-display to crash. Once removed, system-config-display works fine and creates its own xorg.conf that it can deal with later.

Best Regards
Ahmed Hussien
Comment 14 BugRocks 2010-01-21 22:05:51 EST
I'm having problems with xorg too.

system-config-display doesn't work for me on Fedora 12.
I just installed and it moved the screen on the Acer X223W 3 inches to the left so I can't see the left side of the screen.

I tried using system-config-display and it crashed but ABRT is not working for me either and refuses to send reports but that is another bug.

I tried using a modeline and it works for the resolution.
My guess is Fedora 12 is not being able to collect the EDID data and for some reason it also don't load the nouveau driver.

lsmod | grep nvidia
lsmod | grep nouveau
system-config-display
nvidia-xconfig
nvidia-settings
glxinfo | grep nvidia
glxinfo | grep direct
Xorg -configure (X should not be running or it shows a error)

I learned a lot trying to figure it out and my problems are.

Don't load the nouveau driver it keeps using the VESA one and when it does the screen is shifted 3 inches to the left side and there is no 3D support and after installing the nvidia drivers that worked fine in Fedora 11 but don't work at all in Fedora 12 the system-config-display stops working.

And sometimes it loads the nouveau driver but in the next reboot it goes back to VESA

Things I did try:

- Installing Fedora 12 and trying to build a xorg.conf by hand. It works just the drivers doesn't work that good and I'm sure I missed some important configurations that may affect speed.

- Installing the Nvidia drivers with the akamods from rpmfusion. It didn't work even fallowing the instructions given at the rpmfusion and fedora forums Fedora 12 doesn't load the nvidia driver and the nvidia settings doesn't work if it doesn't see the driver.
Comment 15 Matěj Cepl 2010-02-04 19:15:34 EST

*** This bug has been marked as a duplicate of bug 505972 ***

Note You need to log in before you can comment on or make changes to this bug.