This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 506472 - dovecot not compiled in for userdb driver 'ldap'
dovecot not compiled in for userdb driver 'ldap'
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dovecot (Show other bugs)
11
x86_64 Linux
low Severity urgent
: ---
: ---
Assigned To: Michal Hlavinka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-17 09:18 EDT by jean-noel
Modified: 2009-08-17 04:20 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.2-0.rc5.2.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-24 15:34:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace -f dovecot -F (49.71 KB, text/plain)
2009-06-17 09:18 EDT, jean-noel
no flags Details

  None (edit)
Description jean-noel 2009-06-17 09:18:12 EDT
Created attachment 348252 [details]
strace -f dovecot -F

Description of problem:
when starting dovecot , it died with error log :
dovecot: Fatal: auth(default): Support not compiled in for passdb driver 'ldap'
Jun 17 12:29:44 aragon dovecot: Fatal: Auth process died too early - shutting down

Version-Release number of selected component (if applicable):
Paquetages installés
dovecot.x86_64                         1:1.2-0.rc3.1.fc11              installed
dovecot-ldap.x86_64                    1:1.2-0.rc3.1.fc11              installed 

# dovecot --version
1.2.rc3

# dovecot -n
# 1.2.rc3: /etc/dovecot.conf
# OS: Linux 2.6.29.4-167.fc11.x86_64 x86_64 Fedora release 11 (Leonidas) ext3
login_dir: /var/run/dovecot/login
login_executable(default): /usr/libexec/dovecot/imap-login
login_executable(imap): /usr/libexec/dovecot/imap-login
login_executable(pop3): /usr/libexec/dovecot/pop3-login
mail_uid: vmail
mail_gid: vmail
mail_location: maildir:/home/vmail/%u/
mail_executable(default): /usr/libexec/dovecot/imap
mail_executable(imap): /usr/libexec/dovecot/imap
mail_executable(pop3): /usr/libexec/dovecot/pop3
mail_plugins(default): autocreate
mail_plugins(imap): autocreate
mail_plugins(pop3):
mail_plugin_dir(default): /usr/lib64/dovecot/imap
mail_plugin_dir(imap): /usr/lib64/dovecot/imap
mail_plugin_dir(pop3): /usr/lib64/dovecot/pop3
auth default:
 passdb:
   driver: passwd-file
   args: /etc/passwd
 passdb:
   driver: ldap
   args: /etc/dovecot-ldap.conf
 userdb:
   driver: ldap
   args: /etc/dovecot-ldap.conf
 socket:
   type: listen
   client:
     path: /var/run/dovecot/auth-client
     mode: 432
     user: postfix
     group: postfix
   master:
     path: /var/run/dovecot/auth-master
     mode: 384
     user: vmail
     group: vmail
plugin:
 sieve: ~/.dovecot.sieve
 sieve_dir: ~/sieve 

How reproducible:
Every time 

Steps to Reproduce:
1.install dovecot et dovecot-ldap
2.uncomment passdb ldap and userdb ldap in dovecot.conf
3.start dovecot
  
Actual results:
Cannot have the dovecot imap server to serve mail

Expected results:
support of ldap

Additional info:
Comment 1 jean-noel 2009-06-17 16:11:34 EDT
on the dovecot mailing list I ask about the problem. a guy answers that the problem is fixed by rc5.
can i hope to have the rpm package of rc5
thanks
Comment 2 Michal Hlavinka 2009-06-18 01:28:58 EDT
Yes I know about it, but our packages contain sieve and managesieve support, so we need sources for them too. Sieve sources are independent on dovecot version, but managesieve release must match dovecot release 

http://wiki.dovecot.org/ManageSieve

http://www.rename-it.nl/dovecot/1.2/

and there is still no release for dovecot rc5

I've asked managesieve maintainer what is the current plan.
Comment 3 Fedora Update System 2009-06-18 04:00:01 EDT
dovecot-1.2-0.rc5.1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/dovecot-1.2-0.rc5.1.fc11
Comment 4 Michal Hlavinka 2009-06-18 04:01:21 EDT
I've trimmed missing sources from old version to match actual dovecot release, building now...

You can get unsigned packages here:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1422473

or you can wait when they are pushed to updates
Comment 5 Fedora Update System 2009-06-19 05:46:17 EDT
dovecot-1.2-0.rc5.2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/dovecot-1.2-0.rc5.2.fc11
Comment 6 Fedora Update System 2009-06-24 15:34:50 EDT
dovecot-1.2-0.rc5.2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Stefan Klatt 2009-08-04 07:53:08 EDT
It's the same with dovecot 1.2.1 and 1.2.2 in testing :-(
Comment 8 Michal Hlavinka 2009-08-05 04:06:48 EDT
(In reply to comment #7)
> It's the same with dovecot 1.2.1 and 1.2.2 in testing :-(  

could you write more detailed problem description, attach messages from log and attach dovecot.conf? thanks

note: if it is not ldap related, please open new bug
Comment 9 jean-noel 2009-08-05 04:22:44 EDT
for my installation :
# uname -a
Linux aragon.dr15.cnrs.fr 2.6.29.5-191.fc11.x86_64 #1 SMP Tue Jun 16 23:23:21 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux

#yum list dovecot
dovecot.x86_64                      1:1.2.0-1.fc11                      @updates

It is working fine
Comment 10 Stefan Klatt 2009-08-05 08:57:52 EDT
(In reply to comment #8)
> (In reply to comment #7)
> > It's the same with dovecot 1.2.1 and 1.2.2 in testing :-(  
> 
> could you write more detailed problem description, attach messages from log and
> attach dovecot.conf? thanks
> 
> note: if it is not ldap related, please open new bug  

Oh.. sorry, i see the difference... i use the 32 Bit version and there it doesn't work.
I get the identically error :

Aug 04 03:08:35 dovecot: Info: Dovecot v1.2.2 starting up (core dumps disabled)
Aug 04 03:08:35 auth(default): Fatal: Support not compiled in for passdb driver 'ldap'
Aug 04 03:08:35 dovecot: Fatal: Auth process died too early - shutting down

I will open a new bug report if necessary.

Stefan
Comment 11 Michal Hlavinka 2009-08-05 09:06:06 EDT
there's no need to open new bug, it's still ldap related

what modules (and versions do you use?) (output of rpm -qa dovecot | grep dovecot )

please attach your dovecot.conf
Comment 12 Michal Hlavinka 2009-08-05 09:06:46 EDT
(In reply to comment #11)
> what modules (and versions do you use?) (output of rpm -qa dovecot | grep
> dovecot )

it should be: rpm -qa | grep dovecot
Comment 13 Stefan Klatt 2009-08-05 11:24:00 EDT
Hi,

at the moment i use dovecot-1.2.1-0_96.fc11.i586 from atrpms, this works will ldap.

If i use 1.2.2-1.20090728snap.fc11 from updates-testing or 1.2-0.rc2.1.fc11 from fedora i get the error above.

Dovecot 1.2rc2 is really old and like 1.2.2-1.20090728snap no official version. What about the official 1.2.2 (with ldap :-) ) ??

Here is my "dovecot -n":

# 1.2.1: /etc/dovecot.conf
# OS: Linux 2.6.29.6-217.2.3.fc11.i686.PAE i686 Fedora release 11 (Leonidas)
log_path: /var/log/email/dovecot.log
protocols: imaps
listen: *
ssl_cert_file: /etc/pki/tls/certs/cac.is-a-geek.com.cert
ssl_key_file: /etc/pki/tls/private/cac.is-a-geek.com.key
login_dir: /var/run/dovecot/login
login_executable: /usr/libexec/dovecot/imap-login
mail_access_groups: email
mail_uid: 600
mail_gid: 600
mail_plugins: zlib
imap_client_workarounds: tb-extra-mailbox-sep
namespace:
  type: private
  separator: /
  location: maildir:/srv/imapd/user/%u/maildir
  inbox: yes
  list: yes
  subscriptions: yes
namespace:
  type: private
  separator: /
  prefix: #mb/
  location: mbox:/srv/imapd/user/%u/Spam
  hidden: yes
  list: yes
  subscriptions: yes
namespace:
  type: public
  separator: /
  prefix: Public/
  location: maildir:/srv/imapd/shared/public/maildir:CONTROL=/srv/imapd/user/%u/shared-settings/public/control:INDEX=/srv/imapd/user/%u/shared-settings/public/index
  list: yes
  subscriptions: yes
namespace:
  type: public
  separator: /
  prefix: Archiv/
  location: mbox:/srv/imapd/shared/archiv/maildir:CONTROL=/srv/imapd/user/%u/shared-settings/archiv/control:INDEX=/srv/imapd/user/%u/shared-settings/archiv/index
  list: yes
  subscriptions: yes
auth default:
  passdb:
    driver: ldap
    args: /etc/dovecot-ldap.conf
  userdb:
    driver: static
    args: uid=600 gid=600


Nothing special.

Stefan
Comment 14 Michal Hlavinka 2009-08-06 03:11:32 EDT
(In reply to comment #13)
> Hi,
> 
> at the moment i use dovecot-1.2.1-0_96.fc11.i586 from atrpms, this works will
> ldap.

and that's pretty odd, since atrpms and Fedora official packages uses the same sources...

> If i use 1.2.2-1.20090728snap.fc11 from updates-testing or 1.2-0.rc2.1.fc11
> from fedora i get the error above.

between Fedora and atrpms there is one difference: atrpms has "all in one", but fedora has splitted package to sub-packages (dovecot-something), because it's not a good idea to install all kerberos (and other) dependencies if you want to use only pam module.

so... when using dovecot from Fedora, do you have installed all needed subpackages and with matching version-release? (output of rpm -qa | grep dovecot )
 
> Dovecot 1.2rc2 is really old and like 1.2.2-1.20090728snap no official version.
> What about the official 1.2.2 (with ldap :-) ) ??

why do you think that snapshot is not an official version? Dovecot 1.2.2 was released with broken gssapi support, which was fixed in repository a few hours later. This snapshot is 1.2.2 with that gssapi fixes, so it seems pretty official to me :o)

> 
> Here is my "dovecot -n":
> 

Fedora uses slightly different default values, so dovecot.conf (instead of dovecot -n output) is preferred. If you have any sensitive data in the conf, you can replace them with something like "REMOVED".
Comment 15 Stefan Klatt 2009-08-07 08:21:29 EDT
(In reply to comment #14)

>> at the moment i use dovecot-1.2.1-0_96.fc11.i586 from atrpms, this works will
>> ldap.
>and that's pretty odd, since atrpms and Fedora official packages uses the same
>sources...
But different make options!!

>> If i use 1.2.2-1.20090728snap.fc11 from updates-testing or 1.2-0.rc2.1.fc11
>> from fedora i get the error above.
>between Fedora and atrpms there is one difference: atrpms has "all in one", but
>fedora has splitted package to sub-packages (dovecot-something), because it's
>not a good idea to install all kerberos (and other) dependencies if you want to
>use only pam module.
There is only one dovecot package on each fedora repository. 

>so... when using dovecot from Fedora, do you have installed all needed
>subpackages and with matching version-release? (output of rpm -qa | grep
>dovecot )
Please... take a look at the repositories, there aren't different subpackages.

output of rpm -qa | grep dovecot:
dovecot-1.2.1-0_96.fc11.i586

> Here is my "dovecot -n":
> 
>
>Fedora uses slightly different default values, so dovecot.conf (instead of
>dovecot -n output) is preferred. If you have any sensitive data in the conf,
>you can replace them with something like "REMOVED"
If fedora use different default values then the original version we have a big problem because the output of "dovecot -n" is the official base for troubleshooting of dovecot and your statement implies fedora don't the official unmodified source code. "dovecot -n" shows only the difference from the dovecot configuration and the dovecot defaults.

Stefan

P.s.: I know the usage of sub and feature packages only from debian, not from fedora.
Comment 16 Michal Hlavinka 2009-08-07 10:25:46 EDT
(In reply to comment #15)
> (In reply to comment #14)
> >and that's pretty odd, since atrpms and Fedora official packages uses the same
> >sources...
> But different make options!!

they are not such different

> >> If i use 1.2.2-1.20090728snap.fc11 from updates-testing or 1.2-0.rc2.1.fc11
> >> from fedora i get the error above.
> >between Fedora and atrpms there is one difference: atrpms has "all in one", but
> >fedora has splitted package to sub-packages (dovecot-something), because it's
> >not a good idea to install all kerberos (and other) dependencies if you want to
> >use only pam module.
> There is only one dovecot package on each fedora repository. 

no, there is not. For Fedora, there are other sub-packages, use 

yum list 'dovecot*'

to see them.

dovecot, dovecot-ldap, dovecot-gssapi,...

this is the only way how to separate functionality, because other way, you'll have to install ldap and kerberos libraries even if you need only pam.

So if you want to use ldap, you need to have dovecot and dovecot-ldap installed (with matching version-release)

see output of yum info dovecot-ldap for example

> 
> >so... when using dovecot from Fedora, do you have installed all needed
> >subpackages and with matching version-release? (output of rpm -qa | grep
> >dovecot )
> Please... take a look at the repositories, there aren't different subpackages.
> 
> output of rpm -qa | grep dovecot:
> dovecot-1.2.1-0_96.fc11.i586

yes, but this is not official Fedora package
 
> > Here is my "dovecot -n":
> > 
> >
> >Fedora uses slightly different default values, so dovecot.conf (instead of
> >dovecot -n output) is preferred. If you have any sensitive data in the conf,
> >you can replace them with something like "REMOVED"
> If fedora use different default values then the original version we have a big
> problem because the output of "dovecot -n" is the official base for
> troubleshooting of dovecot and your statement implies fedora don't the official
> unmodified source code. "dovecot -n" shows only the difference from the dovecot
> configuration and the dovecot defaults.

it's not such big problem, because changes are not such critical. Configuration is changed from "configure all you need" to "work out of the box" (pam used for authenticating users). It's also changed to match actual state of Fedora (for example accept ipv6 connections), security (disable plaintext auth by default), path to ssl keys matches directory where Fedora have them, ...

There is one change in comment in dovecot.conf explaining this pretty well

 # Default values are shown for each setting, it's not required to uncomment
-# those. These are exceptions to this though: ....
-# <QUITE BIG PARAGRAPH FOLLOWS>
....

to:
 # Default values are shown for each setting, it's not required to uncomment
+# any of the lines.

dovecot.conf is also preferred because it can be used for reproducing problem as is without rewriting and fixing/making new typos
Comment 17 Stefan Klatt 2009-08-14 02:36:12 EDT
(In reply to comment #16)
>> >and that's pretty odd, since atrpms and Fedora official packages uses the 
>> >samesources...
>> But different make options!!
>they are not such different
They are. You can build dovecot with different authentication options like LDAP SQL.

>So if you want to use ldap, you need to have dovecot and dovecot-ldap installed
>(with matching version-release)
At which time was this change? I work since a long time with dovecot and fedora and this brakes a working setup.

>> >Fedora uses slightly different default values, so dovecot.conf (instead of
>> >dovecot -n output) is preferred. If you have any sensitive data in the conf,
>> >you can replace them with something like "REMOVED"
>> If fedora use different default values then the original version we have a 
>> big problem because the output of "dovecot -n" is the official base for
>> troubleshooting of dovecot and your statement implies fedora don't the 
>> official unmodified source code. "dovecot -n" shows only the difference from >> the dovecot configuration and the dovecot defaults.
>it's not such big problem, because changes are not such critical. Configuration
>is changed from "configure all you need" to "work out of the box" (pam used for
>authenticating users). It's also changed to match actual state of Fedora (for
>example accept ipv6 connections), security (disable plaintext auth by default),
>path to ssl keys matches directory where Fedora have them, ...
>
>There is one change in comment in dovecot.conf explaining this pretty well
If this changes are only at dovecot.conf, "dovecot -n" give all necessary infos.

>dovecot.conf is also preferred because it can be used for reproducing problem
>as is without rewriting and fixing/making new typos
I think you get then normally an error from Dovecot
Comment 18 Michal Hlavinka 2009-08-17 04:20:36 EDT
(In reply to comment #17)

> >they are not such different
> They are. You can build dovecot with different authentication options like LDAP
> SQL.

no :) they are build with "all" option and then you will pick only what you want/need by installing appropriate sub-packages

> 
> >So if you want to use ldap, you need to have dovecot and dovecot-ldap installed
> >(with matching version-release)
> At which time was this change? I work since a long time with dovecot and fedora
> and this brakes a working setup.

In the official Fedora repository this exists for long time, in fact I can't remember if/when it was not this way. You can have some troubles if using dovecot from other repositories such as from atrpms. This is not official Fedora repository, so some problems can occur.

> >There is one change in comment in dovecot.conf explaining this pretty well
> If this changes are only at dovecot.conf, "dovecot -n" give all necessary
> infos.

for "no need to change" anything to work, these changes are both in dovecot.conf and dovecot itself

> >dovecot.conf is also preferred because it can be used for reproducing problem
> >as is without rewriting and fixing/making new typos
> I think you get then normally an error from Dovecot  

the point is I can't use the dovecot -n output when trying to reproduce this. I have to create a config file from these values I can accidentally chagne valid not working value to valid working value. Another point is dovecot mailing list prefers dovecot -n output, because it's much smaller. In bugzilla, dovecot.conf is preferred.

Note You need to log in before you can comment on or make changes to this bug.