Bug 506491 - Yums -q quiet option fails to make it any quieter
Yums -q quiet option fails to make it any quieter
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
11
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-17 10:20 EDT by Chris Jones
Modified: 2014-01-21 18:09 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-17 14:08:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Jones 2009-06-17 10:20:16 EDT
Description of problem:
Yum -q quiet option fails to make it any quieter

Version-Release number of selected component (if applicable):
3.2.23-3.fc11

How reproducible:
Always

Steps to Reproduce:
1. yum -qy foo
2. See lack of quietness
  
Actual results:
Lots of output

Expected results:
No, or at least reduced output
Comment 1 seth vidal 2009-06-17 10:27:10 EDT
The only thing I see being outputted is the transaction list and confirmation and that is only outputted if you specify yum -q w/o the -y.
Comment 2 Chris Jones 2009-06-17 13:14:16 EDT
Further investigation reveals it doesn't obey -q when its combined with another option, but it does obey -y when combined with another option, transcript to illustrate follows...

[root@xenon ~]# rpm -qi mapnik-python
package mapnik-python is not installed
[root@xenon ~]# yum -yq install mapnik-python
Loaded plugins: refresh-packagekit
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package mapnik-python.x86_64 0:0.5.2-0.12.svn780.fc11 set to be updated
--> Processing Dependency: python-lxml for package: mapnik-python-0.5.2-0.12.svn780.fc11.x86_64
--> Running transaction check
---> Package python-lxml.x86_64 0:2.2-1.fc11 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=================================================================================================================================================
 Package                            Arch                        Version                                        Repository                   Size
=================================================================================================================================================
Installing:
 mapnik-python                      x86_64                      0.5.2-0.12.svn780.fc11                         fedora                      501 k
Installing for dependencies:
 python-lxml                        x86_64                      2.2-1.fc11                                     fedora                      2.5 M

Transaction Summary
=================================================================================================================================================
Install      2 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 3.0 M
Downloading Packages:
-------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                             18 MB/s | 3.0 MB     00:00     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : python-lxml-2.2-1.fc11.x86_64                                                                                             1/2 
  Installing     : mapnik-python-0.5.2-0.12.svn780.fc11.x86_64                                                                               2/2 

Installed:
  mapnik-python.x86_64 0:0.5.2-0.12.svn780.fc11                                                                                                  

Dependency Installed:
  python-lxml.x86_64 0:2.2-1.fc11                                                                                                                

Complete!
[root@xenon ~]# rpm -q mapnik-python
mapnik-python-0.5.2-0.12.svn780.fc11.x86_64
[root@xenon ~]# yum -qy remove mapnik-python
Loaded plugins: refresh-packagekit
Setting up Remove Process
Resolving Dependencies
--> Running transaction check
---> Package mapnik-python.x86_64 0:0.5.2-0.12.svn780.fc11 set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

=================================================================================================================================================
 Package                            Arch                        Version                                     Repository                      Size
=================================================================================================================================================
Removing:
 mapnik-python                      x86_64                      0.5.2-0.12.svn780.fc11                      installed                      2.3 M

Transaction Summary
=================================================================================================================================================
Install      0 Package(s)         
Update       0 Package(s)         
Remove       1 Package(s)         

Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Erasing        : mapnik-python-0.5.2-0.12.svn780.fc11.x86_64                                                                               1/1 
Unable to send message to PackageKit

Removed:
  mapnik-python.x86_64 0:0.5.2-0.12.svn780.fc11                                                                                                  

Complete!
[root@xenon ~]# rpm -q mapnik-python
package mapnik-python is not installed
[root@xenon ~]# yum -q -y install mapnik-python
[root@xenon ~]# rpm -q mapnik-python
mapnik-python-0.5.2-0.12.svn780.fc11.x86_64
Comment 3 James Antill 2009-06-17 14:08:19 EDT
This is a different "feature". The problem is -q needs to be acted upon (and thus. parsed out of the command line) before yum can run the option parser. So:

yum -yq up == no quiet
yum -qy up == no quiet
yum -y -q up == quiet
yum -q -y up == quiet

...feel free to open an RFE BZ if you feel the above needs to be changed (but don't hold your breath).

Note You need to log in before you can comment on or make changes to this bug.