Bug 506498 - Abort from qpid::sys::DispatchHandle::processEvent
Abort from qpid::sys::DispatchHandle::processEvent
Status: CLOSED DUPLICATE of bug 506298
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
1.0
All Linux
urgent Severity urgent
: 1.1.6
: ---
Assigned To: Andrew Stitcher
MRG Quality Engineering
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-17 10:47 EDT by Gordon Sim
Modified: 2009-06-17 15:25 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-17 15:25:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gordon Sim 2009-06-17 10:47:26 EDT
Description of problem:


Core was generated by `/usr/sbin/qpidd --daemon --port=5672 --data-dir=/app/qgw_tt2/common/data/1 --pi'.
Program terminated with signal 6, Aborted.
[New process 8962]
[New process 8963]
[New process 8961]
[New process 8959]
[New process 8958]
[New process 8957]
[New process 8956]
#0  0x0000003036430215 in raise () from /lib64/libc.so.6
(gdb) bt
#0  0x0000003036430215 in raise () from /lib64/libc.so.6
#1  0x0000003036431cc0 in abort () from /lib64/libc.so.6
#2  0x000000303a4bec44 in __gnu_cxx::__verbose_terminate_handler ()
   from /usr/lib64/libstdc++.so.6
#3  0x000000303a4bcdb6 in ?? () from /usr/lib64/libstdc++.so.6
#4  0x000000303a4bcde3 in std::terminate () from /usr/lib64/libstdc++.so.6
#5  0x000000303a4bceca in __cxa_throw () from /usr/lib64/libstdc++.so.6
#6  0x00000036ad1c8567 in qpid::sys::ScopedLock<qpid::sys::Mutex>::~ScopedLock
    () from /usr/lib64/libqpidcommon.so.0
#7  0x00000036ad1c34d3 in qpid::sys::DispatchHandle::processEvent ()
   from /usr/lib64/libqpidcommon.so.0
#8  0x00000036ad177693 in qpid::sys::Poller::run ()
   from /usr/lib64/libqpidcommon.so.0
#9  0x00000036ad16e64a in ?? () from /usr/lib64/libqpidcommon.so.0
#10 0x0000003c1a006367 in start_thread () from /lib64/libpthread.so.0
#11 0x00000030364d30ad in clone () from /lib64/libc.so.6
(gdb) info threads
  7 process 8956  0x00000030364c565b in read () from /lib64/libc.so.6
  6 process 8957  0x0000003c1a00ab00 in pthread_cond_timedwait@@GLIBC_2.3.2 ()
   from /lib64/libpthread.so.0
  5 process 8958  0x0000003c1a00ab00 in pthread_cond_timedwait@@GLIBC_2.3.2 ()
   from /lib64/libpthread.so.0
  4 process 8959  0x0000003c1a00ab00 in pthread_cond_timedwait@@GLIBC_2.3.2 ()
   from /lib64/libpthread.so.0
  3 process 8961  0x00000030364d4477 in semop () from /lib64/libc.so.6
  2 process 8963  0x00000030364d3498 in epoll_wait () from /lib64/libc.so.6
* 1 process 8962  0x0000003036430215 in raise () from /lib64/libc.so.6=

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Gordon Sim 2009-06-17 10:48:50 EDT
This was with qpidd-0.5.752581-18.el5
Comment 2 Andrew Stitcher 2009-06-17 15:25:56 EDT

*** This bug has been marked as a duplicate of bug 506298 ***

Note You need to log in before you can comment on or make changes to this bug.