Bug 506545 - Input uncommon chinese char in doc format cause OO writer busy loop
Input uncommon chinese char in doc format cause OO writer busy loop
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
11
All Linux
high Severity high
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-17 13:22 EDT by John Lau
Modified: 2009-08-31 19:32 EDT (History)
1 user (show)

See Also:
Fixed In Version: 3.1.1-19.1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-31 19:32:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The problem (709 bytes, text/plain)
2009-06-17 13:25 EDT, John Lau
no flags Details
The strace of OOo (3.17 MB, application/x-gzip)
2009-06-17 13:32 EDT, John Lau
no flags Details
Test odt file with the uncommon chinese char (7.15 KB, application/vnd.oasis.opendocument.text)
2009-06-18 01:46 EDT, John Lau
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 102920 None None None Never

  None (edit)
Description John Lau 2009-06-17 13:22:14 EDT
Description of problem:

When I save the writer document in doc format and try some uncommon chinese char like "
Comment 1 John Lau 2009-06-17 13:23:55 EDT
Description of problem:

When I save the writer document in doc format and try some uncommon chinese char like "
Comment 2 John Lau 2009-06-17 13:25:02 EDT
Created attachment 348302 [details]
The problem
Comment 3 John Lau 2009-06-17 13:29:51 EDT
It seems that the uncommon Chinese char would cause some problem in bugzilla too. I attached Description of problem in the problem.txt. Please have a look.

Additional info:
The problem do not happen if the doc is saved as obt format. And the problem didn't happened in RHEL5 and older fedora.

It is a very trouble problem for Traditional Chinese user. Although we seldom input uncommon chinese char, we may accidentally hit the uncommon chinese char in our input method (like Cangjie, most useful input method for traditional chinese user) and it may hang the OO writer immediately.
Comment 4 John Lau 2009-06-17 13:32:29 EDT
Created attachment 348305 [details]
The strace of OOo
Comment 5 Caolan McNamara 2009-06-17 15:58:31 EDT
Hmm, I don't see if if I cut and paste from the text description attached into writer and save as .doc. Though of course I'm a western user so might not have some font that triggers it or something.

If you save as .odt (which works) and then reload the .odt and use save as .doc does that also hang ?. If it does the attached the .odt as an easier way to reproduce
Comment 6 John Lau 2009-06-18 01:45:57 EDT
When I try to do what you advice, I found another way to trigger the bug, even in .odt file.

I input the uncommon chinese char into a new .odt file. It doesn't hang at first. But when I insert a lot of tab (I press down the tab button for at most about 3 seconds), it can always hang the OO writer with 100% cpu load.

But if it is a common chinese char, the problem doesn't triggered.

I attached the test.odt with that char for you to test.
Comment 7 John Lau 2009-06-18 01:46:40 EDT
Created attachment 348379 [details]
Test odt file with the uncommon chinese char
Comment 8 Caolan McNamara 2009-06-18 04:02:11 EDT
Still not reproducible for me. So if you load the .odt you attached above, then hold down the tab button, it hangs, right ?
Comment 9 John Lau 2009-06-18 04:39:59 EDT
Yes, I insert the tabs BEFORE the uncommon chinese char. And it hangs.

Moreover, I was in zh_TW.UTF-8 environment. But I can reproduce the same issue in en_US environment too.
Comment 10 Caolan McNamara 2009-06-18 05:52:29 EDT
Aha, before the char. Now I have it. confirmed
Comment 11 Caolan McNamara 2009-06-18 08:54:53 EDT
some horrible mixup between utf-16 and ucs-2
Comment 12 Caolan McNamara 2009-06-18 12:19:48 EDT
Fixed logged upstream and checked into F-11 and devel. Will be in >= 3.1.0-11.4 if and when there is another OOo update for F-11 made available
Comment 13 John Lau 2009-06-18 23:13:22 EDT
Woo, you are a fast troubleshooter. ;-) Thank you very much.

If there are testing version available, I can help testing it.
Comment 14 Caolan McNamara 2009-06-19 04:20:37 EDT
It'll probably be quite a while until there's a F-11 update, but the devel F-12/rawhide one will likely be available on Mon/Tue
Comment 15 John Lau 2009-06-19 05:23:12 EDT
Because it is a very common problem for traditional Chinese users (Taiwan and Hong Kong) and too frequent to hit, I would suggest to release the fix ASAP.
Comment 16 Fedora Update System 2009-06-23 03:38:24 EDT
openoffice.org-3.1.0-11.4.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/openoffice.org-3.1.0-11.4.fc11
Comment 17 Fedora Update System 2009-06-26 22:52:59 EDT
openoffice.org-3.1.0-11.4.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7003
Comment 18 John Lau 2009-06-28 23:51:06 EDT
I test it and the problem is fixed! Thank you very much.
Comment 19 Fedora Update System 2009-07-10 03:53:26 EDT
openoffice.org-3.1.0-11.5.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/openoffice.org-3.1.0-11.5.fc11
Comment 20 Fedora Update System 2009-07-16 03:05:43 EDT
openoffice.org-3.1.0-11.5.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7604
Comment 21 Fedora Update System 2009-08-29 05:41:00 EDT
openoffice.org-3.1.1-19.1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/openoffice.org-3.1.1-19.1.fc11
Comment 22 Fedora Update System 2009-08-31 19:31:25 EDT
openoffice.org-3.1.1-19.1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.