Bug 506610 - Patches/files for Windows QMF plug-in support for Grid
Patches/files for Windows QMF plug-in support for Grid
Status: CLOSED DEFERRED
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-qmf (Show other bugs)
Development
All Windows
high Severity low
: 1.3
: ---
Assigned To: messaging-bugs
MRG Quality Engineering
:
Depends On: 522145 522267
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-17 18:47 EDT by Pete MacKinnon
Modified: 2011-08-12 12:02 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-09 22:16:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
qmf_agent.vcproj patch (1.40 KB, patch)
2009-06-17 18:51 EDT, Pete MacKinnon
no flags Details | Diff
qpid.sln patch (9.60 KB, patch)
2009-06-17 19:03 EDT, Pete MacKinnon
no flags Details | Diff
broker.vcproj.patch (60.81 KB, patch)
2009-06-18 09:10 EDT, Pete MacKinnon
no flags Details | Diff
client.vcproj.patch (21.99 KB, patch)
2009-06-18 09:11 EDT, Pete MacKinnon
no flags Details | Diff
common.vcproj.patch (86.20 KB, patch)
2009-06-18 09:12 EDT, Pete MacKinnon
no flags Details | Diff
qmfagent.vcproj.patch (9.83 KB, patch)
2009-06-18 09:14 EDT, Pete MacKinnon
no flags Details | Diff
qmfconsole.vcproj.patch (12.27 KB, patch)
2009-06-18 09:14 EDT, Pete MacKinnon
no flags Details | Diff
qpidbroker.vcproj.patch (9.81 KB, patch)
2009-06-18 09:15 EDT, Pete MacKinnon
no flags Details | Diff
ManagementAgentImpl.cpp.patch (1.17 KB, patch)
2009-06-18 09:20 EDT, Pete MacKinnon
no flags Details | Diff
PipeHandle.h.patch (942 bytes, patch)
2009-06-18 09:25 EDT, Pete MacKinnon
no flags Details | Diff
Posix PipeHandle.cpp.patch (462 bytes, patch)
2009-06-18 09:26 EDT, Pete MacKinnon
no flags Details | Diff
Windows PipeHandle.cpp.patch (3.37 KB, patch)
2009-06-18 09:30 EDT, Pete MacKinnon
no flags Details | Diff
IntegerTypes.h.patch (579 bytes, patch)
2009-06-18 09:34 EDT, Pete MacKinnon
no flags Details | Diff
uuid.h.patch (436 bytes, patch)
2009-06-18 09:35 EDT, Pete MacKinnon
no flags Details | Diff
uuid.cpp.patch (308 bytes, patch)
2009-06-18 09:36 EDT, Pete MacKinnon
no flags Details | Diff
protocol_gen.mak.patch (1.12 KB, patch)
2009-06-18 09:45 EDT, Pete MacKinnon
no flags Details | Diff
example_gen.mak.patch (918 bytes, patch)
2009-06-18 09:47 EDT, Pete MacKinnon
no flags Details | Diff

  None (edit)
Description Pete MacKinnon 2009-06-17 18:47:37 EDT
Various files for the Windows QMF plug-in support required by Grid.

based off revision: 785848

Need Static release and debug builds for correct runtime integration:
cpp/src/broker.vcproj
cpp/src/client.vcproj
cpp/src/common.vcproj
cpp/src/qmfagent.vcproj
cpp/src/qmfconsole.vcproj
cpp/src/qpid.sln
cpp/src/qpidbroker.vcproj

- Changed to provide compile flags required for header file integration of Posix types declared by both Qpid and Condor:
cpp/src/qpid/sys/windows/IntegerTypes.h
cpp/src/qpid/sys/windows/uuid.cpp
cpp/src/qpid/sys/windows/uuid.h

- Modified signature of PipeHandle ctor and fixed a Windows race condition in the processing loop:
cpp/src/qpid/agent/ManagementAgentImpl.cpp

- Refactored the pipe code so that Condor can get a true socket fd it can select on in daemon_core:
cpp/src/qpid/sys/Pipehandle.h
cpp/src/qpid/sys/posix/PipeHandle.cpp
cpp/src/qpid/sys/windows/PipeHandle.cpp

- Removed explicit dependency on Debug libs since we now have even more targets:
cpp/examples/qmf_agent.vcproj
Comment 1 Pete MacKinnon 2009-06-17 18:51:32 EDT
Created attachment 348366 [details]
qmf_agent.vcproj patch
Comment 2 Pete MacKinnon 2009-06-17 19:03:15 EDT
Created attachment 348367 [details]
qpid.sln patch
Comment 3 Pete MacKinnon 2009-06-18 09:10:38 EDT
Created attachment 348440 [details]
broker.vcproj.patch
Comment 4 Pete MacKinnon 2009-06-18 09:11:34 EDT
Created attachment 348442 [details]
client.vcproj.patch
Comment 5 Pete MacKinnon 2009-06-18 09:12:57 EDT
Created attachment 348443 [details]
common.vcproj.patch
Comment 6 Pete MacKinnon 2009-06-18 09:14:01 EDT
Created attachment 348444 [details]
qmfagent.vcproj.patch
Comment 7 Pete MacKinnon 2009-06-18 09:14:52 EDT
Created attachment 348445 [details]
qmfconsole.vcproj.patch
Comment 8 Pete MacKinnon 2009-06-18 09:15:55 EDT
Created attachment 348446 [details]
qpidbroker.vcproj.patch
Comment 9 Pete MacKinnon 2009-06-18 09:20:09 EDT
Created attachment 348447 [details]
ManagementAgentImpl.cpp.patch
Comment 10 Pete MacKinnon 2009-06-18 09:25:23 EDT
Created attachment 348448 [details]
PipeHandle.h.patch
Comment 11 Pete MacKinnon 2009-06-18 09:26:15 EDT
Created attachment 348449 [details]
Posix PipeHandle.cpp.patch
Comment 12 Pete MacKinnon 2009-06-18 09:30:59 EDT
Created attachment 348450 [details]
Windows PipeHandle.cpp.patch
Comment 13 Pete MacKinnon 2009-06-18 09:34:53 EDT
Created attachment 348453 [details]
IntegerTypes.h.patch
Comment 14 Pete MacKinnon 2009-06-18 09:35:33 EDT
Created attachment 348454 [details]
uuid.h.patch
Comment 15 Pete MacKinnon 2009-06-18 09:36:11 EDT
Created attachment 348455 [details]
uuid.cpp.patch
Comment 16 Pete MacKinnon 2009-06-18 09:45:24 EDT
Created attachment 348464 [details]
protocol_gen.mak.patch
Comment 17 Pete MacKinnon 2009-06-18 09:47:05 EDT
Created attachment 348466 [details]
example_gen.mak.patch
Comment 18 Pete MacKinnon 2009-06-18 09:47:38 EDT
Comment on attachment 348464 [details]
protocol_gen.mak.patch

Added Apache license
Comment 19 Pete MacKinnon 2009-06-18 09:48:24 EDT
Comment on attachment 348464 [details]
protocol_gen.mak.patch

Added Apache license
Comment 20 Pete MacKinnon 2009-06-18 13:22:20 EDT
Now upstream at https://issues.apache.org/jira/browse/QPID-1918
Comment 21 Pete MacKinnon 2009-06-18 13:23:31 EDT
Now upstream at https://issues.apache.org/jira/browse/QPID-1918

Note You need to log in before you can comment on or make changes to this bug.