Bug 506616 - EASYFIX [qemu netboot] Eliminate 3 second delay on PXE boot
EASYFIX [qemu netboot] Eliminate 3 second delay on PXE boot
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: etherboot (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Eduardo Habkost
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11VirtTarget
  Show dependency treegraph
 
Reported: 2009-06-17 20:08 EDT by Warren Togami
Modified: 2009-09-03 08:18 EDT (History)
7 users (show)

See Also:
Fixed In Version: 5.4.4-16.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-03 08:16:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2009-06-17 20:08:18 EDT
Currently if you ask qemu-kvm to netboot, it always delays 3 seconds, unnecessarily asking if you really want to netboot.  This 3 second delay can be eliminated by generating a new Etherboot zrom with the delay configured to a negative value.

http://rom-o-matic.net/etherboot/etherboot-5.4.4/contrib/rom-o-matic/build.php?version=5.4.4&F=&arch=i386&nic=rtl8139%3Artl8139+--+[0x10ec%2C0x8139]&ofmt=Binary+ROM+Image%28.zrom%29&A=Configure

ASK_BOOT=-1 (defaults to 3)

This will generate a new .zrom to replace:
/usr/share/etherboot/rtl8139.zrom
Comment 1 Mark McLoughlin 2009-06-19 12:46:01 EDT
Okay, pushing to updates-testing - please test and update bodhi

* Fri Jun 19 2009 Mark McLoughlin <markmc@redhat.com> - 5.4.4-15
- Disable ASK_BOOT (bug #506616)
Comment 2 Fedora Update System 2009-06-19 12:46:35 EDT
etherboot-5.4.4-15.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/etherboot-5.4.4-15.fc11
Comment 3 Fedora Update System 2009-06-24 15:21:57 EDT
etherboot-5.4.4-15.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update etherboot'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6863
Comment 4 Fedora Update System 2009-06-26 22:58:31 EDT
etherboot-5.4.4-16.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update etherboot'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7024
Comment 5 Fedora Update System 2009-07-02 01:41:53 EDT
etherboot-5.4.4-16.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Warren Togami 2009-08-31 15:54:40 EDT
The F-12 qemu with gPXE seems to have regressed and added two or three separate delays during netboot.

+ qemu-kvm -hda /dev/null -boot n -m 256 -net nic,model=rtl8139 -net tap,script=/usr/sbin/examplebridge-ifup

gPXE (http://etherboot.org) - 00:00.0 C900 PCI2.10 INT19 C900
Press CTRL-B to configure gPXE (PCI 00:00.0)...

*** delay of ~3 seconds ***

Press F12 for boot menu

*** delay of ~2 seconds ***

Press N to skip booting from gPXE (PCI 00:00.1)...

*** delay of ~3 seconds ***

The last prompt, if you press N it seems to skip the delay but it goes ahead and boots via gPXE anyway.  This prompt seems to be both incorrect and also with no purpose.

In these cases, you have requested -boot n so why is it second guessing the user with delays?
Comment 7 Mark McLoughlin 2009-09-03 08:16:18 EDT
Warren, please file a new F-12 bug. Thanks

Note You need to log in before you can comment on or make changes to this bug.