Bug 506617 - RFE: QEMU nesting: Allow nested SVM/VMX to be enabled with KVM/QEMU
RFE: QEMU nesting: Allow nested SVM/VMX to be enabled with KVM/QEMU
Status: CLOSED CURRENTRELEASE
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks: libvirtTodoHV
  Show dependency treegraph
 
Reported: 2009-06-17 20:13 EDT by Aaron Kurtz
Modified: 2011-03-17 10:26 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-17 10:26:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aaron Kurtz 2009-06-17 20:13:59 EDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.11) Gecko/2009060308 Ubuntu/9.04 (jaunty) Firefox/3.0.11

KVM has the ability to emulate AMD's virtualization opcodes, providing SVM to the guest and enabling nested virtualization.

I'd like to be able to enable this feature for libvirt-controlled guests.

Reproducible: Always




from kvm's help:

-enable-nesting enable support for running a VM inside the VM (AMD only)
Comment 1 Daniel Berrange 2009-11-13 06:12:40 EST
There's a thread discussing this upstream

http://www.redhat.com/archives/libvir-list/2009-November/msg00304.html
Comment 2 Daniel Berrange 2010-09-22 08:56:44 EDT
An updated proposal based on the CPU model/features support in guest XML

http://www.redhat.com/archives/libvir-list/2010-September/msg00344.html
Comment 3 Cole Robinson 2011-03-17 10:26:31 EDT
Upstream since september:

http://libvirt.org/git/?p=libvirt.git;a=commit;h=f98a6cd6ae95291e09584d3b8853837934506d45

Note You need to log in before you can comment on or make changes to this bug.