Bug 506651 - un-relevant packages in the Snapshot's Packages sub-tab
un-relevant packages in the Snapshot's Packages sub-tab
Status: CLOSED NOTABUG
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
530
All Linux
medium Severity medium
: ---
: ---
Assigned To: Pradeep Kilambi
Jan Hutař
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-18 01:52 EDT by Jan Hutař
Modified: 2009-06-19 11:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-19 11:16:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2009-06-18 01:52:59 EDT
Description of problem:
I see there completely un-relevant packages (among with relevant "aide") on the Snapshot's Packages sub-tab (On the snapshot's detail page I see correct "Package Manifest: 1 change" - so the summary is OK).


Version-Release number of selected component (if applicable):
Satellite-5.3.0-RHEL5-re20090612.0-x86_64


How reproducible:
always


Steps to Reproduce:
  1. Enable Provisioning
  2. `rhn-profile-sync` and tag last snapshot
  3. Install "aide" through WebUI and `rhn_check`
  4. Ensure "aide" was installed with `rpm -q aide`
  5. Provisioning > Snapshots > tagged snapshot > Packages sub-tab


Actual results:
Package Current Version  Snapshot Version Difference
aide  0.13.1-2.0.4.el5  -   Current profile only 
curl  7.15.5-2.el5   7.15.5-2.1.el5_3.4  Snapshot newer 
file  4.17-15   4.17-15.el5_3.1  Snapshot newer 
pango  1.14.9-3.el5   1.14.9-5.el5_3   Snapshot newer


Expected results:
Package Current Version  Snapshot Version Difference
aide  0.13.1-2.0.4.el5  -   Current profile only


Additional info:
Sorry, I'm not able to reproduce this any more. Could the relevant code be slightly checked as I have seen this 2 or 3 times yesterday?
Comment 1 Brandon Perkins 2009-06-18 10:50:07 EDT
Prad, can you take a look at this and see if there is anything obvious before we approve or deny this bug.

Note You need to log in before you can comment on or make changes to this bug.