Bug 506656 - X11/extensions/XTest.h cannot be included
X11/extensions/XTest.h cannot be included
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-proto-devel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
: 507328 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-18 03:48 EDT by Mamoru TASAKA
Modified: 2009-07-22 16:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-22 16:11:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mamoru TASAKA 2009-06-18 03:48:08 EDT
Description of problem:
Compiling the following code:
----------------------------------------------------
#include <stdio.h>
#include <X11/extensions/XTest.h>

int foo(void){
	return XTestQueryExtension(NULL, NULL, NULL, NULL, NULL);
}
----------------------------------------------------
fails like:
$ LANG=C gcc -c test.c -Wall 
In file included from test.c:2:
/usr/include/X11/extensions/XTest.h:50:35: error: X11/extensions/XInput.h: No such file or directory
In file included from test.c:2:
/usr/include/X11/extensions/XTest.h:54: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'XTestQueryExtension'
/usr/include/X11/extensions/XTest.h:62: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'XTestCompareCursorWithWindow'
/usr/include/X11/extensions/XTest.h:68: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'XTestCompareCurrentCursorWithWindow'
/usr/include/X11/extensions/XTest.h:74: error: expected ')' before '*' token
/usr/include/X11/extensions/XTest.h:81: error: expected ')' before '*' token
/usr/include/X11/extensions/XTest.h:88: error: expected ')' before '*' token
/usr/include/X11/extensions/XTest.h:96: error: expected ')' before '*' token
/usr/include/X11/extensions/XTest.h:103: error: expected ')' before '*' token
/usr/include/X11/extensions/XTest.h:113: error: expected ')' before '*' token
/usr/include/X11/extensions/XTest.h:123: error: expected ')' before '*' token
/usr/include/X11/extensions/XTest.h:132: error: expected ')' before '*' token
/usr/include/X11/extensions/XTest.h:142: error: expected ')' before '*' token
/usr/include/X11/extensions/XTest.h:152: error: expected ')' before '*' token
/usr/include/X11/extensions/XTest.h:156: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'XTestDiscard'
test.c: In function 'foo':
test.c:5: warning: implicit declaration of function 'XTestQueryExtension'

Version-Release number of selected component (if applicable):
xorg-x11-proto-devel-7.4-17.fc12.noarch

How reproducible:
100%

Steps to Reproduce:
1. See above
2.
3.
  
Actual results:
With -17.fc12 this does not compile.

Expected results:
With -15.fc12 this compiles.
Comment 1 Rex Dieter 2009-06-18 23:44:24 EDT
confirmed, induces build failures, ie,
http://koji.fedoraproject.org/koji/buildinfo?buildID=107008
Comment 2 Rex Dieter 2009-06-22 09:54:04 EDT
*** Bug 507328 has been marked as a duplicate of this bug. ***
Comment 3 Rex Dieter 2009-06-22 09:57:40 EDT
According to,
https://www.redhat.com/archives/fedora-devel-list/2009-June/msg01764.html

XInput.h has moved from xorg-x11-proto-devel to libXi, so shouldn't

xorg-x11-proto-devel
Requires: libXi-devel
?

Or is something else expected?
Comment 4 Rex Dieter 2009-06-22 11:06:20 EDT
My previous kdebase-workspace build failure now ran to completion, but I'm explicitly pulling in libXi-devel somewhere (via qt-devel), so I'm not sure if *this* particular issue is addressed yet or not.
Comment 5 Adam Jackson 2009-07-22 16:11:48 EDT
This should be fixed in rawhide now.  That these headers were ever in -proto-devel at all was a mistake.

Note You need to log in before you can comment on or make changes to this bug.