Bug 506664 - On installation from kickstart, the postinstallation doesn't show what actually happens on console
On installation from kickstart, the postinstallation doesn't show what actual...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Martin Sivák
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-18 04:37 EDT by stef
Modified: 2010-02-23 14:03 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-23 14:03:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Postscript's output on tty3 (16.68 KB, image/png)
2009-06-30 08:15 EDT, Martin Sivák
no flags Details
my kickstart file (7.37 KB, application/octet-stream)
2009-06-30 08:26 EDT, stef
no flags Details

  None (edit)
Description stef 2009-06-18 04:37:20 EDT
Description of problem:
When installating from kickstart with a %post section, the postinstallation procedure doesn't show what actually happens on console 3 (Alt-F3 during install), so you don't know if you're doing things right of if an error happens.
This makes difficult the the kickstart conception and the errors tracking.

Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:
1.install from kickstart with a %post section
2.go to console 3 (Alt-F3)
3.
  
Actual results:

Show only a message "running %%post script"

Expected results:

Show only a message "running %%post script" and the complete console messages during the execution

Additional info:
Comment 1 Chris Lumens 2009-06-29 13:43:18 EDT
These scripts are run through execWithRedirect, and should be directing all their output to /dev/tty3 unless you say otherwise.  I believe Dave was the last person to touch this code, but he's pretty swamped with storage bugs again/still at the moment.  Picking someone at random...
Comment 2 Martin Sivák 2009-06-30 08:15:42 EDT
Created attachment 349943 [details]
Postscript's output on tty3

Hi, I can see all output from the postscript on 3rd console. It seems that it isn't line buffered (text was printed only after I sent data to the stdin test command) but the output on stdout and stderr is clearly there.

Is it possible you have --log argument specified for your %post section? Or if you had used serial console, then the output went to the log also. In other cases you should see everything on the tty3.

Can you post the kickstart in question please?
Comment 3 stef 2009-06-30 08:26:50 EDT
Created attachment 349944 [details]
my kickstart file
Comment 4 stef 2009-06-30 08:27:41 EDT
(In reply to comment #2)
Well, I can see the output, but only at the end of the %post being processed, so it gives a huge load of text at a time instead giving it during the progression.

I upload the kickstart too
Comment 5 Martin Sivák 2009-06-30 09:07:31 EDT
Ah I see now, yeah as I said it isn't line buffered. Can you test it with updates image from http://msivak.fedorapeople.org/anaconda/exec2.img please? Just append

updates=http://msivak.fedorapeople.org/anaconda/exec2.img

to the kernel command line. It should fix it (it does on my test machine). If it does for you too, I'll integrate it into the main source.
Comment 6 stef 2009-06-30 10:23:15 EDT
(In reply to comment #5)
I just tested, I finally got the output displayed as the %post steps moves on.
It's good for me.

BTW, could you have a look on the Bug 506663 since it is also related to the %post part of the kickstart install (different problem though).
Comment 8 Martin Sivák 2009-08-21 09:02:05 EDT
We had to update the patch to keep it to log the output of kickstart tasks. It will be included as soon as I got it reviewed.
Comment 9 Martin Sivák 2009-08-26 08:33:58 EDT
Ok patch is commited, it will shhow up in next anaconda build (12.17)

Note You need to log in before you can comment on or make changes to this bug.