Bug 506692 - Crash when closing tab with Java remote management applet
Crash when closing tab with Java remote management applet
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
: 542763 548737 548741 554955 569068 569291 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-18 07:44 EDT by Jakub Hrozek
Modified: 2010-03-05 10:00 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-19 09:20:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Core file (10.22 MB, application/x-bzip2)
2009-06-18 07:44 EDT, Jakub Hrozek
no flags Details
complete backtrace (14.09 KB, text/plain)
2009-06-18 16:24 EDT, Matěj Cepl
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 499295 None None None Never

  None (edit)
Description Jakub Hrozek 2009-06-18 07:44:57 EDT
Created attachment 348417 [details]
Core file

Description of problem:
When I close a tab containing an IBM server remote management applet, firefox segfaults.

This may be specific to the particular applet as I tested some tests applets at sun.com and FF did survive..but anyway, it shouldn't crash.

Core file is attached.

Version-Release number of selected component (if applicable):
firefox-3.5-0.20.beta4.fc11.x86_64
xulrunner-1.9.1-0.20.beta4.fc11.x86_64
nspluginwrapper-1.3.0-5.fc11.x86_64
java-1.6.0-openjdk-1.6.0.0-22.b16.fc11.x86_64
java-1.6.0-openjdk-plugin-1.6.0.0-22.b16.fc11.x86_64


How reproducible:
always

Steps to Reproduce:
1. login into the IBM remote server web tool
2. use their applet
3. close the tab with the applet
4. Kaboooom
  
Actual results:
crash

Expected results:
no crash

Additional info:
did not happen in F10, so I suspect it's actually a regression in Firefox.
Comment 1 Matěj Cepl 2009-06-18 16:24:14 EDT
Created attachment 348553 [details]
complete backtrace
Comment 2 Martin Stransky 2009-06-19 03:14:39 EDT
It's here:

rv = mOwner->GetDocument(getter_AddRefs(document));

so i suppose the mOwner is null or some bogus value. Matej, can you attach the mOwner value and some extended bactrace with local variables?
Comment 3 Matěj Cepl 2009-06-19 07:20:21 EDT
That's better answered by Jakub ... I have never seen that IBM Java thing in my life.
Comment 4 Jakub Hrozek 2009-06-19 07:39:20 EDT
The mOwner value indeed is NULL:

---
805	  rv = mOwner->GetDocument(getter_AddRefs(document));
(gdb) print mOwner
$1 = (class nsIPluginInstanceOwner *) 0x0
---
Comment 5 Matěj Cepl 2009-06-19 09:20:10 EDT
We filed this bug in the upstream database (https://bugzilla.mozilla.org/show_bug.cgi?id=499295) and believe that it is more appropriate to let it be resolved upstream.

We will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

Thank you for the bug report.
Comment 6 Matěj Cepl 2009-12-09 20:07:49 EST
*** Bug 542763 has been marked as a duplicate of this bug. ***
Comment 7 Chris Campbell 2009-12-18 09:59:48 EST
*** Bug 548737 has been marked as a duplicate of this bug. ***
Comment 8 Chris Campbell 2009-12-18 10:01:00 EST
*** Bug 548741 has been marked as a duplicate of this bug. ***
Comment 9 Chris Campbell 2010-01-13 07:49:53 EST
*** Bug 554955 has been marked as a duplicate of this bug. ***
Comment 10 Chris Campbell 2010-03-02 14:25:59 EST
*** Bug 569291 has been marked as a duplicate of this bug. ***
Comment 11 Chris Campbell 2010-03-05 10:00:16 EST
*** Bug 569068 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.