Bug 506706 - mkinitrd:daemonize --ignore-missing /bin/plymouthd in init script silences console
mkinitrd:daemonize --ignore-missing /bin/plymouthd in init script silences co...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-18 08:46 EDT by Stefan Assmann
Modified: 2009-06-22 10:26 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-22 10:26:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Assmann 2009-06-18 08:46:44 EDT
Description of problem:
While I tried to boot F11 without an initrd and couldn't get that to work I tried to boot a custom kernel with the default initrd of my system and noticed the following:

part of the init script from initrd:
mknod /dev/ttyS0 c 4 64
mknod /dev/ttyS1 c 4 65
mknod /dev/ttyS2 c 4 66
mknod /dev/ttyS3 c 4 67
daemonize --ignore-missing /bin/plymouthd
echo "Loading output module"
modprobe -q output
echo "Loading video module"

everything that gets echoed after the daemonize --ignore-missing /bin/plymouthd command won't appear on the console. There's no message Loading output module or Loading video module displayed for example. By putting some more echo's in there I figured that this is caused by the daemonize command. I replaced daemonize --ignore-missing /bin/plymouthd with /bin/plymouthd and afterwards all ongoing messages will be displayed again.

Now I can guess what daemonize is supposed to do however maybe someone could clarify why this is needed and what is the host for this program. I couldn't find it in the initrd. :)

Sorry I'm not that familiar with the whole initrd stuff on Fedora yet. TIA!

Version-Release number of selected component (if applicable):
mkinitrd-6.0.86-2.fc11.x86_64

How reproducible:
always

Steps to Reproduce:
1. check log during boot and see that for example "Loading <yourmodule> module" is not displayed.

Actual results:
lot of boot messages are missing

Expected results:
boot messages are displayed on console

Additional info:
Comment 1 Peter Jones 2009-06-22 10:26:47 EDT
This is the expected behavior of that command; it redirects to /var/log/boot.log .  Hitting escape after this should bring it back to the console as well.

Note You need to log in before you can comment on or make changes to this bug.