Bug 506711 - Request to make a non-typical install easier
Request to make a non-typical install easier
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-18 09:01 EDT by Piotr Piotrowski
Modified: 2009-06-30 06:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-18 11:23:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Piotr Piotrowski 2009-06-18 09:01:01 EDT
User-Agent:       Mozilla/5.0 (compatible; Konqueror/4.2; Linux) KHTML/4.2.3 (like Gecko) Fedora/4.2.3-3.fc11

At present to perform an install that is not typical, one has to know in advance what options can be entered during the install startup (after hiting tab) and remember to actually enter them. Could there be some visible option "advanced install" with the first screen of such an install being a list of all the options with checkboxes or something similar?

Making typical install easier does not mean a more advanced install has to be harder.

Reproducible: Always
Comment 1 Andy Lindeberg 2009-06-18 11:23:22 EDT
The options that can be entered on the boot line are well documented on the wiki.
Comment 2 Piotr Piotrowski 2009-06-19 09:37:40 EDT
I am not talking about documentation! I am talking about userfriendlyness!

You have already exposed the vesa option, which is good. I needed that option several years ago. This time I no longer needed vesa but required askmethod, which in the past was included in the standard install process. Who knows what I will need in a years time?

Why not go one step further then exposing a single arbitrary option and give a screen with a selection of options?
Comment 3 Peter Jones 2009-06-19 09:55:40 EDT
This request just isn't practical at all -- there are a very large number of options you can type there, and combinations thereof; there's no possible way to do a pre-set boot option for all of them.

This really is a documentation issue, and not something that can realistically be solved in the UI.
Comment 4 Piotr Piotrowski 2009-06-19 10:19:14 EDT
I do realize that squeezing *all* advanced options is unrealistic. However I could as well ask why vesa? Why not askmethod or anything else? I am sure there is a bunch of options which is fairly often used. As it is now there is even no longer any help on the boot screen. As far as I remeber there was such a thing and was accessed with F1 or something like that. If you can not put every option on the screen at least put some that are considered to be used most often. In my opinion that would make the process a little more userfriendly for not entirely typical install. In my opinion lately the non-typical install process is getting more and more irksome.
Comment 5 Chris Lumens 2009-06-29 15:14:11 EDT
(1) We should be moving towards not needing these special options.  Often times if one is required, that means there's a bug somewhere.  For example, the "vesa" option is likely indicative of busted video drivers.  We need to be exposing these problems and getting them worked on, instead of providing easy ways to work around the bugs that means they will never really get fixed.

(2) Many of these options are really kernel options, and as such cannot be prompted for until well after it's too late.  Some of the anaconda options fall into the same boat.  It's too late to prompt for "nomodeset" once anaconda's up and running, for instance.  So where's this code going to go?  Are we going to require multiple screens in multiple places to prompt for the options that can take effect ay different times?

As much as you may not like to believe it, this really is a documentation problem.  We do a good job of keeping the list of options on the wiki up to date, but it doesn't sound like it's getting enough publicity.
Comment 6 Piotr Piotrowski 2009-06-30 06:38:13 EDT
If there were only kernel options and using them would indicate bugs, then I would totaly agree. However, that is not true. In fact there are different kinds of options there and some (those are actually the ones that are of interest to me) represent user's choice regarding the install process. Those options are: askmethod, ext4migrate, ip=, lang=, repo=, updates=, etc. Some of the options are included in some screens of the install process (lang) others are not (askmethod). Some of these options are hidden, because they are exprerimental and I can accept that. What I meant from the begining was that in my opionion it would be better if all those "decision" options where accessible from the installer. The installation process changes form version to version and I no longer know what I will be asked for and what decisions are made for me. I agree there should be the possibility to just click next and have Fedora installed, but I would be greatful for an advanced button that would give me more control over the install process while being easy to use.

There are applications that have great documentation, but are nevertheless hard to use and there are applications where no or little documentation is needed due to well designed user interface. More over it is not true that powerful applications need to have hard to use user interfaces. Therefore I would still argue its an interface not documentation thing. While upgrading to F11 I required the askmethod option. I knew all about it, because I used it when upgrading to F10. Unfortunately when it came to installing I just forgot about it and relized when it was too late. No documentation would help, interface would. If you consider this a problem with my memory rather then with anaconda, then fine. I just thought adding advanced button would help (not only me) - I like when applications give easy access to some more advanced features.

Note You need to log in before you can comment on or make changes to this bug.