Bug 506749 - RFE: add essential character devices for booting without initrd to rootfs
RFE: add essential character devices for booting without initrd to rootfs
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-18 11:02 EDT by Stefan Assmann
Modified: 2009-06-18 11:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-18 11:32:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Assmann 2009-06-18 11:02:51 EDT
Description of problem:
Hi guys, I tried to figure out why I can't boot F11 with only a plain kernel, specifying the root= parameter. In the end it turned out to be missing /dev/null and /dev/console on the root partition.

Could we add these please during the installation? It's a mere
mknod /dev/null c 1 3
mknod /dev/console c 5 1

The benefit would be to compile whatever kernel you like without the need of creating an initrd and just boot your system with it. Quick testing of vanilla kernels for example is what comes to my mind.

Another thing would be to just run an init=/bin/bash without an initrd which currently is impossible because of the missing char devs.

I'm not exactly sure which component I should assign this to, please feel free to move to the appropriate place.

TIA :)
Comment 1 Jeremy Katz 2009-06-18 11:32:34 EDT
And when the set of required devices changes?

We only support booting if you have an initramfs.  If you want to boot without one, you're already building your own kernels and installing them by hand so having you create a few device nodes really isn't a big deal.  Especially as if you build with the sort of stock initramfs stuff in the kernel, they actually get created for you.
Comment 2 Stefan Assmann 2009-06-18 11:45:18 EDT
Hi Jeremy,

do you see any harm from doing this? If so I'd really like to know. So far I haven't figured out how I can build an initrd from for example a vanilla kernel git repository. So the only way I know so far would be to make a modules install to install all modules under /lib/modules/ and thereby polluting that directory. Afterwards I could generate an initrd.

I wouldn't have to do that if I could just boot the kernel w/o the initrd. Maybe you can help me understanding what's so bad about that. :)

Note You need to log in before you can comment on or make changes to this bug.