Bug 506750 - F9->F11 upgrades are supported
F9->F11 upgrades are supported
Status: CLOSED NEXTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: install-guide (Show other bugs)
devel
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Nalley
David Nalley
:
: 522241 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-18 11:03 EDT by Michal Schmidt
Modified: 2009-09-09 20:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 522241 (view as bug list)
Environment:
Last Closed: 2009-06-18 18:42:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Schmidt 2009-06-18 11:03:45 EDT
Description of problem:

The Installation Guide is wrong about upgrading from F9 to F11.
In http://docs.fedoraproject.org/install-guide/f11/en-US/html/ch-upgrade-x86.html it says:

Important
It is not possible to upgrade directly from Fedora 9 to Fedora 11. To upgrade Fedora 9 to Fedora 11, upgrade to Fedora 10 first. 

This is simply not true. Upgrading from F9 to F11 using Anaconda or using preupgrade is supported and works (I've checked using preupgrade myself).
It is only required to upgrade to F10 first when using the unsupported live yum upgrade method.


I confirmed this today on #fedora-devel:
<michich> Does anyone know the reason why "It is not possible to upgrade directly from Fedora 9 to Fedora 11."? (source: http://docs.fedoraproject.org/install-guide/f11/en-US/html/ch-upgrade-x86.html) Notice that the guide talks about upgrades using Anaconda, not live yum upgrades where such a requirement is understandable.
<dgilmore> michich: rpm incompatabilities
<dgilmore> michich: F-11 uses stronger hashes than F-9  and the F-9 rpm does not support the new sha256sum hases
<michich> dgilmore, preupgrade F9->F11 worked fine for me. Why?
<dgilmore> michich: anaconda upgrades use the new rpm
<michich> dgilmore, indeed, so it is supposed to work, right?
<geppetto> dgilmore: but that's just a problem for live yum upgrades
<dgilmore> geppetto: right whihc is what i said
<dgilmore> looks like the docs is not quite correct
<dgilmore> geppetto: well what i meant
<michich> dgilmore, that's why I said "Notice that the guide talks about upgrades using Anaconda"
<dgilmore> michich: the guide is wrong
<michich> thanks for confirming my suspicion
<dgilmore> michich: unless im wrong for some reason
<dgilmore> but AFAIK using anaconda based updates from F-9 to F-11 is perfectly supported
<michich> I'll file a BZ against the Install guide
<dgilmore> for yum upgrades you need to at the least install F-10's rpm from the updates repo
<michich> that's exactly how I understand it as well
Comment 1 Ruediger Landmann 2009-06-18 18:42:57 EDT
Thanks for the catch. This will be gone in the next revision of the guide.
Comment 2 Paul Jakma 2009-06-21 05:02:07 EDT
Another method:

- install the F10 fedora-release (and its single dependency)
- yum update rpm (to get the F10 rpm, which is compatible with F11 upgrade)
- rpm --rebuilddb (not sure if this step is required, but I did it just in case)
- now update fedora-release to F11
- yum upgrade

EWORKEDFORME
Comment 3 Michal Schmidt 2009-06-21 06:28:53 EDT
Paul,

this is interesting, you may want to update the wiki page http://fedoraproject.org/wiki/YumUpgradeFaq with this useful information.

However, live yum upgrades are not recommended by most Fedora developers, so this method should not be relevant for the Installation Guide.
Comment 4 Ruediger Landmann 2009-09-09 20:09:47 EDT
*** Bug 522241 has been marked as a duplicate of this bug. ***
Comment 5 Christopher Beland 2009-09-09 20:38:22 EDT
Out of curiosity, will the revised documentation be re-released before Fedora 12 comes out?

Note You need to log in before you can comment on or make changes to this bug.