Bug 506783 - Slow upgrades of IPA clients using DVD (local) medium
Slow upgrades of IPA clients using DVD (local) medium
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-18 12:33 EDT by Thomas Sailer
Modified: 2009-06-29 12:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-29 11:25:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Sailer 2009-06-18 12:33:52 EDT
Description of problem:
IPA clients usually configure nsswitch to also contact remote databases (using ldap, for example) for user/group information.

anaconda does not configure networking when using local media.

Now, user/group lookups (eg. getent calls in the udev preinstall scriptlet), take a long time, since the network is unreachable.

Configuring network significantly speeds up installation.
Comment 1 Chris Lumens 2009-06-29 11:25:17 EDT
You can use the asknetwork parameter to force anaconda to configure your network before the upgrade really begins.  Aside from that, there's nothing really we can do to help.  We aren't going to know when to bring up the network on demand, and we don't want to ask to bring it up every time on upgrades just in case.
Comment 2 Thomas Sailer 2009-06-29 12:01:47 EDT
Thanks for the tip about asknetwork.

What you could do is look at /etc/nsswitch.conf, and set up networking if either passwd, shadow or group contains ldap (or possibly nis or nisplus).

BTW is there going to be an anaconda update? The reason I used the DVD to update the IPA client is because I tried using koan/cobbler, but anaconda did not find the fedora partitions. When running anaconda from the DVD, it finds the fedora partitions.

Note You need to log in before you can comment on or make changes to this bug.