Bug 506787 - why do you change the dist tag to el5_3
why do you change the dist tag to el5_3
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: giflib (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Norm Murray
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-18 12:45 EDT by Levente Farkas
Modified: 2009-06-22 01:03 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-22 01:03:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Levente Farkas 2009-06-18 12:45:17 EDT
there is a package called giflib-4.1.3-7.1.el5.1.src.rpm in 5.3 while there is another in updates caleed giflib-4.1.3-7.1.el5_3.1.src.rpm. why? why do you choose to set the dist tag in stead of the increase the release as it used to be in most case to giflib-4.1.3-7.1.el5.2.src.rpm? it cause a lot's of problem. eg if someone like to rebuild the src.rpm and use the standard .el5 dist tag then both the base and the updates pacakges will have the same version since in the spec file you do not increase or any way modify the release tag it's just a build environment changes.
anyway unfortunately this's not the only package which use the same dirty trick:-(
Comment 1 Norm Murray 2009-06-22 01:03:49 EDT
This is simply standard naming policy for packages released outside of a regular update - i.e. this, which was a security errata. This helps to ensure easy identification of when/where a package was built in the lifetime of a Red Hat Enterprise Linux release lifetime, as well as to ensure that you can always update to the latest built package.

Note You need to log in before you can comment on or make changes to this bug.