Bug 506795 - numactl not working on systems with non-sequential node numbering, upstream ok
numactl not working on systems with non-sequential node numbering, upstream ok
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: numactl (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Neil Horman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-18 13:06 EDT by Erik Jacobson
Modified: 2009-07-02 01:52 EDT (History)
2 users (show)

See Also:
Fixed In Version: 2.0.3-1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-02 01:52:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Erik Jacobson 2009-06-18 13:06:45 EDT
Some multi-socket Intel 5500 / Nehalem systems do not number nodes sequentially
in Fedora11.  This is a separate bug and I will be either filing ensuring one
exists on this.  The issue has an upstream kernel patch.

However, regardless of this, numactl shouldn't tip over like it does in this
situation:

# numactl --hardware
available: 3 nodes (0-2)
node 0 cpus: 0 1 2 3 4 5 6 7
node 0 size: 4087 MB
node 0 free: 3591 MB
libnuma: Warning: /sys not mounted or invalid. Assuming one node: No such file or directory
node 1 cpus:
node 1 size: <not available>
node 1 free: <not available>
node 2 cpus:
node 2 size: 4096 MB
node 2 free: 3962 MB
No distance information available.


# ls -ld /sys/devices/system/node/node*
drwxr-xr-x 2 root root 0 2009-06-18 09:30 /sys/devices/system/node/node0
drwxr-xr-x 2 root root 0 2009-06-18 09:30 /sys/devices/system/node/node2

Cliff Wickman has confirmed this is fixed upstream.  It can be found here:

ftp://oss.sgi.com/www/projects/libnuma/download/numactl-2.0.3.tar.gz

Cliff built the latest numactl and ran it as so and confirmed it fixed the
issue:

# ./numactl --hardware
available: 2 nodes (0,2)
cpw: hardware: bit 0: 1
node 0 cpus: 0 1 2 3 4 5 6 7
node 0 size: 4087 MB
node 0 free: 3588 MB
cpw: hardware: bit 1: 0
cpw: hardware: bit 2: 1
node 2 cpus:
node 2 size: 4096 MB
node 2 free: 3962 MB
node distances:
node   0   1   2 
  0:  10   0  20 
  1:   0   0   0 
  2:  20   0  10 

This is related to existing BZs 499633 506590 996252
Comment 1 Erik Jacobson 2009-06-18 13:45:41 EDT
Existing versions:
kernel-2.6.29.4-167.fc11.x86_64
numactl-2.0.2-4.fc11.x86_64
Comment 2 Neil Horman 2009-06-26 11:50:11 EDT
I've updated rawhide to the latest numactl upstream release (2.0.3).  Could you please confirm that that package solves your issues?  If so, I'll port it to F11, and send out an update.  Thanks!
Comment 3 Neil Horman 2009-06-26 12:10:59 EDT
sorry, that should be numactl-2.0.4-4.fc12
Comment 4 Erik Jacobson 2009-06-26 15:33:31 EDT
I've checked all the mirrors including download.fedora.redhat.com and
everything seems to be at numactl-2.0.3-2.fc12.x86_64.rpm.

I'll keep waiting but if you have a means to point me where this file might reside, I can test it today.

ps I'm not sure how the RHEL/Fedora tie-in works, but this might also address
464625.
Comment 6 Erik Jacobson 2009-06-26 16:37:51 EDT
I'm assuming 2.0.4 is a typo and will test with 2.0.3.  I checked our OSS web
site and the latest is 2.0.3.  

I pulled down numactl-2.0.3-2.fc12.x86_64.rpm and ran the test.  Looks good!

BEFORE
[root@cct201 ~]# numactl --hardware
available: 3 nodes (0-2)
node 0 cpus: 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
node 0 size: 4087 MB
node 0 free: 3292 MB
libnuma: Warning: /sys not mounted or invalid. Assuming one node: No such file or directory
node 1 cpus:
node 1 size: <not available>
node 1 free: <not available>
node 2 cpus:
node 2 size: 4096 MB
node 2 free: 3962 MB
No distance information available.


AFTER

[root@cct201 ~]# numactl --hardware
available: 2 nodes (0,2)
node 0 cpus: 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
node 0 size: 4087 MB
node 0 free: 3289 MB
node 2 cpus:
node 2 size: 4096 MB
node 2 free: 3962 MB
node distances:
node   0   1   2 
  0:  10   0  20 
  1:   0   0   0 
  2:  20   0  10 
[root@cct201 ~]# rpm -q numactl
numactl-2.0.3-2.fc12.x86_64
Comment 7 Erik Jacobson 2009-06-26 16:38:42 EDT
PS: Yes, tested version matches koji link. thanks!
Comment 8 Fedora Update System 2009-06-29 12:04:29 EDT
numactl-2.0.3-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/numactl-2.0.3-2.fc10
Comment 9 Fedora Update System 2009-06-29 13:03:44 EDT
numactl-2.0.3-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/numactl-2.0.3-1.fc11
Comment 10 Fedora Update System 2009-07-02 01:44:54 EDT
numactl-2.0.3-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2009-07-02 01:52:22 EDT
numactl-2.0.3-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.